DANIELSKI Sep 29, 2013 @ 11:14am
Random lag issues?
I had this game before on the same PC and it ran great very smooth, once i bought it on steam it tuened into crap, at the menu it lags when i move my mouse over the icons and in game it lags when i move or rotate the camera, I do not need to post my specs because it exceeds the requirments. If someone could help that would be great.
Showing 1-4 of 4 comments
< >
Crazed Possum Sep 29, 2013 @ 11:30am 
it's your AMD radeon catalyst drivers bevleive it or not u will need to back date them . look through the threads here because i don't remember what drivers they were.
DANIELSKI Sep 29, 2013 @ 12:20pm 
Originally posted by Crazed Possum:
it's your AMD radeon catalyst drivers bevleive it or not u will need to back date them . look through the threads here because i don't remember what drivers they were.

Thank you so much , i havent done that yet but that must be the issue because i did update them.
Butros Sep 29, 2013 @ 3:41pm 
There has got to be another way than back dating. I too have been struggling with this issue.
DANIELSKI Sep 29, 2013 @ 4:38pm 
Originally posted by Butros:
There has got to be another way than back dating. I too have been struggling with this issue.
It is easy i found out how, type driver manager in windows search, the nwhen it opens go to display driver or whatever it might be called , click on your GPU card , then go through the tabs and there will be an option " roll back driver" or something like that and click it then reboot. :)
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Sep 29, 2013 @ 11:14am
Posts: 4