Lana Del Hanks Sep 22, 2013 @ 2:48pm
I get stuttering every other second. Please help!
I can't play because every other second my game stutters.

Specs:
AMD FX-6300
HD RADEON 6770
4GB DDR3 RAM
Showing 1-15 of 110 comments
< >
Razor Sep 22, 2013 @ 2:58pm 
The same is happening to me
Lana Del Hanks Sep 22, 2013 @ 3:00pm 
If it helps, my catalyst driver version is 13.9, I'm going to try 13.10 beta and see if it helps.
Sven Hungspeäre Sep 22, 2013 @ 3:33pm 
If you have a lot of stuff in your park your game begins to stutter
Apostulator Sep 22, 2013 @ 3:41pm 
Are you letting the game adjust your screen-resolution and graphics quality?
Or are you going in and setting it to 1920X1080 and everything to supermax?
Razor Sep 22, 2013 @ 3:45pm 
Actually, if I just watch my park in the camera tutorial, everything is fine. The stuttering occurs only once I start moving my mouse. The same stuttering occurs even in the menus, but its more noticeable in-game where trees stop swaying and people stop walking,
Apostulator Sep 22, 2013 @ 3:49pm 
Try dialing-down your screen resolution and graphics-quality settings.
You don't need to match your aspect ratio; you can switch between 4:3, 15:9, 16:9 - things will just distort a little -- switch back to 1024X768 just for a test, then open your world and see about the stuttering. dial down those graphics settings too for a test.
Razor Sep 22, 2013 @ 4:11pm 
Well I went into custom settings, set everything to the lowest settings with a 800x600 resolution, but still the same result.
Lana Del Hanks Sep 22, 2013 @ 4:14pm 
Yeah I put everything at low and same thing, and the same thing happens in the menus.
Apostulator Sep 22, 2013 @ 4:15pm 
Razor, do you currently run any other high-end games with-out frame-rate issues? Say, Skyrim, for instance?
Last edited by Apostulator; Sep 22, 2013 @ 4:17pm
hellot1M Sep 22, 2013 @ 4:59pm 
i am having these same exact issues. my specs are much better and yet the game makes it seem like i dont have enough. i cant even turn my res past 900. i read a few years back that old games will act like this on over powered PCs.

and people have you looked at his specs? why are you asking such strang questions? its like asking a basketball player if he knows how to play basketball... lol
Lana Del Hanks Sep 22, 2013 @ 5:02pm 
I updated my drivers to 13.10 and still the same problem. I really want a fix for this, RCT3 was one of my favorite games back in the day.
Anokh Sep 22, 2013 @ 5:20pm 
Same thing for me even on the main menu. It's at 100 FPS, but when I move my mouse it drops to 3-6 FPS. Running on AMD A-10 5800K and a Radeon HD 7750.
Klayman Sep 22, 2013 @ 5:35pm 
Me too I got hd6850 and it lags xD
Apostulator Sep 22, 2013 @ 5:37pm 
Originally posted by hellot1M:
i read a few years back that old games will act like this on over powered PCs.

This may be a clue to some peoples problems then...

Last edited by Apostulator; Sep 22, 2013 @ 5:41pm
Razor Sep 22, 2013 @ 5:43pm 

Originally posted by Apostulator:
Originally posted by hellot1M:
i read a few years back that old games will act like this on over powered PCs.

This may be a clue to some peoples problems then...

I just wish there were a fix for this.
Showing 1-15 of 110 comments
< >
Per page: 15 30 50