PandoxUniverse Sep 22, 2013 @ 10:48am
Rollercoaster Tycoon 3 Platinum doesnt work!
I realy need help! I just installed Rollercoaster Tycoon 3, but it doesnt work! I have Windows 7 Home Premium 64-bit. Pls help!!!
Showing 1-13 of 13 comments
< >
will.j.savage Sep 22, 2013 @ 10:59am 
Same problem here, have checked driver version (most currant) tried running in Xp mode and ever tried runnning with my desktop res at 800 x 600. Still wont run :(
Spicy rotted Kitten! Sep 22, 2013 @ 11:13am 
which version of WIndows do you have Will ?
will.j.savage Sep 22, 2013 @ 12:23pm 
I have windows 7 Home premium 64 bit. However i think the prolem lies with my radeon Hd5700 video card. It seems the game doesnt like it (same with a few other people on these forums)
TOG | Zalzany Sep 22, 2013 @ 1:22pm 
Just got it, confirmed it works with my nvida with no compatiblty mode used.
PandoxUniverse Sep 23, 2013 @ 9:55am 
ok i fixed it
PandoxUniverse Sep 23, 2013 @ 9:56am 
dont really know how but nur its running without problems
KnightsOfBlood`BabyM Sep 23, 2013 @ 10:14pm 
man h ow do u do it
PandoxUniverse Sep 24, 2013 @ 6:58am 
i dunno
Spicy rotted Kitten! Sep 24, 2013 @ 3:37pm 
Still the same crap on my end, formated from Win7 X64 to Win8.1 X64 and the problem is still there. I think there is an issue with the ATI cards as I have a 7870, and a lot of people complaining on the web are ATI users.
Spicy rotted Kitten! Sep 24, 2013 @ 3:53pm 
Fixed it by installing 13.4 ATI drivers, works smoothly now !
tatschke Oct 1, 2013 @ 5:29am 
doesnt work with 13.9 drivers?
Spicy rotted Kitten! Oct 1, 2013 @ 9:07am 
13.4
BH.Amai Cupcake Oct 2, 2013 @ 8:40pm 
Update drivers works :D. I have windows 7 premium 64bit operating system works smoothly
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Sep 22, 2013 @ 10:48am
Posts: 13