Sentient Lightbulb Jul 28, 2013 @ 7:06am
RCT3 Won't run on my windows 8
During the summer sale I bought RCT3 but it won't run, I have tried every compatibility pack and ran it as an administrator but it won't work, it doesn't even lauch with the compatibility and it crashes instantly without. Please help!
Showing 1-9 of 9 comments
< >
Munsu Aug 8, 2013 @ 1:03pm 
The same :/
amd133mhz Aug 11, 2013 @ 8:18am 
I had the same issue and what I did to fix it was I ran STEAM not RCT3 in windows 7 compat mode , you have to actuaLLY RUN THE steam.exe LAUNCHER IN windows 7 mode and that seemed to work for me. nothing I did to the rct3.exe file ITSELF did anything i had to actually run STEAM in windows 7 mode.
Sentient Lightbulb Aug 11, 2013 @ 8:42am 
Originally posted by amd133mhz:
I had the same issue and what I did to fix it was I ran STEAM not RCT3 in windows 7 compat mode , you have to actuaLLY RUN THE steam.exe LAUNCHER IN windows 7 mode and that seemed to work for me. nothing I did to the rct3.exe file ITSELF did anything i had to actually run STEAM in windows 7 mode.
I did do that but it still didn't work
amd133mhz Aug 13, 2013 @ 10:03pm 
Yea actually mine isnt even loading now it just says it's already running. %&!#$ windows 8! Ive tried deleting appcahce like steam says but that doesnt do anything countless reboots etc guess us Windows 8 useres were not meant to play games.
amd133mhz Aug 13, 2013 @ 10:56pm 
Ok I got mine back up and running. I went to the rct3plus.exe file right click properties compat mode I chose windows XP sp 3 and I also selected disable display scaling on high DPI setting

I went to the Steam.exe and UN DID the run in 7 opted to disable display scaling on high DPI settings mode and chose run as admin ,to try and fix a diff issue, and now both issues I was having seem to be fixed.(I was having trouble getting skyrim to play in fullscreen )

RCT3Plus is up and running and I hope this works
sneaky_snailz Aug 14, 2013 @ 1:47pm 
Originally posted by amd133mhz:
Ok I got mine back up and running. I went to the rct3plus.exe file right click properties compat mode I chose windows XP sp 3 and I also selected disable display scaling on high DPI setting

I went to the Steam.exe and UN DID the run in 7 opted to disable display scaling on high DPI settings mode and chose run as admin ,to try and fix a diff issue, and now both issues I was having seem to be fixed.(I was having trouble getting skyrim to play in fullscreen )

RCT3Plus is up and running and I hope this works
this didnt work for me =(
amd133mhz Aug 14, 2013 @ 10:46pm 
Originally posted by sneaky_snailz:
Originally posted by amd133mhz:
Ok I got mine back up and running. I went to the rct3plus.exe file right click properties compat mode I chose windows XP sp 3 and I also selected disable display scaling on high DPI setting

I went to the Steam.exe and UN DID the run in 7 opted to disable display scaling on high DPI settings mode and chose run as admin ,to try and fix a diff issue, and now both issues I was having seem to be fixed.(I was having trouble getting skyrim to play in fullscreen )

RCT3Plus is up and running and I hope this works
this didnt work for me =(

Just when I get it working It stops again

THIS TIME It loads but after I click Play screen goes dark just get sound
PewDiePie Aug 16, 2013 @ 8:36am 
Same here. :(
amd133mhz Aug 17, 2013 @ 10:34am 
I got mine back up running it in -windowed at launch options and changing the default resalutions to a compat one. BUT there is a HUGE performance decrease now for some reason so I am unsinatalling and reinstalling AGAIN

edit NO LUCK runs slow as hell after uninstall and reinstall. I guess RCT3 was just not meant to be on a computer for gaming

I am running windows 8 with a amd fx6200 6 core 3.8ghz with 10gb ddr 3 1600 ram radeon 7790 2gddr5 card used to run good.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Jul 28, 2013 @ 7:06am
Posts: 9