RollerCoaster Tycoon 3: Platinum!

RollerCoaster Tycoon 3: Platinum!

Ver estadísticas:
VulGerrity 1 ene. 2013 a las 19:04
Get RCT3 to run on Mac OS 10.6.8?
I recently bought RCT3 but when I click play it says that it can't run on my machine, that it needs OS 10.7.5 or higher.

I really don't want to update to Lion at all, I think Lion stinks. Is there anyway I can get it to run on Snow Leopard?
< >
Mostrando 1-3 de 3 comentarios
Carlos Danger 1 ene. 2013 a las 19:39 
DNo updateno game
exp:/13 - Phil Mc Filou - 9 jun. 2013 a las 2:11 
me too
sudo 9 jun. 2013 a las 10:29 
I also want it on Snow Leopard, but you should have read the system requirements before you bought it.
< >
Mostrando 1-3 de 3 comentarios
Por página: 15 30 50

Publicado el: 1 ene. 2013 a las 19:04
Mensajes: 3