DeadlyPanda Mar 20, 2013 @ 8:39pm
Failed to create Direct 3D Device.
I keep trying to run RCT3 but I keep getting this message "Failed to create Direct 3D Device" I don't get why. I upgraded to windows 8 and it was working fine for abot 5 mins and then this happened. I don't know why. Anyone have any solutions.
Showing 1-6 of 6 comments
< >
Fat Dan Jun 9, 2013 @ 4:05pm 
tell me if you do coz i got the same problem on win 7 and i aint even played it yet?????!
abbott1492 Jun 10, 2013 @ 10:19am 
i have same problem now. This happened when i changed the graphics from quality to performance and then it crashed and came up with the error and now i cant get back on the game. well annoyed
alexXxanodyne Jun 10, 2013 @ 2:12pm 
A possible fix is setting it to run in compatability mode for earlier versions of windows. as well as having it run in 640 by 480. just right click the game in your library click properties and go to local content and click browse local content. then find the game itself and right click it to visit its properties and in the compatibilty tab are all the options. for my windows 8 i chose run in compatibility for windows 7, and run in 640 by 480. hope this helps
Soren Hiro Nov 29, 2013 @ 11:23pm 
Originally posted by alexXxanodyne:
A possible fix is setting it to run in compatability mode for earlier versions of windows. as well as having it run in 640 by 480. just right click the game in your library click properties and go to local content and click browse local content. then find the game itself and right click it to visit its properties and in the compatibilty tab are all the options. for my windows 8 i chose run in compatibility for windows 7, and run in 640 by 480. hope this helps

Dude, you're the man!!! I have been trying to solve this problem for days and your solution work just fine!!! I did the same thing that abbott1492 did (my game also crashed) and I wasnt' able to play, but now it's on baby!!!

Thanks again! :D
Crazed Possum Nov 30, 2013 @ 8:17am 
you can also find the config file and delete it thus telling the game your starting over. or open it and set the FirstTime to a zero and save over it. the file is called " Options" and there are 2 of them. the other one is under C\Main\AppData(this folder is a hidden folder and you will need to check off view hidden folders in your folder options just to see it)\Roaming\Atari\RCT3\Options file
Odande Mar 13 @ 5:30pm 
Originally posted by alexXxanodyne:
A possible fix is setting it to run in compatability mode for earlier versions of windows. as well as having it run in 640 by 480. just right click the game in your library click properties and go to local content and click browse local content. then find the game itself and right click it to visit its properties and in the compatibilty tab are all the options. for my windows 8 i chose run in compatibility for windows 7, and run in 640 by 480. hope this helps

I will literally marry you. Thank you!
Showing 1-6 of 6 comments
< >
Per page: 15 30 50