IHNN Mar 4 @ 10:27am
Glitch Reports
While playing, I noticed that the undo feature didn't always undo correctly: some things would undo after 1 move, others after 2. I made a level exploiting this to try to bring it to peoples attention (link below), and have also made a video demonstrating the solution, which you can also view below if you want to just see how it's broken and not try to figure it out for yourself.

http://cc3d.chuckschallenge.com/Share.php?levelId=15283
http://www.youtube.com/watch?v=_eIYGdZJnLM
Last edited by IHNN; Mar 7 @ 4:41pm
Showing 1-15 of 81 comments
< >
Allack  [developer] Mar 4 @ 11:20am 
Thanks IHNN yes the undo is really complex; there are a few bugs that we are still ironing out. But it always good to get examples so we can then reproduce and fix them.
IHNN Mar 5 @ 7:19am 
I suspect the best times for Asida 9 and Eclair 13 (ab)use undo to do something not otherwise possible, as the times are way beyond everyone else's. The fact that the same user played both ("Default") also hints towards a common method. Both of these times also appeared in March, so the method still exists.

On a slightly related note, Asida 16 seems impossible to obtain-with the best method I've found (in the ice block room, RDDRULURRR [2 blocks pushed] UULDULDLDRRRR [exit]), as it maxes at 9.4 while the best is 9.1. The first room seems obvious in how to optimize it as well: pushing the blocks one at a time through the center. At no point can the path of one block be moved farther along while pushing another, so where are the 2 moves/3 tenths coming from?
kdg977 Mar 5 @ 8:41am 
Don't know how to post a video of this, so hopefully my explanation will suffice. In Clottie 23, there's a bug with the undo. The third blue block can be pushed onto the ice so that it collides with the fourth blue block and comes back to squash Woop. Hit undo and the third blue block is now missing. Tried it several times with same result so it appears to be reproducible.
IHNN Mar 5 @ 12:48pm 
I've also been able to make monsters and enemies despawn with undo while sliding, but not consistently.
IHNN Mar 7 @ 4:43pm 
While going through a teleport with a key, the game will break the first available lock in reading order while still putting you through the same teleport it normally would. As a result, a level I made involving teleports and keys doesn't function at all, as the first down gives you a blue key, and going back up eats the key on a presently inaccessible lock through the highest teleport.
random 8 Mar 7 @ 7:28pm 
15167 The yellow squishy doesn't produce visible spray to its left, but if you step on that square you die (as you should). It USED to when i was building it, but it stopped about halfway through construction. Is the level like this for anyone else?
15325 The column (or whatever it's called) is not surrounded by a blue plate like the other one is.

Also, the green toggle button has a darker tint on its plate compared to the other three buttons.
Last edited by random 8; Apr 4 @ 2:56pm
IHNN Mar 18 @ 11:52pm 
Currently, I am completely unable under any circumstances able to move the camera while in the editor. It's been this way since the 1.15x update.
Locke Mar 19 @ 8:15am 
Originally posted by IHNN:
Currently, I am completely unable under any circumstances able to move the camera while in the editor. It's been this way since the 1.15x update.
You have a controller plugged in? I have mine plugged in all the time, and noticed that I couldn't find any way to make mouse controls move the camera, but the right stick on the controller works.
random 8 Mar 19 @ 1:21pm 
When pausing while playing a custom level, if the cursor is on the info button, pressing left on the keyboard moves it to controls --> restart --> home instead of the actual order: restart --> controls --> home. I'm not sure if this is intended or not, but pressing up moves it to play --> controls --> play --> restart --> play --> home. Similarly with right and down.
IHNN Mar 19 @ 1:58pm 
No controller plugged in, I simply can't move the viewing area in the editor.
KJAZZ Mar 22 @ 2:28pm 
Originally posted by Locke:
Originally posted by IHNN:
Currently, I am completely unable under any circumstances able to move the camera while in the editor. It's been this way since the 1.15x update.
You have a controller plugged in? I have mine plugged in all the time, and noticed that I couldn't find any way to make mouse controls move the camera, but the right stick on the controller works.

I'm having the same issue, no controller plugged in here. Very annoying, as it effectively means I can't make any levels that aren't tiny in size.
random 8 Mar 22 @ 9:16pm 
Hmm, i thought it was working on my end after the last update, but i tested it just now and i can't move the map either. (also no controller)
random 8 Mar 22 @ 10:35pm 
I played around a little more in the editor and got this:

http://steamcommunity.com/sharedfiles/filedetails/?id=241248809
kdg977 Mar 24 @ 7:51am 
I just posted a level with a couple more undo bugs: It's 15372.

The disappearing ice trick has been mentioned before, but I figured I'd throw it in since I wanted to demonstrate the other one anyway. It took a little playing around to make it work, ended up stealing the set-up from a previous weekly challenge.

I haven't seen the other bug mentioned anywhere before. You can alter the path a creature takes. Just start the level and let the creature move all the way to the end of the corridor. Hit the undo button. This time when the creature moves forward it will go up onto the button. You can also render the level unsolvable by hitting undo earlier and making the creature unable to advance.
Showing 1-15 of 81 comments
< >
Per page: 15 30 50