Darkest Dungeon

Darkest Dungeon

View Stats:
 This topic has been pinned, so it's probably important
Satoru Jan 30, 2015 @ 11:22am
Master List of Darkest Dungeon Fixes
If you are running into any issues with the game, please try all the workarounds below to see if one of them solves your issue. Also, please look for any existing threads that might cover your issue before starting a new one. Thanks!

I'll try to correlate fixes for Darkest Dungeon in this thread so it's easier to find.

100% CPU Utilization

If you're having this issue you can roll back to the previous build

1) In your Steam library find Darkest Dungeon
2) Right click->Properties
3) Click the "BETAS" tab
4) Click the pulldown
5) Select "pre_controller_support"
6) Click "Close"

The game will update the files to the previous build


Audio Enhancement Programs Can Cause Crashes

Note this is nearly the #1 issue for the game crashing so don't skip this section

Some audio enhancement tools may cause the game to crash. So far known programs that may cause issues are

* Nahimic (installed on MSI laptops)
* Sonic Sound 2 (installed on Asus laptops)
* Sonic Suite
* Razer Chroma (and possibly Synapse) - note your headset will still be usable

If you have any of these programs in your system tray, please kill them and try relaunching the game.

If that doesn't work then as a last resort uninstall the program and restart your computer

http://steamcommunity.com/app/262060/discussions/3/492379159714705337/#p3

The devs are aware of the issue and are looking into a fix for it


Issues with Windows 10 upgrade

If you upgraded to Windows 10 and are having issues with the game please try out a few of these tips. Note these are good tips for any other games you might have issues with as well on Win10.

1) Rerun the vcredist from:
Steam\SteamApps\common\DarkestDungeon\_CommonRedist\vcredist\2013
Then reboot your computer

2) Try running Steam as an administrator

3) Try running the Darkest.exe in Windows 7 compatibility mode

Run Darkest.exe in Compatibilty Mode

You can try to run the game in Compatibilty mode if you're on Windows

* Go to \steam\steamapps\common\darkest dungeon\_windows\
* Right Click-Properties on Darkest.exe
* Click the "Compatibilty" tab
* Check the "Run this program in compatibility mode for:"
* Select Windows 8/7/Vista/XP
* Work down from the highest version of windows listed down


Disable the Steam Overlay

This is the most common cause for people's inability to run the game, so try this first! If you are seeing the game stop at the Red Hook logo, this is likely the solution to your issue!
  • Go to your Library
  • Right click -> Properties on Darkest Dungeon
  • Uncheck "Enable the Steam Overlay while in-game"

Disable Raptr Plays.tv

Raptr's Plays.tv seems to cause issues if running in the background. But it may work if -capture is used as a launch option


Check If The Language Is Set

If your game crashes its possible the language is not set in the Steam menu

  • Go to your Library
  • Right click -> Properties on Darkest Dungeon
  • Go to the "Languages" tab
  • Select "English"

Then load the game. You can change the language to another one later once it loads properly.

"Reboot" Steam Cloud"

If you're game is crashing its possible your local SteamCloud saves or settings are bad.

  • Go to your Library
  • Right click -> Properties on Darkest Dungeon
  • Go to the "Updates" tab
  • At the bottom Uncheck "Enable Steam Cloud Synchronization for Darkest Dungeon"
  • Click "OK"
  • Repeat the above steps and Check the "Enable Steam Cloud Synchronization for Darkest Dungeon"
  • Click "OK"

Note you have to click "OK" after each step so steam will pull the proper files down from the Cloud.


Update Your Video Card Drivers

This is the next most common cause for people's inability to run the game, particularly on PC.

First check your driver version using this method and make sure your drivers are recent:
  • In Steam, go to the Help menu
  • Then go to "System Information"
  • Check your driver version and OpenGL version under the "Video Card" section
If you see that your drivers are from, say, August 2009, and/or you are running a version of OpenGL earlier than 2.1, and your card supports 2.1 or higher, then you should definitely be updating your drivers.

It is also important that you update your drivers through software provided by your video card manufacturer or directly from their site. Using Windows or updating software provided by your laptop manufacturer to find more recently drivers is less reliable, as they will likely only have drivers that initially shipped with the product, or will be out of date with the actual video card manufacturer.


Always make sure you reboot your machine after installing the drivers, just to be safe. Then try relaunching the game.

Laptop users should force their Nvidia/AMD cards

Use the Nvidia Control Panel or AMD CCC to force the game to use your built in GPU instead of the Intel one

This guide should help you depending on your video card:

http://www.howtogeek.com/175281/how-to-force-graphics-options-in-pc-games-with-nvidia-amd-or-intel-graphics/

We've also noticed that some HP laptops don't report the correct OpenGL version and/or people can't force their video card. Please see these links for more information on a possible solution:

http://h30434.www3.hp.com/t5/Notebook-Display-and-Video/Official-HP-statement-on-Switchable-Graphics-and-Open-GL/td-p/766285
http://support.hp.com/us-en/document/c02948560

Manually create the save game folder (New fix 2/4/2015)

This fixes some crashes/not starting issues so don't ignore this!!
  • Open Windows Explorer
  • Browse to c:\Users\<Username>\My Documents
  • Check if there is a folder called "Darkest"
  • If there isn't create the folder by right click->New folder and name it "Darkest"

On PC, if creating the Darkest folder yourself doesn't work, or if the game can't create it and you get an error saying as much, it's possible your Windows user profile has become corrupted. If that happens, try creating a new user account and see if you can run the game.

If you have a "My Documents\Darkest" directory and the game doesn't recognize it properly, you might need to restore it to it's default location. Please see this link for more information: http://www.sevenforums.com/tutorials/18583-user-folders-restore-default-location.html

Run the Game in Windowed Mode
  • Go to your Steam Library
  • Right click -> Properties on Darkest Dungeon
  • Click the "GENERAL" tab
  • Click "Set Launch Options
  • In the box type in "-size 1280 720" (remove the quotes)

Disable the intro cinematics
  • Go to your Steam Library
  • Right click -> Properties on Darkest Dungeon
  • Click the "GENERAL" tab
  • Click "Set Launch Options"
  • In the box type in "-disablevideo" (remove the quotes)

Disable all audio
  • Go to your Steam Library
  • Right click -> Properties on Darkest Dungeon
  • Click the "GENERAL" tab
  • Click "Set Launch Options"
  • In the box type in "-disableaudio" (remove the quotes)

No Save Games Visible

This appears to have been an issue with users having either special characters or non-English WIndows. This should be fixed in Build 7547. Please restart Steam to get the latest patch.

Try Restarting Steam

If you don't see the game in your library, try restarting the Steam client.

Streaming the Game in Windowed Mode

Capturing works fine in fullscreen, but to capture properly in windowed mode, use the "-capture" (remove the quotes) command line option in the launch options.
  • Go to your Steam Library
  • Right click -> Properties on Darkest Dungeon
  • Click the "GENERAL" tab
  • Click "Set Launch Options
  • In the box type in "-capture" (remove the quotes)

Mouse clicks don't register properly
Icons look misaligned or off center
Clicking on menus doesn't work
Can't Run Fullscreen On Windows 8 PC and Surfaces
This should now be fixed as of build #7740
  • Try disabling UI Scaling
Also try disabling UI scaling on a per-exe basis

  • Go to c:\program files\steam\steamapps\common\darkestdungeon\_windows
  • Find Darkest.exe
  • Right click->Properties
  • Go to Compatibility
  • Check "Disable display scaling on high DPI settings"

Try running both Steam and Darkest.exe as administrator

  • Go to c:\program files\steam\
  • Right click ->Properties on steam.exe
  • Click the Compatibility tab
  • Check "Run this program as an administrator

Then try doing it for the Darkest Dungeon exe
  • Go to c:\program files\steam\steamapps\common\darkestdungeon\_windows
  • Right click ->Properties on darkest.exe
  • Click the Compatibility tab
  • Check "Run this program as an administrator

Reinstall VCRedist

Go to

C:\Program Files\Steam\steamapps\common\DarkestDungeon\_CommonRedist\vcredist\2013

And re-run both the vcredist_x64.exe and the vcredist_x86.exe

Then reboot your computer

Verify the Integrity of the Game Cache

If you have tried all of these workarounds, and are still having trouble running the game, or if there are other obvious missing elements to the game (such as missing fonts), validate that all of the files are actually installed properly:
  • Go to your Steam Library
  • Right click -> Properties on Darkest Dungeon
  • Click the "Local Files" tab
  • Click on the "Verify Integrity of Game Cache..." button

Manually Reinstall the Game

Occasionally doing a re-verify won't work. This can be for various reasons especially if you had mods installed previously. If your game is crashing after an update try doing a manual reinstall of the game. To do so

  • Go to c:\program files\steam\steamapps\common\ (or wherever you have Steam installed)
  • Find the folder "DarkestDungeon"
  • Rename this to "DarketDungoenold" or to anything else
  • Go to Steam
  • In your Library, right click Darkest Dungeon, select "Delete Local Content"
  • Reinstall the game

Then try your save game again.

Post your system specs and details about your issue in the Crash Bugs sub-forum

If you are having crash or cannot start issues, and have done everything above please make a post in this sub-forum. The devs are treating all such issues at the highest priority.

Also the devs request that you send them additional logs if you can't start the game. This thread tells you how to enable the additional logging


http://steamcommunity.com/app/262060/discussions/0/612823460253966357/

Launch the game and send the data to the devs

It's important for the devs to know what your system specs are if they are to troubleshoot issue. Try to put a baseline information such as

OS:
Video Card:
CPU:

You can also go to the Steam Client and go to
Steam-Help-System Information

That window has a lot of technical stuff about your system that can help the devs identify things

Also when describing your problem be as descriptive as possible. They'll need to recreate your problem so more details is always better. Adding screenshots can also be helpful in describing visual issues.

Please be patient. The devs are absolutely committed to getting the game working for everyone.

The devs are active in fixing everyone's problems. So definitely post your bugs and crashes and they'll get resolved as fast as humanly possible.

I understand not being able to play the game is frustrating. But please be patient.
Last edited by Satoru; Jan 6 @ 11:06am
< >
Showing 1-15 of 1,540 comments
Satoru Jan 30, 2015 @ 11:22am 
Reserved for more information
Red Hook Keir  [developer] Jan 30, 2015 @ 11:34am 
THANKS MAN
Adept Pardoner Jan 30, 2015 @ 12:36pm 
Okay so, at the moment, once the opening cutscene plays it puts me on a screen showing a town and then instantly crashes. I'm unable to play at all.
Satoru Jan 30, 2015 @ 12:40pm 
Have you tried some of the fixes above? What are your system specs?
Adept Pardoner Jan 30, 2015 @ 12:47pm 
Tried the ones that can apply to me, no luck.

Video Card: nVidia GeForce GTX 550 Ti
CPU: Intel Core 2 Quad CPU
Satoru Jan 30, 2015 @ 1:02pm 
Originally posted by SideWaysThinker:
Tried the ones that can apply to me, no luck.

Video Card: nVidia GeForce GTX 550 Ti
CPU: Intel Core 2 Quad CPU

Please try them all. You never know which one might apply to your situation.
Adept Pardoner Jan 30, 2015 @ 1:16pm 
...Apparently it only works in windowed mode for me?
Red Hook Keir  [developer] Jan 30, 2015 @ 1:28pm 
In the options you can set which monitor the full screen uses. -size overrides that. Could maybe be a monitor number issue?
bloodychaos17 Jan 30, 2015 @ 2:45pm 
Playing on laptop, indeed I had to force the game to run on my Nvidia card otherwise I wouldn't be able to see the intro movie xD
zero playtime Jan 30, 2015 @ 3:02pm 
I have a problem with even starting the game. Every time i try to run it, the game simply display a OpenGL error.
Text:
Could not create OpenGL context.
A GPU capable of OpenGL 3.1 or better is required.

Have tried to update my graphics driver. No effect.

OS: Windows 7
Video Card: GeForce GT 520MX
CPU: Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz
Satoru Jan 30, 2015 @ 3:18pm 
Originally posted by zero playtime:
I have a problem with even starting the game. Every time i try to run it, the game simply display a OpenGL error.
Text:
Could not create OpenGL context.
A GPU capable of OpenGL 3.1 or better is required.

Have tried to update my graphics driver. No effect.

OS: Windows 7
Video Card: GeForce GT 520MX
CPU: Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz

Are you forcing the Nvidia video card in the Nvidia control panel
Satoru Jan 30, 2015 @ 3:46pm 
Originally posted by Kallisti:
Problem Event Name: BEX
Application Name: darkest.exe
Application Version: 0.0.0.0
Application Timestamp: 54cbdefe
Fault Module Name: MSVCR120.dll
Fault Module Version: 12.0.20827.3
Fault Module Timestamp: 521c8750
Exception Offset: 000a4653
Exception Code: c0000417
Exception Data: 00000000
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 0f83
Additional Information 2: 0f835c98dfad0b9799bfa65d438b9370
Additional Information 3: 905b
Additional Information 4: 905b9efd4e5ea403c0345f150d8c9147

any ideas

BEX errors are usually when you don't have DEP enabled
Insomnicron Jan 30, 2015 @ 4:11pm 
The game would only display the (rad) Red Hook logo, but was audibly playing the (awesome) intro movie, and would never display anything else.

I disabled the steam overlay and it worked like a charm, solving the issue.

Now... what is your solution to the rising fear of death the game is generating :D
VoltaicWar Prey Jan 30, 2015 @ 5:14pm 
Everytime I click on the shortcut for the game, it opens but has a black space and then a notice shows saying darkest.exe has stopped working
Roy Killington Jan 30, 2015 @ 10:30pm 
Audio skips during cinematic, but disabling the Steam Overlay fixed it. Wanted to report it, though.
< >
Showing 1-15 of 1,540 comments
Per page: 15 30 50