Call of Duty > General Discussions > Topic Details
God Muffin Freeman May 18 @ 7:50pm
Buffer Overrun Error
Every time time I try to start the sigleplayer or multiplayer of Call of Duty I get a buffer overrun error. I tried running it in Windows XP compatibility mode, but that didn't help. I tried looking up some fixes but none of them worked. Here are my specs:

Windows 8.1 64 bit
4 GB RAM
Intel i5-3337U
Intel HD Graphics 4000
Showing 1-8 of 8 comments
< >
Lemonfed May 27 @ 8:48pm 
go into your game folder make a back up of CODSP.exe then change the name for mohaa.exe ... then run mohaa.exe , I don't understand why but it's made the game run for me , well I have the retail so I wonder if the steam version might act different.

to play multiplayer do the same but with CodMP.exe
Last edited by Lemonfed; May 27 @ 8:54pm
BangXander Jun 2 @ 8:53pm 
I have the same problem... Have you resolved it ?
Lemonfed Jun 2 @ 8:55pm 
did you tried what my suggestion? I know it's work with the retail ... would like if someone could confirm they can run the steam version this way. but of course changing the file name will force you to run the game without going from the steam interface thru.
Last edited by Lemonfed; Jun 2 @ 8:59pm
katzenjogi Jun 3 @ 1:46am 
Hi there, bought the game yesterday - it ran first smooth for about five hours, after a break I wanted to play again: Buffer overrun.

No changes on hard- or software in that time. Other Quake2 Engine games work fine like MOHAA, RTCW or what else.

Tried all what was supposed on Internet: renamed the file, run it as administrator, xp compatibility mode (these three ones lead to the "steam not found" error.)

Fooling around with the graphics, loading down nhancer (which doesn't work on new nvidia graphic cards (and that means GTX 2XX and above), loading down nvidia inspector, choosing the right profile. Using older graphic cards driver....

Checked the integrety of the game files, reinstalled the whole game, tried different hdds and install paths - nothing worked...

The crazy thing is, that it runs first and than no way. The crazier thing is that the retail one runs even on the same system but not the steam one. If you copy and paste the retail exe in the steam folder, it works from direct hitting the exe fine, but if you try to start it through steam, you get the buffer overrun error. Really weird....
Last edited by katzenjogi; Jun 3 @ 3:38pm
God Muffin Freeman Jun 3 @ 2:18pm 
Sorry lemonfed, I tried it and it didn't work
BangXander Jun 3 @ 5:14pm 
i'm gonna try it now....
BangXander Jun 3 @ 5:19pm 
Well... i think my problem was the Steam.dll archive missed in my local folder C:\Steam\SteamApps\common\Call of Duty. Finally, I solved it..Thanks
Traveller Jun 27 @ 8:22am 
Hello guys, I'm having a very similar problem to you. I bought the game yesterday, it ran fine twice in a row, but the second time my computer suddenly just decided to take a nap: the screen went black and it didn't react to anything I stomped on the keyboard.
So I went 'ok whatever time to go to bed' and forcefully turned it off.

The very annoying thing is that now, when I try to start up CoD, he first says 'your game didn't quit normally' ♥♥♥♥ like that (OH REALLY?), asks me to run it in safe mode. Then he says 'it appears your computer settings have changed do you want to change your settings' blabla ♥♥♥♥ like that. Whether I say yes or no anywhere on those two points, the outcome is always the same: BUFFER OVERRUN DETECTED.

He says that the internal state of my computer has been corrupted. First of all I don't know what the ♥♥♥♥ that means, and since I bought this game yesterday I'm really getting ♥♥♥♥ed off. I tried reinstalling the game, it makes no difference. I tried to change the name of the CoDSP.exe file, it makes no difference. I copy pasted the Steam.dll file in my cod folder and, although he now doesn't say 'failed to find steam' anymore, he still ends up doing the same routine of buffer error crap. Hell, I even tried some DEF turning on thing I read somewhere else on this community hub.

I AM CLUELESS. ANYBODY, HELP!
Showing 1-8 of 8 comments
< >
Per page: 15 30 50