Lifeless Planet

Lifeless Planet

View Stats:
BLUEGILL Mar 7, 2014 @ 4:01pm
Camera Bug
Camera is slowy spinning around the player. I can move the mouse to look around, but when i stop, the camera spins again. Anyone else having this issue?
< >
Showing 1-14 of 14 comments
meshuggah12345 Mar 7, 2014 @ 5:30pm 
Do you have a joystick plugged in? If so it is probably off centre causing the camera to rotate.
Last edited by meshuggah12345; Mar 7, 2014 @ 5:30pm
David Board  [developer] Mar 7, 2014 @ 5:35pm 
Yup, that would be my guess too. Let me know if you can't clear it up by tweaking your gamepad settings. Sometimes you have to adjust the "dead" zone so stick doesn't register movement when in the center position.
Erdrick Mar 8, 2014 @ 12:04am 
I was having the same issue, unplugging my dualshock 4 helped. Thanks!
BLUEGILL Mar 9, 2014 @ 12:23pm 
Yeah it was a joystick issue... Great game so far David. Keep up the good work!
Gavlan the Great Jul 29, 2014 @ 12:31pm 
Having this issue, though I don't have any input devices plugged in excluding KB+M. Any thoughts?
David Board  [developer] Jul 31, 2014 @ 1:50am 
Originally posted by Gavlan the Great:
Having this issue, though I don't have any input devices plugged in excluding KB+M. Any thoughts?

Honestly I'm stumped on this. The game allows gamepad input at all times, but what could be causing the "ghostly" input data with nothing plugged in is a mystery to me. You might go on a hunt for third-party gamepad drivers utilities. Could it be you had a gamepad installed at one time that had some funky drivers? I admit I'm just grasping at ideas here. You might also try plugging in a gamepad just to see if it works and/or clears up the issue. Let me know if you clear this up.
Gavlan the Great Jul 31, 2014 @ 12:44pm 
No luck unfortunately but I sincerely appreciate you trying to help. I'm pretty sure (but not certain) the only controller I've installed is an officialy XBOX USB pad, so I doubt the software is questionable. Interesting side note you might think is funny, the camera rotation is twice as fast if I turn OFF higher quality effects.
David Board  [developer] Aug 3, 2014 @ 11:29pm 
Originally posted by Gavlan the Great:
No luck unfortunately but I sincerely appreciate you trying to help. I'm pretty sure (but not certain) the only controller I've installed is an officialy XBOX USB pad, so I doubt the software is questionable. Interesting side note you might think is funny, the camera rotation is twice as fast if I turn OFF higher quality effects.

Well, that makes sense actually because with the effects off, the frame-rate is much higher... I'm really at a loss here. I suppose you've tried other games and they work just fine?

Oh, one obvious thing I don't think has been mentioned here is to try resetting your control inputs under the Input tab in the game launch window. So you would choose each option for the stick/trigger controls and then move each appropriate stick (or press the triggers) to reset them. Again, just a guess but worth trying. The triggers of course are analog, so it could be something weird like the look setting is assigned to a trigger and the trigger dead zone isn't quite right (an odd situation, but again we're looking for something odd).
Stereorage82 Nov 13, 2015 @ 11:22am 
This issue still exists. I have no gamepad installed. My camera just rotates around me. Can't play the game at all.
pegtor48 Nov 30, 2015 @ 4:25pm 
I am having the same issue
David Board  [developer] Dec 9, 2015 @ 11:49pm 
Hi guys, I'm sorry you're still having this problem. I've never seen it myself so it's hard to figure what could be going on here (besides the obvious and ideas already discussed). In another thread, somebody said they fixed it by reinstalling gamepad drivers and restarting. But if you don't have a gamepad, all I can figure is maybe a stuck keyboard key or possibly... input from your laptop's touchpad. Of course, I don't know that you're running a laptop. Again, just guessing at this point.

I suppose you've tried to uninstall the game and reinstall? Be sure to delete your game preferences file (where to find it listed at support.lifelessplanet.com). You don't need to delete saved games, just the user preferences. And then reinstall clean...

It sounds like at least a couple of you are having this trouble. If you can give me make/model of your PCs including windows version (or macos) that will help find out if there's a common culprit here.

Also remember that you can reset your inputs in the launch window--if you haven't tried that, do give it a try. Feel free to email direct at games at stage2studios.com as I watch email more than this forum. I try... just stretched thin. Hope some of this helps!!!
leo Mar 10 @ 1:27am 
i'm suffering the same problem.. camera is spinning around when Xbox one controller is usb plugged. i'll try to reinstall controller and game next days
Solution: Need to turn off "Auto-Center Camera" in Options menu.
boz Apr 15 @ 2:31am 
i had the same problem. i had a 3dconnexion device (space navigator) plugged in. unplugging it wasn't enough, i had to disable the software too.
< >
Showing 1-14 of 14 comments
Per page: 15 30 50