Xx_Nightfire_xX Dec 9, 2013 @ 1:13am
WinRAR or 7-Zip on launch?
When I launch the game, It opens the file with WinRar. I'm so lost I can't even provide a decent explanation.
Last edited by phr00t; Dec 13, 2013 @ 11:51am
Showing 1-15 of 30 comments
< >
phr00t  [developer] Dec 9, 2013 @ 5:29am 
Reinstalling Java should resolve this. WinRAR is configured to open Jar files on your machine when Java should be configured instead.
phr00t  [developer] Dec 9, 2013 @ 2:17pm 
I changed how the game is launched, which should resolve this issue without needing to re-install Java.
NekoJonez Dec 12, 2013 @ 7:42am 
Yet, I still have this issue. :s
phr00t  [developer] Dec 12, 2013 @ 7:59am 
Are you on Windows? The JAR should no longer be trying to be opened directly... do you see a black "command" window appear in the background? Did you try re-installing Java?

You can also try this:

http://www.majorgeeks.com/files/details/jarfix.html
Flyskar Dec 13, 2013 @ 11:44am 
Hey phr00t I'm having the same issues. It worked on my older laptop and it worked on my new desktop for quite some time. Now about 1-2 weeks later I came back to play it and I'm getting the same issues as mentioned above. To make this easier for you to understand I took a screenshot here:http://puu.sh/5Ly5f.png
This is all that pops up, nothing more.. Nothing less. Help/Suggestions?
Flyskar Dec 13, 2013 @ 11:46am 
UPDATE: I went to the link you suggested above and let it downlaod and do it's thing. Game works fine now. Maybe you should Pin this thread so anyone else with the same problems can find the fix easily.
phr00t  [developer] Dec 13, 2013 @ 11:50am 
OHHHHHHHHHHHHHHHHHH javahome.jar is causing the thing to appear, not the 3079 executable. "javahome.jar" finds where Java is so I can start 3079 with proper arguments. I'll pin this & I may also update that black "command" window to mention the jarfix thing too!
Flyskar Dec 13, 2013 @ 11:56am 
Unfortunately another issue has appeared. Here is what I have my settings set to:
http://puu.sh/5LyDu.jpg
And also I should note that I have the range set to 115..but I've tried multiple different ranges. And for the settings I've tried different resolutions and options.. The end result is always a crash with this appearing:
http://puu.sh/5LyLO.jpg
and the command window remaining idle in the background as if I was still playing the game.
phr00t  [developer] Dec 13, 2013 @ 1:45pm 
Something is wrong with that refresh rate... 29hz is too low. It should be 50-120hz. Does it allow you to select any others? Does it work OK in windowed mode? Does changing the color settings help at all (32bpp instead of 16bpp?)
H4Xification Dec 13, 2013 @ 1:47pm 
*sigh* I've tried just about everything entioned before, from reinstalling java to downloading javafix, and yet nothing works. I have the same command screen/javahome screen combo pop up when i try to run 3079... is it my computer or something? I'm running windows 8.1 currently...
Flyskar Dec 13, 2013 @ 1:50pm 
Thanks for the help so far phr00t. The game works fine in windowed..but I want to go with fullscreen. And for some reason It only gives me the options 29hz and 30hz.. color options do not help at all. Also incase this is needed (I doubt it is) I'll just post my specs for reference:
16gigs RAM, Radeon 7800 series gfx card (1gig vram), and an i5-2400k cpu quad core.
Flyskar Dec 13, 2013 @ 1:52pm 
Actually now the game won't respond in windowed mode. It boots up, but no buttons respond or seem to work.. Just stuck on the little tip/tutorial screen :/
Flyskar Dec 13, 2013 @ 1:55pm 
Ok now I can't even see the startup help screen... Straight to this error it goes:http://puu.sh/5LFEo.jpg
Man I don't know what's happening anymore ;( (Also I have reinstalled and verified the cache over 10 times, no notable differences.)
phr00t  [developer] Dec 13, 2013 @ 6:14pm 
@H4Xification,

What window comes up for javahome? Is it 7zip / WinRAR? Can you try uninstalling that program, then uninstalling Java, finally re-installing Java? The jarfix program might not work on Windows 8.1 and your JAR association is stuck on something other than Java...

@UndercoverSanity,

Hrm... might want to try clearing your preferences in the registry. Run regedit and go to:

HKEY_CURRENT_USER\Software\JavaSoft\Prefs

... and delete the 3079 tree. This should reset all your settings. Then, make sure you have the latest video drivers installed here:

http://support.amd.com/en-us/download/auto-detect-tool

... hopefully this will allow the engine I am using to pick up your video settings...
phr00t  [developer] Dec 14, 2013 @ 9:00am 
Here is something else to try in Windows 8 if the .jar extension is associated with a WinRAR/7zip program:

http://www.wikihow.com/Associate-File-Types-in-Windows-8

... see if you can change the .jar association to "Java Binary" or "Java Runtime" etc.
Showing 1-15 of 30 comments
< >
Per page: 15 30 50