Zigfrak > General Discussion > Topic Details
Alex Ayars  [developer] Jan 18 @ 11:30am
Linux Mouse Issue and You
A Unity3D defect involving mouse handling is affecting most (but not all) players on Linux.

We really want to get this fixed, but we're at the mercy of Unity on this one. If you have a Unity3D community account, or know someone who does, you can help by spreading the word and lending votes to this issue:

http://issuetracker.unity3d.com/issues/screen-dot-lockcursor-under-linux-breaks-input-dot-getaxis

The issue is that when locking the cursor during mouse look, the camera freaks out and the game can crash. We work around this by not locking the cursor on Linux, but that means when the cursor hits the screen or window edge, camera look stops responding.

It seems that Unity will not fix it unless enough users cry out, so all help in raising this issue with them is much appreciated.

In the next release (1.12), an option to toggle cursor lock will be available under Input Options. If you're one of the lucky few who this does not affect, you'll have the option to use mouse look normally. Please experiment with this option carefully.
Showing 1-15 of 17 comments
< >
foobrew Jan 24 @ 12:26am 
Still only 4 votes :-(
Alex Ayars  [developer] Jan 30 @ 7:42pm 
9 now -- top Linux issue!
Skully Jan 30 @ 7:58pm 
Doesn't affect verdun and rust. Both use unity3d aswell. Ask them how they did it.
Alex Ayars  [developer] Jan 30 @ 8:51pm 
Originally posted by Skully:
Doesn't affect verdun and rust. Both use unity3d aswell. Ask them how they did it.

Many players of those games actually are affected -- there are long threads about the mouse issue in both of those communities, echoing the same symptoms I've seen with Zigfrak.

Since it sounds like your setup is among those which don't have this problem, you might be able to enable cursor locking in the next release.

I'm glad that Unity has acknowledged the problem, anyway. Hope they can get it smoothed out.
Last edited by Alex Ayars; Jan 30 @ 8:52pm
Skully Jan 30 @ 9:05pm 
Sounds great, Hopefully they can fix it for everyone
Tak! Feb 10 @ 4:12am 
It looks like the issue with Rust is different - for them, users report that enabling cursor lock actually *fixes* their problems.
For those of you who are experiencing this, can you list your:
* Distribution/version
* Window manager
* Graphics hardware, driver, and driver version
Alex Ayars  [developer] Feb 17 @ 3:49pm 
Originally posted by Tak!:
It looks like the issue with Rust is different - for them, users report that enabling cursor lock actually *fixes* their problems.
For those of you who are experiencing this, can you list your:
* Distribution/version
* Window manager
* Graphics hardware, driver, and driver version

Thank you Tak!(!!!)

This guy means it. If anyone wants to chime in with their specs here, please do so. It will be greatly appreciated!
Skully Feb 17 @ 7:01pm 
Ok my specs.
Fedora 20 64bit KDE (with openbox as window manager when gaming)
i7 4470k cpu
Nvidia GTX660ti 2gb video card (331.38 prop driver)
16gb ram

Ok all Unity games have mouse issues in KDE and ofcoarse as it's a compositing window manager, Unity engine disables vsync.

To fix this, I have 2 scripts on my desktop to switch window manager. 1st switches to Openbox and 2nd switches back to kwin. Script is simple like this.

(1st openbox)
#!/bin/bash
openbox --replace &

(2nd kwin)
#!/bin/bash
kwin --replace &

So whenever I am going to be gaming, I switch the manager to openbox. I do this for all games, not just Unity engine titles. As even with Kwin's "disable effects when fullscreen" option is used, openbox just plays games smoother, and some games with higher fps.

This completly fixes the mouse issues in Unity games. Example, Verdun is stuck looking up at sky with Kwin. I also play rust and Anna extended edition without any issue.

All I ask is at least an option to enable mouse locking, so people like me who won't have an issue can at least play your game properly. EVEN if it's just a command line switch or hidden config option. Later when Unity fix this stuff, you can remove the option or whatever.

Need anything else? Let me know!

EDIT: I had to install the package called "openbox-kde" on Fedora 20. This allows the openbox window manager to integrate properly inside KDE.


Last edited by Skully; Feb 17 @ 7:12pm
HunterZ Feb 21 @ 10:59pm 
Skully: I run Kubuntu 13.10 (KDE+KWin) with hardware compositing disabled all the time instead of just while in fullscreen apps (KDE still looks nice to me without the fancy effects) and Zigfrak seems to run fine for the most part.

I'm looking forward to being able to try the cursor lock, because it's really annoying hitting the edge of the screen.
Last edited by HunterZ; Feb 21 @ 11:01pm
Alex Ayars  [developer] Feb 22 @ 12:32pm 
1.13 includes an option to enable cursor lock for Linux users (under Input Options).

If your rig is affected by this bug, enabling this option will cause glitchiness and crashing. I'd recommend 1) save and quit first to avoid data loss in case of crash and 2) starting out with subtle mouse movements before deciding to keep it on.
Skully Feb 22 @ 4:58pm 
YAY! Thankyou so much for this. I can finally play it properly. The locking works great, only one little issue is the mouse cursor doesnt stay properly hidden when dragging around. You can see it sitting in middle of screen flickering.

Not a big issue, I can live with that. Thankyou for responding to your players.
I am going to go spend a few hours in space :)
þÛ®£ Mar 21 @ 4:37am 
Had the same issue and found this thread, activated mouse lock and it works great for me. Awesome game!
Tak! Mar 21 @ 7:14am 
So how many people are actually experiencing the "camera freaks out" behavior? Most of this thread seems to be people wanting to turn cursor locking back on...
lozdawney May 25 @ 3:27pm 
+1 for camera freaks out... for me it happens in rust (view goes up vertical then game freezes) and surgeon simulator (hand dives forward then game freezes)
My system:
Linux mint 16 KDE x64, AMD Catalyst 14.4
Alienware M15x, i7-740qm, 8gb DDR3, AMD HD6990m
Currently working round it by using XFCE just for those two titles, but logging out and in every time I load/exit the games is annoying!! Hoping for a fix soon
Alex Ayars  [developer] Jun 21 @ 11:30am 
This seems to have improved in the latest version of Unity (4.5). Zigfrak 1.15 was built with this new version, and is available on a beta opt-in basis. Be sure to enable cursor lock under input options.

It's still a little glitchy (feels jumpy, and the cursor does not auto-hide as intended), but it's definitely better. I had to turn mouse input sensitivity all the way down on our test machine.

Any feedback?
Last edited by Alex Ayars; Jun 21 @ 11:30am
Showing 1-15 of 17 comments
< >
Per page: 15 30 50