Achmanrun Mar 21, 2013 @ 6:55pm
Game not working?
I just bought the game on discount but it keeps crashing when loading all the map stuff and sprites etc. etc.? Anyone else had this or have a solution?
Showing 1-15 of 40 comments
< >
EddySkillzKillz Mar 21, 2013 @ 7:13pm 
Yes. I've had the same problems on my Win 7 x64b. I've look thru the forums here which takes a bit of time. I've tried installing DX9c, C++ for 64 and validating my game files on Steam (all things previous users said helped them) and didnt change anything to make game run.

Basically, it gets to World Map initializing and crashes. I revalidate the steam files and says some are bad. I revalidate 4-6 files. Repeat, exact same problems and files need revalidating.
I've got the whole collection but I think there maybe some problem with how Steam delivers them in the order they need to be installed, since each is basically a service patch. I'm to point now of just not caring to spend any more time trying to figure this out.
Achmanrun Mar 21, 2013 @ 7:25pm 
Yep, exactly my problem, i've also tried validating game files but fixing them didn't help..
BOT Velikan Mar 21, 2013 @ 7:36pm 
Same problem, scenarios are working but world map do not. I hope it will be fixed soon
EddySkillzKillz Mar 21, 2013 @ 7:42pm 
I doubt it as these were the same problems that folks in forum were having last yr. The original came out in 2009 with last update I think in 2011ish? So I doubt they care at this point. Paradox makes you go register on their site to be able to view any help / troubleshooting forum posts.

I also found the game launch .exe file in steam folders and tried running compatiblity for previous versions of Win's as well with exact same results. This is kinda lame to spend this much time trouble shooting a game.
Achmanrun Mar 21, 2013 @ 8:05pm 
Even lamer that steam is putting a broken game on discount, im ♥♥♥♥ed off
Lunatic Mar 21, 2013 @ 8:08pm 
I had similar problems, that was because i use 2 screens... What I did is I disabled my 2nd screen then it all worked fine afterwards. Hope it helps
Achmanrun Mar 21, 2013 @ 8:10pm 
Haha, i don't even have a second screen so doubt it's that, thanks for the input though :P
Lavaeolus Mar 21, 2013 @ 10:03pm 
I get the launch window, a clock, first five notes of ride of the valkyries then nothing. wtf!
Sentinel Mar 21, 2013 @ 11:25pm 
tried updating the c++ files, updating direct x, chainging the setting file to match my resolution, turning off my second monitor.

Game still crashes as soon as I start it.
Minensucher☭ Mar 22, 2013 @ 8:00am 
I could tell you how i fixed it because it always crashed at loading.i just had to change from HDMI to DVI
Nichtswisser Mar 22, 2013 @ 8:24am 
Same problem here! When I choose "default" in the launcher the game starts, yet when I select the expansion as play mod it crashes when loading the map crap.

Nice puting something on discount that does not work, thanks a lot Paradox!
EddySkillzKillz Mar 22, 2013 @ 8:27am 
So the answers to making less than a $10 game work like it's supposed to:
1. Spend a lot of time troubleshooting the problem they knew existed 1-2 yrs ago,
2. Modify your software, several times in hopes that it fixes it,
3. Modify your hardware set up...in the hope it fixes it,

At this point, I dont see how this game could be worth it. I'm beginning to think all Paradox does is churn out broken stuff to nickel and dime folks into buying "fixes," I mean DLC.

Thanks for the headaches Steam!
Lavaeolus Mar 22, 2013 @ 8:54am 
This is complete bs, has anyone been able to fix this?
sinfnrei Mar 22, 2013 @ 9:32am 
i wanted to buy the game but thx to your reports ill spend the money on some beer elsewhere :D
dirk Mar 22, 2013 @ 9:59am 
I verified my game cache integrity twice. First time it found 4 files, second time it found 6 files. After that I was ok.
Showing 1-15 of 40 comments
< >
Per page: 15 30 50
Date Posted: Mar 21, 2013 @ 6:55pm
Posts: 40