Panzeroo Dec 4, 2013 @ 11:15pm
Black ICE update
The next version is on the horizon and will be available as a playable beta around Christmas. It has a huge amount of changes including a rework of air units and techs and GFX, new light bomber and heavy transport plane units, expanded specialised HQs, Sniper combat tactics, new submarine types, reworked OOBs (divisions start with 5 brigades now), a entire 6 months of bug fixes and game balance changes, new buildings with landforts split into pillbox and fortress buildings, and much more. Finally, since the 30th June 2013 there has been over 10,000 downloads of the 3.2 version of BICE !

Links will initally be on the paradox forum.
Showing 1-15 of 19 comments
< >
dhbaer Dec 5, 2013 @ 4:26pm 
Can't wait. I post regularly in your subforum under a different name. Looking forward to it.
Attila[DK] Dec 10, 2013 @ 10:01am 
BLACK ICE is THE coolest expansion for HOI ever build! I just dont understand why Paradox isnt going to purchase it and make it official. But we need an expansion from 1929 with events :-) or even better from 1918!
SeriousCat Dec 10, 2013 @ 2:31pm 
Yeeeeeees!

PS:
Please give the option to install a "Lite" version of BlackICE that does not include changes to the graphics. I spent a whole day figuring out which graphics changes were made in the Total Realism project mod for Darkest Hour. I prefer the original graphics and I just want the gameplay improvements.
Attila[DK] Dec 11, 2013 @ 7:37am 
SeriousCat - for Gods sake NO! Black ICE is perfect - a lot better than the original. But on terms of grapics and the gameplay :-)
Filthy Console Peasant Dec 17, 2013 @ 2:29pm 
Will 3.2c saves be compatible?
Mr Snifflez Dec 18, 2013 @ 7:52pm 
I thought i read somewhere black ice doesnt support sprites, just has counters, is that true? wanna know before i try downloading
Panzeroo Dec 18, 2013 @ 8:08pm 
It won't be 3.2c compatiable. However the changes made deserve a new game start.

There is a sprite pack sub mod available as well. http://forum.paradoxplaza.com/forum/showthread.php?689766-Black-ICE-Sprite-Project-by-Aleksi_i
HaTsUnE_NeKo Dec 20, 2013 @ 9:39am 
oh
and i missed this entirly,
runs to go read up on it
Attila[DK] Dec 22, 2013 @ 8:36am 
Does anybody know when we can expect the new version??
Panzeroo Dec 23, 2013 @ 10:40pm 
We are aiming for just after Christmas. Obviously it can be difficult this time of the year to coordinate the modding team, but we are hoping for a beta ready a day or two after xmas.
Attila[DK] Dec 23, 2013 @ 11:23pm 
:-) thanks
CMHQ_Kutuzow Dec 30, 2013 @ 1:17pm 
Panzeroo ---> I played Blac Ice MKVII version 1.6.4 and i LOVE your's mod. it's completly new game expirience in my opinion. I was so exiting when found new version 3.2 c.
I made everything step by step from your install instruction:
http://www.moddb.com/mods/black-ice/downloads/black-ice-mk-vii-32

(i have PXTO checksum), and mod crash. Sometimes I can play 2 min, sometimes 5 min, but its very unstable. I haven't any problem with this last version.
I have Vista 64, but i try also on Win 7 -the same problem.
Did you work on that problem? The new verision will be more stable then 3.2c?


P.S. Now i can't play in 3.2c due this crash problem and can't go back to vanilla due the simplicity of the basic version in comparison to your great MOD. I hope new version will work perfectly (like old 1.6.4 did).
Panzeroo Dec 31, 2013 @ 3:24pm 
CMHQ_Kutuzow, you 100% need podcat's TFH exe to play BICE. It opens up the game engine to use more then 2Gb of computer memory. The mod adds in so much new content that without it you are lucky just to be able to install. Podcat's TFH exe is available on the paradox HOI3 forum once you have registered your base HOI3 game - you will notice a small tank icon under your avatar. Once you have overwritten the vanilla TFH exe with this you will not have any CTD issues with 3.2c. There is also a new beta 4.2, which is also stable enough to play. The link for 4.2 will be place in this forum very soon.
Attila[DK] Jan 1 @ 11:26am 
Panzero - there is a lot of missing texts to the events. I dont get any get to any of the "boming campaigns" nor the "convoy attacks". GREAT update! I love it!
Panzeroo Jan 1 @ 8:32pm 
if you are missing text it could be due to you not playing with english language settings. The mod is only designed to be played in english. The strategic bombing/ convoy sinking notifications might need your notification settings to be adjusted ? Convoy attacks will not begin informing you until about 800 sinkings have occured. You can still see the results of your attacks in the naval map screen, and air map screen for bombings.
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Dec 4, 2013 @ 11:15pm
Posts: 19