Haldurson Oct 30, 2013 @ 12:16am
Same bug as in Talisman DE re: Crown of Command
Sometimes when I need to enter the Crown of Command to win the game, the game will no let me. Someone on the Talisman DE forums suggested that I must have had an incomplete Wizards quest, but that is not the case.

I'll be on the last space before it, and no option to go forward, just options to go backwards along either other path.
Last edited by Haldurson; Oct 30, 2013 @ 12:17am
Showing 1-2 of 2 comments
< >
derek_tah Oct 30, 2013 @ 8:14pm 
Just to be clear you do have the Talisman needed before entering the Crown of Command correct?
Haldurson Oct 31, 2013 @ 12:43am 
Yes. Don't you need it even to get to the inner region anyway? In any case, I've owned prologue since it was first released months and months ago, and hadn't seen this bug until recently (After DE was released). That MIGHT be because I hadn't tried any of the new characters that were added (most quests don't require you to go to the Crown of Command, although that's the only way to win with those new characters).

BTW, the main reason why I've turned back to Prologue is because of problems like this with DE. I was hoping the new version of DE would have fixed it but it didn't. So went back to Prologue and sure enough, had the exact same issue. With DE it didn't happen every single time, but with Prologue and the new characters, at least since the last DE patch, I'm 3 for 3.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50