QUAD Jun 29 @ 3:14pm
just purchased baldur's gate 2 and doesnt start please help
I push play & doesnt start push play again & says its already runninhg? i've tried reinstalling and nothing heres a quick video https://www.youtube.com/watch?v=VU4dIlYnzZw&feature=youtu.be
Showing 1-15 of 30 comments
< >
jakalfakka Jun 29 @ 5:09pm 
got the same problem
Ryulin23 Jun 29 @ 5:57pm 
Same. Subscribing for answers
mew Jun 29 @ 5:58pm 
Im having problems too, i just bought and installed it, and upon launch the main menu is glitched graphically, theres big white lines and you can bairly see anything, and once you finally navigate into the game its incredibly slow and choppy.

Absolutely unplayable.
Zipalong Jun 29 @ 10:20pm 
I am also having this issue in which it pops up sayin "preparing to launch baldur's gate 2" and then that box vanishes and nothing happens.
Draker Raze Jun 30 @ 12:46am 
I am also having the same issue. The game seems to try to launch, but nothing pops up. My steam handle says I am playing, then after 15 seconds it goes back to just plain "online". I have done the typical trouble shooting that goes with steam, such as verify cache and such, but no luck.
Towers Jun 30 @ 6:33am 
Yup, also having this issue! I just want to play this game.

Bleh.
Saruman the grey Jun 30 @ 7:11am 
having the same problem sinse most recent patch.. click play and doesnt open, nothing really happens
Nunns Jun 30 @ 7:18am 
Add the game to your exceptions list and then try to run straight from game.exe
Last edited by Nunns; Jun 30 @ 7:18am
Judas13 Jun 30 @ 9:17am 
that does not help (in my case).
mastergradius Jun 30 @ 11:24am 
i couldn't pass up the sale on this title. of course there are problems with the perfect deal. i double click the game shortcut and nothing happens.
Лось Убогий Jul 2 @ 2:57pm 
Originally posted by Nunns:
Add the game to your exceptions list and then try to run straight from game.exe
this man is right. u need to add Baldur.exe to DEP exeptions.

just google 'how to make a dep exeption'

worked for me
Last edited by Лось Убогий; Jul 2 @ 2:57pm
mew Jul 5 @ 3:40am 
I tried installing it on linux, not the linux steam, but the windows version of steam using wine, and funnily enough it works perfectly.

A windows game that runs better on linux than windows, teehee.
ÄmJii Jul 5 @ 9:09am 
Silly question, but have you tried restarting your computer after installing the game?
El Gigante Jul 6 @ 8:02am 
same problem
slimbocker2000 Jul 6 @ 11:05am 
I have the same problem. Thing is it worked the first time I played it. Every time after it freezes on the screen just after you choose the adventure you want to play. I have reinstalled the game 5 time since and it refuses to work. Decided to post here after being blown off by beamdog's customer support.
Showing 1-15 of 30 comments
< >
Per page: 15 30 50
Date Posted: Jun 29 @ 3:14pm
Posts: 30