Entropy > General Discussions > Topic Details
scrawl Dec 9, 2013 @ 12:25pm
Game doesn't start (Linux version)
When I start it from Steam nothing happens. No window pops up or anything.

Trying to start it from terminal gives this:

scrawl-desktop:~/Steam/SteamApps/common/Entropy$ ./EntropyLinux.x86
Set current directory to /home/scrawl/Steam/SteamApps/common/Entropy
Found path: /home/scrawl/Steam/SteamApps/common/Entropy/EntropyLinux.x86
Mono path[0] = '/home/scrawl/Steam/SteamApps/common/Entropy/EntropyLinux_Data/Managed'
Mono path[1] = '/home/scrawl/Steam/SteamApps/common/Entropy/EntropyLinux_Data/Mono'
Mono config path = '/home/scrawl/Steam/SteamApps/common/Entropy/EntropyLinux_Data/Mono/etc'
scrawl-desktop:~/Steam/SteamApps/common/Entropy$

It's not even crashing or anything. Just quits instantly.

Any ideas?
Showing 1-15 of 21 comments
< >
UbuntuIsFriendly Dec 9, 2013 @ 1:28pm 
Hi scrawl, I won't be able to help you but usually with reports like these it's always good to specify which distribution you're using. Ubuntu? Arch?
Seppi Dec 9, 2013 @ 4:36pm 
I am getting the same error, but a bit different.


~/.steam/steam/SteamApps/common/Entropy♠ ./EntropyLinux.x86
Set current directory to /home/seppi/.local/share/Steam/SteamApps/common/Entropy
Found path: /home/seppi/.local/share/Steam/SteamApps/common/Entropy/EntropyLinux.x86
Mono path[0] = '/home/seppi/.local/share/Steam/SteamApps/common/Entropy/EntropyLinux_Data/Managed'
Mono path[1] = '/home/seppi/.local/share/Steam/SteamApps/common/Entropy/EntropyLinux_Data/Mono'
Mono config path = '/home/seppi/.local/share/Steam/SteamApps/common/Entropy/EntropyLinux_Data/Mono/etc'

The window draws, and the screen goes fullscreen blue.

When I run it from steam, it gives a non-full screen window that is black with a window UI.

I am running arch linux 64bit with the latest nVidia drivers
pmyarchon  [developer] Dec 9, 2013 @ 4:38pm 
Originally posted by Seppi:
I am getting the same error, but a bit different.


~/.steam/steam/SteamApps/common/Entropy♠ ./EntropyLinux.x86
Set current directory to /home/seppi/.local/share/Steam/SteamApps/common/Entropy
Found path: /home/seppi/.local/share/Steam/SteamApps/common/Entropy/EntropyLinux.x86
Mono path[0] = '/home/seppi/.local/share/Steam/SteamApps/common/Entropy/EntropyLinux_Data/Managed'
Mono path[1] = '/home/seppi/.local/share/Steam/SteamApps/common/Entropy/EntropyLinux_Data/Mono'
Mono config path = '/home/seppi/.local/share/Steam/SteamApps/common/Entropy/EntropyLinux_Data/Mono/etc'

The window draws, and the screen goes fullscreen blue.

When I run it from steam, it gives a non-full screen window that is black with a window UI.

I am running arch linux 64bit with the latest nVidia drivers

Thanks for a feedback, Seppi, we'll check this out!
Seppi Dec 9, 2013 @ 4:41pm 
It may be due to the fact that I have multiple x11's. I'm testing this theory out.
Invisabit Dec 9, 2013 @ 4:44pm 
I am currently playing while running Ubuntu 13.10. Everything running smooth here
Seppi Dec 9, 2013 @ 4:45pm 
I have moved down to one X11 instance, and all I get is the same color:

http://i.imgur.com/8IszM3D.png

A lovely #314D79
pmyarchon  [developer] Dec 9, 2013 @ 4:47pm 
Originally posted by Seppi:
It may be due to the fact that I have multiple x11's. I'm testing this theory out.

I watched your videocast.
Better not start Entropy from the console like, start it from Steam Client.
Seppi Dec 9, 2013 @ 4:49pm 
@pmyarchon, same result :(

Edit: I'm a big fat hairy liar! I got it up!
Last edited by Seppi; Dec 9, 2013 @ 4:49pm
pmyarchon  [developer] Dec 9, 2013 @ 4:49pm 
Originally posted by Seppi:
I have moved down to one X11 instance, and all I get is the same color:

http://i.imgur.com/8IszM3D.png

A lovely #314D79

We officially support Ubuntu 12.04 & Ubuntu 13.10 as mentioned in linux specs for Entropy.

But we'll try our best to make it running on other distributions too.
Last edited by pmyarchon; Dec 9, 2013 @ 4:49pm
ashiroff  [developer] Dec 9, 2013 @ 5:49pm 
Originally posted by Seppi:
same result :(
Seppi, you installed to OS lib32 packages? if not - read this[bbs.archlinux.org]
Seppi Dec 9, 2013 @ 6:01pm 
@pmyarchon - I was able to get the game running. The blue screen fades to the game when run from steam.

@ashiroff - I will document in this thread what packages I do and don't have compared to the page you linked for other arch users!
scrawl Dec 10, 2013 @ 4:44am 
I can play it now. It's really weird because it didn't update or anything. I guess a Steam restart did it.
scrawl Dec 10, 2013 @ 4:47am 
Well.. now it freezes a few seconds after I'm spawned in space.
Vondor Dec 11, 2013 @ 2:13pm 
Same here with Kubuntu 13.10 what should not make a difference to Ubuntu... Looks like in the first post from scrawl. If startet with stream, just quits. If startet from directory, bluescreen and nothing....
ptah_alexs Dec 12, 2013 @ 6:21am 
Game crashed when i'm click Enter on gate or station. no output_log in data dir. debian sid, x64, ia32-libs installed.
Showing 1-15 of 21 comments
< >
Per page: 15 30 50
Date Posted: Dec 9, 2013 @ 12:25pm
Posts: 21