SuperBio Nov 5, 2013 @ 2:51am
Have A problem, Post it here, I might be able to help
MAJOR UPDATE Found the problem responsible for most of the please reinstall game problems.

If you have ever installed The Earth Trilogy on your pc before steam this applies to you.
The Earth Trilogy fails to remove registry files that deal with the placement of the directory.
Use this guide to find them
Use regedit to examine the value of the following keys:

<BLOCKQUOTE>quote:</font><HR>
[HKEY_CURRENT_USER\Software\Topware\TheMoonProject\ BaseGame\FileSystem]
"OutputDir"="F:\Program Files\SSI\The Moon Project"
"DataPath"="F:\Program Files\SSI\The Moon Project/&gt;;G:\game/&gt;"
<HR></BLOCKQUOTE>

After you have found these keys right click and press Modify, copy paste the current directory for Earth/Moon/LostSouls and it should work.
For instance(S:\ProgramFiles\steamapps\common\Earth 2150 The Moon Project is what my Moon Project is under so you just add (S:\ProgramFiles\steamapps\common\Earth 2150 The Moon Project/>;F:\game/>) like so for the first entry and (S:\ProgramFiles\steamapps\common\Earth 2150 The Moon Project) for the second.

Other Problems

Basic problems include resolution problems which cause the game to crash at the research, and consturction center screens.
More Advanced problems would be the game crashing after creating a profile before the Skirmish, Multiplayer, or Campaign screens.
Lan Problems include not port forwarding and if your using hamachi I have a whole guide on how to use that, which is probably the best way to play a private match with your friends.

Fixes in the same order are

Resolution problems can be fixed by changing the resolution to 1680x1050x32 or lower, you can use OpenGL to if you get constant crashes like some users, although you will have to run the game at a lower resolution than 1680x1050x32.

The game crashing after creating a profile before the Skirmish, Multiplayer, or Campaign screens, is solved by turning off Data Execution Prevention (walkthrough in its ussage is herehttp://windows.microsoft.com/en-us/windows7/Change-Data-Execution-Prevention-settings?SignedIn=1)

Finally running the multiplayer through tcp/directip means you will either have to port forward your router, or use hamachi. Port Forwarding is not reccomended because it is usually much harder to do for certain people, say you live in a dorm. Hamachi is a better option for private games and much easier to use. To use hamachi, download it from the internet create a profile and then create a network. As of now hamachi can only have 5 other computers on a network including the host machine. Whoever runs hosts the game just hosts the game through tcp/directip. From here is where most bugs are. Most people can see the game but can't join it but a few can't even see the game. To fix both issues use a program called forcebind ip gui which you can find on google. Once you have that program use it to force bind the unique ip that hamachi has given you to Earth/Moon/LostSouls's exe once done force bind ip gui should boot the game and you should be able to see the game and join it. The host does not need to use force bind ip gui.

Hopefully this can clear up some of the problems I keep see poping up.
Hope to see you in a game one day,

SuperBio out.
Last edited by SuperBio; Mar 30 @ 1:46am
Showing 1-15 of 142 comments
< >
Talint Nov 5, 2013 @ 5:12am 
No movies for me, in Moon Project / Lost Souls
..but in EftBP(original) all ok.
any idea?
Flyingmoley Nov 5, 2013 @ 5:42am 
i cant get it to run at all. it asks permission to change something i click yes then a black box appears for 2 seconds then disappears and that it nothing any help please??
RaiderNation Nov 5, 2013 @ 7:19am 
Originally posted by Flyingmoley:
i cant get it to run at all. it asks permission to change something i click yes then a black box appears for 2 seconds then disappears and that it nothing any help please??
same problem 4 me. bought all three and none will play. say yes to changes, then box in upper left corner for 2-3 seconds then nothing. LAME
phonixor Nov 5, 2013 @ 8:19am 
@Talint i have the same problem
Adagumo no Yaorochi Nov 5, 2013 @ 9:32am 
Thanks for all this SuperBio, other issues you might want to fix:
Movies not showing in TMP/LS; Ambient music not working in TMP/LS; Finding a solution to work on a bigger res than 1680x1050; People cannot join games on EARTHNET ( tries to get in, game stops for 1-2 secs, then u get stuck for a few more secs, 'till it freezes again for 1-2 secs, and goes back to normal but you still failed to get in) and other few errors most ppl can't fix.
If you or anyone else finds fixes for these problems, please post them. Thanks again SuperBio for the list!
SuperBio Nov 5, 2013 @ 6:14pm 
Alright back with some fixes, For the EarthNet you have to port forward 2300-2400 and 47624, I am working under the assumption that most people understand port forwarding, and how its different for everyone because of unique routers and the such.

For the movies not showing up, you might want to leave it that way, on the GOG forums I helped a person with Windows 7 who couldn't get the game to run because of the movies, so the logic here is that they crash the game. He had to manually remove the videos from the folder.

As for the music not playing, I am going to do an in depth search as I have never heard of that problem, my guess would be that its an mp2 incompatability problem.

As for the resolution problems, the game was never meant to play anything in widescreen as widescreen wasn't prevalent during that time.

The version of the game steam uses is no different than the version sold ten plus years ago. Though I am pretty sure I have heard of a fix for the counstruction center/Research center bug that occurs with resolutions higher than 1680x1050x32.

I will look into that as I am sure I myself have played the game at 1080p, pretty sure it involved a widescreen hack and a mod to the game but it worked, similar to how KOTOR and KOTOR 2 had custom GUIs made for them for widescreen.

If anyone has any information on widescreen hacks feel free to post them and I will add them to the post.
Last edited by SuperBio; Nov 5, 2013 @ 6:15pm
trainoflegos Nov 5, 2013 @ 9:32pm 
1600x1200x32 resolution works also me and superbio have been working on these fixes for ages.

If u dont want to use the forcebind gui u can use gameranger but we had severe lag on it and were trying to find another solution we discovered forcebindip gui a couple weeks ago

here is link to the program http://old.r1ch.net/stuff/forcebindip/
SuperBio Nov 5, 2013 @ 9:38pm 
Yeah Gameranger is not at all a good program to use though there are a lot of people that use it, I assume its because everything else failed. Whoever could make a good vpn service similar to hamachi came around but with a public view for games, could get a lot of fans to come and use their services.
The Golden BB Nov 6, 2013 @ 1:41am 
Since your super helpful SuuperBio, maybe you an hlep me get it going since It doesn't run. Click to play the game and it doesn't appear to do anythingf I've tried multiple resolutions and also running it iunder XP mode... Any ideas would be most welcome.
Adagumo no Yaorochi Nov 6, 2013 @ 2:15am 
@SuperBio Well, i've port forwarded those exact same ports and I still can't connect, which is weird. I tried disabling the firewall but it ended up being for naught. As for the movies, I wouldn't mind disabling them, but simply removing them works? Also, some people might want to try to view them, so if you have enough time to check it after you found all other fixes, please do. Another thing, people have posted a patcher around that changes to your version to 2.1.9.9 ( I think) and gives out Operation X, you might want to check that out. Lastly, what version should we all use for standard play anyways? The one that comes with steam or...? Thanks again btw!
SuperBio Nov 6, 2013 @ 2:59am 
Okay will for your first problem the Earthnet is down quite a lot so its possible you tried to connect at that time. The ports also might have changed with newer updates I will check again to make sure I have the right ports.

The movies work for some people and for others they don't sometimes it doesn't download them so check the intergity of the game cache, personally I would avoid them as they crashed my game more than anything over the years.

As for the people posting the patcher that gives you version 2.1.9.9. That's a mod called Operation X hence the reason it gives it out. Its a good mod and a large majority of the community uses it. I myself am running OPX Beta 3.

As for standard Version, Patch 22 is the lastest version which came out over ten years ago. The Steam version is no different from that version or the GOG version or any of the other version you could find over the last ten years.

I also wouldn't expect and update ever from the devs, after Earth 2160 which wasn't nearly as good of a seller as Earth 2150 and its standalone expansions, they pretty much dropped support. Most of the support afterwards was done by modders who created Mods such as SUPERSTORM, and Operation X.


Last edited by SuperBio; Nov 6, 2013 @ 3:13am
SuperBio Nov 6, 2013 @ 3:04am 
Originally posted by Candas:
Since your super helpful SuuperBio, maybe you an hlep me get it going since It doesn't run. Click to play the game and it doesn't appear to do anythingf I've tried multiple resolutions and also running it iunder XP mode... Any ideas would be most welcome.

As for your problem tell me if this works. First go to setup and make sure your resolution is set to 1680x1050x32 or smaller, second disable the intro. Check if it runs after that. If it doesn't try this go to the installation directory and remove the video files from the game. Back them up if you want but they might be causing your crash/not being able to start the game problem.
Adagumo no Yaorochi Nov 6, 2013 @ 3:43am 
Ah... Superstorm... What an amazing mod it was, freaking AI was a beast... I verified the game cache and the movies don't work, meh, i'll just delete them, now that I know I can... I run Operation X beta 3 version 7 that was included in the patch, so I guess i'm okay there. Thanks for everything!
FreeFury Nov 6, 2013 @ 7:20am 
Alright, i have a problem with the game (The Moon Project). I can start the game normal, play Skirmish even, but when i want to do multiplayer it freezes. Here is what happens: I click on multiplayer, i choose my profile and then i choose the TCP-LAN thingy, and there my mouse freezes.

Tried:
- DEP solution
- Administrator
- XP Service Pack 3

Any help would be appreciated, greetz from FreeFury
trainoflegos Nov 6, 2013 @ 10:30am 
Originally posted by [VH:
FreeFury]Alright, i have a problem with the game (The Moon Project). I can start the game normal, play Skirmish even, but when i want to do multiplayer it freezes. Here is what happens: I click on multiplayer, i choose my profile and then i choose the TCP-LAN thingy, and there my mouse freezes.

i have seen this happen before it freezes for like 1 minute then goes back to the pick connection window it means that it timed out and cant connect to the server you have chosen this is what happened to me and Superbio when trying to connect to each others servers by entering the hamachi ip in we could see the games but couldnt connect.

Forcebindip gui program i posted earlier should fix the problem if that is the problem
Showing 1-15 of 142 comments
< >
Per page: 15 30 50