Earth 2150 Trilogy

Earth 2150 Trilogy

Can't get it to work
I've tried all 3 games, on OpenGL and D3D on every possible resolution, Hardware and Software sound. Every possible combination. Always, crash on startup. Have an idea how to fix this or have a workaround ? I really want to enjoy this gem of my childhood again.

Edit: Running on Win 8 Pro x64

Edit2: SOLVED!

I got it to run now! Thank you so much! It's been a whole weekend of me trying to get it to work, never did the thought cross my mind that it could be Data Execution Prevention.

Turning it off is really easy.

Control Panel > System > Advanced System Settings > Under Tab "Advanced" click Settings under "Performance" > Click Tab "Data Execution Prevention"

From there you can fiddle with the Settings as you like, it was enough for me to just set it to ON for essential windows programs and services.

Thanks to SuperBio for this find!
Last edited by ҪФLDЇҬZ ҪФLLЇGЦLД; Nov 4, 2013 @ 3:45pm
< >
Showing 1-15 of 20 comments
ᵏᶤᵚᶤ‰ Nov 1, 2013 @ 3:03pm 
+1
run out of workaround tricks and nothing works at all

win7 64
Last edited by ᵏᶤᵚᶤ‰; Nov 1, 2013 @ 3:03pm
Duke Danger Nov 1, 2013 @ 3:05pm 
Suffering exactly the same problem.
Really wanted to play this game from my childhood.

Also windows 7 64
darekmaver Nov 1, 2013 @ 4:29pm 
Had the same problem. Run "Graphic Settings" and turn off "Play intro" and "Autorun". It worked for me. It has something to do with video player...
Saiko Nov 1, 2013 @ 4:54pm 
Dares trick seems to work, thanks ^^
Duke Danger Nov 1, 2013 @ 5:26pm 
Works a treat. Thanks a lot.
Originally posted by darekmaver:
Had the same problem. Run "Graphic Settings" and turn off "Play intro" and "Autorun". It worked for me. It has something to do with video player...
I have just tried that, sadly, it is not working for me. Great for the others though and thanks for that. I will give it another try tommorow, maybe fiddle around with some more settings.
linuxjediz Nov 3, 2013 @ 7:20pm 
No that didn't work for me. I have even tried compatability mode for 98, but nothing.
SuperBio Nov 4, 2013 @ 11:36am 
Try disabling Data Prevention Execution for the exe of the game. I did that and had a similar problem. Link here http://windows.microsoft.com/en-us/windows7/Change-Data-Execution-Prevention-settings?SignedIn=1

Okay I can't find any way to turn it off in 8 but its the problem without a doubt. Try looking for that.
Last edited by SuperBio; Nov 4, 2013 @ 11:42am
Originally posted by SuperBio:
Try disabling Data Prevention Execution for the exe of the game. I did that and had a similar problem. Link here http://windows.microsoft.com/en-us/windows7/Change-Data-Execution-Prevention-settings?SignedIn=1

Okay I can't find any way to turn it off in 8 but its the problem without a doubt. Try looking for that.
I got it to run now! Thank you so much! It's been a whole weekend of me trying to get it to work, never did the thought cross my mind that it could be DEP.

Turning it off is actually the same as in Win7.

Control Panel > System > Advanced System Settings > Under Tab "Advanced" click Settings under "Performance" > Click Tab "Data Execution Prevention"

From there you can fiddle with the Settings as you like, it was enough for me to just set it to ON for essential windows programs and services. Am so glad it finally runs, tommorow is Moon Project Time I'm afraid. Thanks again buddy!
linuxjediz Nov 4, 2013 @ 6:35pm 
Kinda works now. I got it to run half the time, but it runs waaaaayyy too fast when it does. Like a clock needs adjusted or something.
G.I. Joe Nov 4, 2013 @ 7:27pm 
@linexjediz, It's probably running based off your monitors refresh rate. Do you have one thats higher then 60Hz?
linuxjediz Nov 4, 2013 @ 7:34pm 
nope
Liam Nov 6, 2013 @ 1:54am 
What happens if DEP isn't enabled to start with....
linuxjediz Nov 6, 2013 @ 7:26pm 
it doesn't work
Havoc Dec 3, 2013 @ 9:00pm 
Can I bump this for a possible related issue? I also have the issue of the game running too fast. Monitor refresh rate is 60Hz, Also I am running on a newer 8 core processor on windows 7 64 bit, I remember running this game before on a quad core processor on windows 7 64 bit with no issue, leads me to believe its a processor issue. I've tried disabling 4 cores and restarting but no changes.
< >
Showing 1-15 of 20 comments
Per page: 15 30 50