Drega Aug 15 @ 7:02pm
Hoping someone can help me with this issue.
I have checked several different forums, google searches... etc. I can't seem to find anyone who has the same problem I do when trying to run the game. When I click play I get the options to run the game or open the graphical settings menu, these both crash instantly with the message "Setup.exe has stopped working". I've tried compatibility mode, looking for the graphics options outside the game (to no avail), DEP is turned off, I even went into my registry to find the graphics options in there, but because the game won't even start they don't show up, and I can't try any of the other suggestions because they all involve going to the graphics menu, which also crashes instantly. If someone has had this problem and solved it please let me know.

Windows 7 Ultimate 64-bit
AMD Athlon 7850 Dual-Core Processor 2.80 GHz
8 GB of ram
Nvidia GT 220 video card
Last edited by Drega; Aug 16 @ 9:39am
Showing 1-10 of 10 comments
< >
THEFANG >,< Aug 16 @ 8:54am 
Fang here, intresting and unusual problem... i wonder if your graphics card is outdated prehaps? did you check the "readme" files stored in the game documents located on your drive under program files, steam, steamapps, common? maybe that'll help? not too sure.
Last edited by THEFANG >,<; Aug 16 @ 8:54am
Drega Aug 16 @ 9:19am 
If anything I would think an older video card would HELP the game run lol. Yes I've checked the documentation and they suggest the same things about changing it to a 4:3 aspect ratio but I can't do that because I can't get into the graphical options menu :/. It's really disappointing, I've been wanting to pick this game up again after I played lost souls years ago, but lost the second disc.
Thank you for the response though.
Last edited by Drega; Aug 16 @ 9:41am
THEFANG >,< Aug 16 @ 2:10pm 
no problem and my apologies. hope there will be a way to fix that problem. prehaps set it to OpenGL maybe?
Drega Aug 16 @ 4:21pm 
I wish I could, but like I said the game settings (setup.exe) crashes for me as well, and if the game doesn't run it doesn't want to create the settings file on my computer so I have nothing to edit that way either :/. Guess I'll have to play the not-quite-as-great sequel 2160 until I can figure something out.
THEFANG >,< Aug 16 @ 4:47pm 
well there is a mod for earth 2160 if your intrested. it looks quite simular to earth 2150 but somewhat improved... mind you the aliens in the mod are quite OP however. heres the link anyways: http://www.moddb.com/mods/nep-new-earth-project
Drega Aug 16 @ 4:55pm 
Hmm sounds pretty good, thanks I'll give it a shot.
Drega Aug 16 @ 5:19pm 
Well now, I seem to have gotten it to work... I was looking up an old game I used to play called Metal Fatigue, which is super fun if you can find a copy, pretty sure its abandonware so you should be able to find it for free. Anyways in one of the install guides I needed to download a program called Glide Wrapper, which forces old programs into certain settings, now Earth 2150 wasn't listed on their but it DID WORK. So now I can play it :D.
THEFANG >,< Aug 16 @ 6:08pm 
well then congrats, now you can replay the retro days :D

good luck, and don't kill me plz xP
Drega Aug 16 @ 6:11pm 
Yep, and if your looking for another game thats similar to this one check out Warzone 2100 the dev's only sold it for about 5 years and released the source code, so the community has been making it better and better, and it's completely free.
THEFANG >,< Aug 16 @ 6:49pm 
hmm, i'll go check it out when i have the chance, thanks much :)
Showing 1-10 of 10 comments
< >
Per page: 15 30 50