Earth 2150 Trilogy

Earth 2150 Trilogy

NeverZero Aug 14, 2014 @ 4:56am
unit construction crashing game
Everytime i click unit construction it crashes the game. Does anyone know how to fix this? :(
< >
Showing 1-15 of 15 comments
THEFANG >,< Aug 14, 2014 @ 7:18am 
Fang here, simple fix yes! go to your graphic settings and lower your resolution to about "1024x768". this game is quite old since 2000-2001 and it doesn't really support widescreen. by fixxing the resolution to that, you'll be able to access the unit construction, and it won't crash anymore. hope this helps
NeverZero Aug 14, 2014 @ 10:08am 
Originally posted by THEFANG >,<:
Fang here, simple fix yes! go to your graphic settings and lower your resolution to about "1024x768". this game is quite old since 2000-2001 and it doesn't really support widescreen. by fixxing the resolution to that, you'll be able to access the unit construction, and it won't crash anymore. hope this helps :advent:
it works now thanks :)
THEFANG >,< Aug 14, 2014 @ 11:15am 
no problem :)

hey if you want a better skirmish experence, i suggest to get the "Super Storm" mod for this game. not only there are new AI but now you can have alliance battles (like 3v3 for example)

enjoy the game
NeverZero Aug 14, 2014 @ 12:04pm 
Originally posted by THEFANG >,<:
no problem :)

hey if you want a better skirmish experence, i suggest to get the "Super Storm" mod for this game. not only there are new AI but now you can have alliance battles (like 3v3 for example)

enjoy the game :advent:
ok ill check the mod out thanks.
THEFANG >,< Aug 14, 2014 @ 1:49pm 
here, this link will help: http://homepage.ntlworld.com/gmtechb/Earth/SS_V2.htm

also even though this game has any multiplayer function at all, its very rare these days (unless you install certain programs) that can be useful for LAN based games.
Karakuliambro Aug 19, 2014 @ 6:37am 
Originally posted by THEFANG >,<:
Fang here, simple fix yes! go to your graphic settings and lower your resolution to about "1024x768". this game is quite old since 2000-2001 and it doesn't really support widescreen. by fixxing the resolution to that, you'll be able to access the unit construction, and it won't crash anymore. hope this helps :advent:

thank you alot!
THEFANG >,< Aug 19, 2014 @ 12:50pm 
@Karakuliambro, no problem :) enjoy the game and try not to kill me xP
LastSuicide Aug 26, 2014 @ 11:33am 
Hey Fang, thx for the mod hint! I'll try it. :)
THEFANG >,< Aug 26, 2014 @ 2:38pm 
No problem :), enjoy
Devin Plombier Sep 7, 2014 @ 10:50am 
Originally posted by THEFANG BASE >,<:
Fang here, simple fix yes! go to your graphic settings and lower your resolution to about "1024x768". this game is quite old since 2000-2001 and it doesn't really support widescreen. by fixxing the resolution to that, you'll be able to access the unit construction, and it won't crash anymore. hope this helps :advent:

Had the same problem, you fixed it, thanks.
THEFANG >,< Sep 7, 2014 @ 12:01pm 
No problem comrade, enjoy :)
heraldic Oct 15, 2014 @ 12:14pm 
Had the same Crashing Problem here....
Graphics Settings....ok....
But how do i get to the Graphics Setting Menu?
There was only one before i startet the Game FIRST time.
Don´t know how to get there after the first Start Setup.

Any Idea?
THEFANG >,< Oct 15, 2014 @ 1:22pm 
Fang here if you want to go back to that setup its pretty simple. go to your library in the steam client and then right click on the game you want to access its graphic settings. there should be an option for that. hope this helps
heraldic Oct 15, 2014 @ 4:18pm 
Yes, it works fine now.

Many Thanks Fang!
THEFANG >,< Oct 15, 2014 @ 6:36pm 
no problem comrade enjoy the game :)

and try not to kill me in the LC campaign plz xP
< >
Showing 1-15 of 15 comments
Per page: 15 30 50