Rust > General Discussions > Topic Details
George W. Bush Dec 14, 2013 @ 3:07pm
Rust how to Fix lagg
Hi guys, i have a question,

My Pc is very fine and my Internet to, i download over 1 MB/sec and my Pc has a Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz 2.40GHz with 16 GB RAM windows 8-64 bit.

I can play the new Assassins Creed on max graphic Games like Nether DayZ without lags, etc...

But in Rust i have every 15 second an 2 seconds lagg and i don't know why.

A lot of people don't have lags in Rust and i don't understand why i have laggs, i turned the grass off but still have laggs and i hope u maybe know how i can fix the lagg ?
Showing 1-13 of 13 comments
< >
AnnoyedBatman Dec 14, 2013 @ 3:34pm 
Are you experiencing lag or frame drops? They are quite different. If it's lag, try a different server. The lower the ping, the better.
George W. Bush Dec 14, 2013 @ 3:41pm 
I think it's a lag. I tried 9 different servers and it's on every server the same. I play very fine for 15 seconds than the Screen is frozen for 1-2 seconds and than the game runs normally 15 seconds later the same Problem again etc....

I'm sure it's not my Pc or internet because i have no Problems in other Games but not many players have my Problem in rust and i don't know what it is or what i can do =(
[MS] HoBoBoB182 Dec 14, 2013 @ 5:03pm 
Bring down the render quality and in consle (f1) type grass.on false

that helped me
George W. Bush Dec 14, 2013 @ 5:09pm 
This doesn't work. I tried already to low all graphic but still don't work. My Pc is very good and the graphic isn't the reason for this =(
Precursor7410™ Dec 14, 2013 @ 5:16pm 
i have the same problem
George W. Bush Dec 15, 2013 @ 12:58pm 
I tried something new. I ran Rust on Windows 7 and no lagg on windows 8.1. i have laggs.

So this is the reason for my Problem. I hope they fix Rust for Windows 8.1. User ....
GPVM Dec 15, 2013 @ 1:27pm 
Ohh well that might explain why I have same kind of spikes every 20 secs or so.. running windows 8.1 as well
iTs-clan.com | Canni Dec 23, 2013 @ 8:38am 
got crazy laggs here on very good computer...
ATI and win7 64bit
Peter Griffin Jan 18 @ 4:53pm 
Same here,

I deactivated the Realtek Audio in my sound options, played a few seconds, then activated again. No lags anymore ;)
Artem Jan 18 @ 5:08pm 
Tech problems, you never know…
PrettyDamaged Jan 18 @ 5:12pm 
I've the same problem. I ran a ping to Google and it exactly drops every time I've lag in Rust.
It seems like the netcode make my router going crazy...
Aceborn Jan 18 @ 5:39pm 
Originally posted by KSTYER12:
Same here,

I deactivated the Realtek Audio in my sound options, played a few seconds, then activated again. No lags anymore ;)

what do you mean exactly? did you turn off your sound driver?The game doesn't have such options so I'm guessing you did all this from your desktop.
Can you be more specific please?
p1nky Jan 18 @ 5:56pm 
ATI Graphic, the same is here. My pc run bd4 no problem. But in rust i have problems. Lags + my graphic card goes crazy. Fix it please.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Dec 14, 2013 @ 3:07pm
Posts: 13