7 Days to Die > Bug\Crash Reports > Topic Details
Lead  [developer] Dec 20, 2013 @ 6:04pm
Fixes for some common issues or failure to launch
Failure to start due to "Unknown Error" or "mono.dll" error:
(if you experience in-game crashes, you might consider trying this as well)

You may need to revert from a 64bit executable to the 32bit one.

Method:
1. Open your Steam Library, right-click "7 Days to Die" and click "Properties".
2. Click the "Local Files" tab, and then click "Browse Local Files".
3. Once an explorer Window pops up, double-click "Install_32bit.bat".

(this thread will get updated periodically as new information becomes available)


Some crash issues on 64bit systems fixed by installing a Microsoft Visual C++ Update
http://www.microsoft.com/en-us/download/details.aspx?id=13523
Last edited by Red Eagle LXIX; May 28 @ 12:07pm
Showing 1-5 of 5 comments
< >
|WEP|Grim_Reaper Jan 20 @ 11:00am 
Blurry Text With ATI Card Fix
Hello everyone. This fix has been known for quite a while and there are posts around. But I'll make a sticky for all of you who are having trouble finding the fix posts.

Anyways. Long story short, you need to open up your ATI Cataclyst Control Panel and turn the Mipmap Setting to High.

You can find a guide on how to get there here http://www.rcrncommunity.com/vga-guide/ati-amd#ccc

While this is a guide for Skyrim, the same "rules/steps" apply.

If you still however need help, please feel free to submit a support ticket by going to https://7daystodie.com/support and clicking the black support button on the left of the screen.

Take care!
The Fun Pimps
Red Eagle LXIX Apr 18 @ 6:28am 
I'll use this post for more generic issues that will eventually be addressed.

Game Won't Start, Unknown Error, Mono.dll Error
http://7daystodie.com/forums/showthread.php?206-General-Problems-Solved-LOOK-HERE-BEFORE-POSTING-ISSUES&p=1742&viewfull=1#post1742
http://steamcommunity.com/app/251570/discussions/0/648814395766980061/
http://steamcommunity.com/app/251570/discussions/0/648814395766980061/#c558747287862314647

Install does not always get it right for some reason and has on some systems installed 32bit versions on x64 and x64 version on win32 (which will never work).
While the x64 windows can run the 32bit version the 64bit would have access to more memory if the system has it.
The x64 version will never run on the 32bit version of windows though and can sometimes give the error described above.

Try this:
Steam Client > Right Click 7 Days To Die > Properties
http://steamcommunity.com/sharedfiles/filedetails/?id=226029644
> Local Files Tab > Click the Browse Local Files Button.
http://steamcommunity.com/sharedfiles/filedetails/?id=226029872
In the Explorer window that opens right-click and select Run As Administrator the Install_xxbit.bat that matches your version of Windows. If getting failure to start you probably want the 32bit version.
http://steamcommunity.com/sharedfiles/filedetails/?id=226030045
Last edited by Red Eagle LXIX; Jun 28 @ 7:24am
Red Eagle LXIX Apr 18 @ 9:32am 
Please post your computers specifications to help users and the developers.

OS Version:
Processor & Speed:
For Intel CPU, TurboBoost enabled (yes/no)(Only applies to Intel CPUs):
System Memory:
Shared with Video Card or discrete memory for each (shared/discrete):
Graphics Card:
Graphics RAM:
For Intel Graphics, TurboBoost enabled (yes/no)(only applies to Intel GPUs):
Video Resolution:
Video Refresh Rate:
Fullscreen (yes/no):
Steam Overlay enabled (yes/no):

FWIW, and maybe it will help get some information:
Code and memory usage will improve as the game progresses, but the full optimization stages are much further along in a normal development cycle so I'd not expect them anytime soon. That is not to say The Fun Pimps can't do such sooner than a normal development cycle, just setting a more realistic expectation.

Originally posted by 7 Days To Die Requirements:
Subject to change
May be higher during Alpha and Beta stages

PC System Requirements
Minimum:
OS: WindowsXP (Service Pack 3)
Processor: 2.4 Ghz Dual Core CPU
Memory: 4 GB RAM
Graphics: Nvidia 8800 GTX | Radeon HD 4770
DirectX: Version 10
Hard Drive: 1 GB available space
Additional Notes: Install size will gradually increase with future updates.

Recommended:
OS: Windows 7 or higher
Processor: 3.0 Ghz Quad Core CPU or faster
Memory: 6 GB RAM
Graphics: Nvidia GTX 460 | Radeon HD 5850
Network: Broadband Internet connection

Mac System Requirements
Minimum:
OS: 10.6
Processor: 2.4 Ghz Dual Core CPU
Memory: 4 GB RAM
Graphics: Nvidia 9800M GTS | Radeon HD 6770M
Hard Drive: 1 GB available space
Additional Notes: Install size will gradually increase with future updates.

Recommended:
OS: 10.9
Processor: 3.0 Ghz Quad Core CPU or faster
Memory: 6 GB RAM
Graphics: Nvidia GT 650M or 750M (strongly recommended)
Network: Broadband Internet connection
Last edited by Red Eagle LXIX; Apr 18 @ 9:33am
Red Eagle LXIX May 17 @ 8:54am 
Comodo Firewall and Unity engine Games (Stuck building environment)
There are known issues with Comodo firewall and the Unity engine. I would suggest trying with Comodo completely uninstalled (FYI, I had found this issue a while ago with another user on the main site and the uninstall Comodo recommendation comes from Comodo).

http://7daystodie.com/forums/showthread.php?5037-Stuck-when-trying-to-join-Game&highlight=comodo
Originally posted by Red Eagle LXIX:
Silly question, Do you run Comodo Firewall?
If so, try Game Mode before running and see if that works.
If that doesn't work and you are using Comodo, you might want to uninstall it. Comodo seems to have issues with the Unity engine and a number of games in general.

What language setting do you use in Windows?

(sorry, been looking around for the cause of the error you are seeing. 2 most common for other games are Commodo firewall {quite a lot} and language choice).
Originally posted by 9mb:
NO silly question! Commodo Firewall was the problem! Thank you sooo much for you efforts and your help! It seems important to uninstall it. The Game Mode and just closing it had no effect in my case.
Thanks to all of you and especially to Red Eagle :-)
And another link to a success after removing Comodo who still hasn't fixed their known Unity Engine compatibility issues:
http://steamcommunity.com/app/251570/discussions/0/558756255868769847/#c558756256110394173
Originally posted by 88MIKE:
THANKS alot red eagle, that solved my problem it seems....i uninstalled both the game and comodo then reinstalled the game with no security and now it works...looks like im going to switch to zone alarm instead and hope that doesnt cause problems

Last edited by Red Eagle LXIX; May 17 @ 8:13pm
Red Eagle LXIX Aug 19 @ 6:35am 
Multiple odd crashes, failure to start or load a save, failure to quit properly
In the Steam Client, Games Library
Right-Click 7 Days To Die
Select and click Properties
Select and click the Local Files tab
Click the Browse Local Files Button

Navigate to the \7 Days To Die\Data\Worlds\Navezgane folder by doing the following:
Double-click the Data folder
Double-click the Worlds folder
Double-click the Navezgane folder
If you see a folder called Saves, delete it.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50