Dark Matter

Dark Matter

View Stats:
Dark Matter > General Discussions > Topic Details
Stranger May 29, 2014 @ 2:57am
Not work on Linux
After start game, in menu, mouse pointer scroll to up of screen and game stopped.

Linux, x86_64
< >
Showing 1-8 of 8 comments
Maiksy Jun 2, 2014 @ 9:35am 
Dark Matter uses game engine called "Unity", which is unfortunately not supported on Linux systems, or at least there are some severe issues like the one you described
mariobuntu Jun 5, 2014 @ 12:52am 
no problems here.ubuntu 12.04 and nvidia gt 240.
akmelius Jun 23, 2014 @ 7:12am 
If I play on ultra I lost the control of the mouse. In high no problemes.
3])linux Jun 27, 2014 @ 6:17am 
Originally posted by Myelins:
Dark Matter uses game engine called "Unity", which is unfortunately not supported on Linux systems, or at least there are some severe issues like the one you described
Unity is 100% supported on gnu/linux, you just can't develop games on linux yet with Unity but you can publish games for linux.
jpalko Jul 1, 2014 @ 9:54pm 
Originally posted by akmelius:
If I play on ultra I lost the control of the mouse. In high no problemes.

Do you happen to have a sample prefs file ($HOME/.config/unity3d/InterWave Studios/Dark Matter/prefs) for the high setting? I can't get the settings to help with anything by altering UnityGraphicsQuality number on mine and the mouse just keeps on travelling upwards. Also no help from altering to 0 "Screenmanager Is Fullscreen mode" setting. Nor from disabling Steam overlay.

My prefs file is now:
<unity_prefs version_major="1" version_minor="0">
<pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>
<pref name="Screenmanager Resolution Height" type="int">1080</pref>
<pref name="Screenmanager Resolution Width" type="int">1920</pref>
<pref name="UnityGraphicsQuality" type="int">3</pref>
</unity_prefs>
LonePiper Jul 24, 2014 @ 5:40am 
Not sure what the the source of the problem is exactly, but notice if you alt-tab out of the game and move your cursor around, there is a second cursor on the screen of the game. This one moves twice the distance as your "regular" cursor.
jpalko Jul 29, 2014 @ 11:53pm 
I don't get a second cursor but once returning from alt-tabbing out of the game I return to it and if I move the mouse at all into any direction, it speeds up to the top of the screen from where I clicked it back to the game. Can't get any settings modified or anything done with this. I just have kill the process and move on to play something else.
The mousebug (@ KDE) was solved by making a new window behavior in the desktop settings menu.

1. Open "Configure Desktop"
2. Open "Windows Behavior"
3. Click " Window Rules" to the left
4 Click "New.." to the right
5. Under the tab "Window matching" set the "delay" to maximum
6. Click "Detect Window Properties"
7. Start Dark Matter in time and click the window or the fullscreen once the delay kicks in and changes the cursor
8. Close Dark Matter
9. Under the tab "Size&Position" tick "Fullscreen" and use "Apply Initially" and tick "Yes"
10. Close the window by "Ok" and close the last one by clicking "Apply"
11. Star Dark Matter and have fun!

Based on rust similiar issue: https://steamcommunity.com/app/252490/discussions/5/540731691409538299/
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Dark Matter > General Discussions > Topic Details