SteamVR > General Discussions > Topic Details
gunhero Aug 22 @ 5:48pm
DK2 problem - SteamVR works but not HL2 - Black screen, no tracking and only UI visible
Hello,
I have a really strange problem.
SteamVR works fine for me but when I try to start HL2 from it in VR mode all I see are a bunch of blue bubbles.Head tracking works here and I can hear the game in the BG but that´s it.
When I try to start the game directly from regular steam and then activate virtual reality from in-game and I reboot it, it seems to be in VR mode but position tracking does not work, and I can only see the UI. The 3d is actually not being rendered at all.

Running with latest firmware, sdk and drivers.

Running on an AMD 6970 with latest official drivers.
Showing 1-8 of 8 comments
< >
[LOL'd] Peregrines Fury Aug 23 @ 10:40pm 
same issue, running nvidia 770. It loads up with the screen. Has the bubbles from the background of big picture mode. The mouse works ( I can move it around and its the BPM cursor) but there is nothing to click on. I am getting full tracking though, just not loading into BPM within the VR environment. ( the environment is loading fine though)
Last edited by [LOL'd] Peregrines Fury; Aug 23 @ 10:40pm
gunhero Aug 24 @ 5:19am 
Does your main monitor support 1920x1080 resolution in 75 hz?
Mine does not, and I think that might be causing a bug with the rift.
I tried getting it to work with disabling and unplugging the main monitor but no luck so far.
BunHead Sep 6 @ 4:34am 
Having the same issue here, running two Nvidia 550 in sli. Has anyone managed to resolve this yet, because it seems to effect all Valve games (Lost Coast, HL2E2...)

Plus no my monitor does not support that resolution, has anyone got further with this?
I've since tried changing the primary screen resolution to 1024x780, but still no joy.

Since this post I've managed to get it working, by 1st making sure that after the Oculus is put into extended mode. You then go to the screen properties and make the new display the primary display. This brought back the picture, however when I started the game it kept rotating left. I then fixed this issue by going to the games settings and for mouse, make sure that raw input is ticked.

Hope this helps.
Last edited by BunHead; Sep 8 @ 9:28am
Drew Sep 8 @ 8:14pm 
Same problem here, SteamVR works pretty well, but when I launch HL2 in VR mode, I get the menu over a black screen, usually defaulting to a low res (640x480?) 4:3 mode. I can hear the game running and think I can actually see some movement in the extreme left of frame. Tried almost everything. Actually, it did work, randomly once, but I have no idea what I did different that time and haven't been able to reproduce. Win7 64, GTX 770, Intel,
Angrykorean Sep 12 @ 7:33am 
same thing with my nvidia 770

on the oculus i see the bubbles (from the Big Picture I guess), the game launches on my main monitor tho, tried it with "Among the sleep" game

dont know how to fix it yet
Drew Sep 12 @ 5:08pm 
I've finally had some success. But only by making the DK2 the primary display before launching HL2. This is obviously a pain on a few fronts. Al least when you power down the DK2 everything resets to normal. I really hope they can get this working a bit better for us....
Crevan Embrust Oct 28 @ 5:39pm 
If you start up HL2 to a black screen with white menu options, you're doing it right as far as I know. Just start up the game and it'll play the way it should, even if the main menu has a black background.

A few times I've gotten the bubbly screen for steam, but alt+tab has done the trick for me.
OHOHOHOOHOH
Showing 1-8 of 8 comments
< >
Per page: 15 30 50