Underrail > General Discussions > Topic Details
Styg  [developer] Sep 24, 2013 @ 12:26pm
If you have trouble running the game, look here first
- Make sure you have Media Player installed as Windows feature (no longer required)
- If you're running an old demo version, try running as admin
Last edited by Styg; Jan 16 @ 3:26am
Showing 1-15 of 32 comments
< >
V̟̋ì͚t̪͊r̳͛i͇͛o̦̅l̥ Oct 3, 2013 @ 12:05pm 
Why are you creating dependencies on a ♥♥♥♥♥♥, optional windows package that should have been deprecated years ago? The API is worthless and the [M$ media player] core and underlying codec framework is unstable, insecure and highly vulnerable to breakage within userspace.

There are plenty of good reasons not to have that godawful media player installed, but there is absolutely no good reason for 3rd party software to rely on it. Good practice for windows coding depends only on core winapi, DX (OGL is still superior, however), compiler libs/framework; everything else you satisfy via included DLL's or static linking. Need audio playback without license fees? use SFML, SDL2.0, OpenAL, etc.. There are plenty of far superior options, but reliance on WMP/WinMM/ACM/VCM/KMixer/etc. just makes it look like you don't know how to write code (C# isn't exactly winning you any credibility either).

I've been following this project for a long time, so let me tell you again that I really love the spirit of this game. However, if you're going to insist that I foolishly reconfigure my OS to accommodate sloppy code, then I'm just going to insist on a refund.
templeth Oct 4, 2013 @ 9:31am 
Wow Vitriol. (hehe... in this case the the name suits). I think you could have taken this to Dejan's attention a little more lightly. That wall of text is a big superior prose ♥♥♥♥ on Dejan's work/passion/time. This is 4 years labour. Frankly I'm grateful and I'm not going to spit chips at his work. Yes it is preferable that ms media player is NOT neccesary but I dont think its time to call this guy a hack programmer.
DynamicRanger Oct 6, 2013 @ 9:28am 
I can't help but agree with Vitriol, even the negative tone. Media Player is one of the first things to go when I configure Windows after an installation. This same problem occurred with A.R.E.S., but the dependency was eventually patched out, I think. In either case, I can't play this game until it isn't dependent on WMP--you'd have to be talking about HL3 for me to even consider reinstalling what is bloated crapware (WMP), at best.
sirchet Oct 7, 2013 @ 9:00am 
I have to agree with Mr. V. his points are valid and the tone implied is actually up to the person who reads it.

Let's remember, written word is subject to the frame of mind of the reader, regardless of the writer's intention.
Babarix Oct 9, 2013 @ 8:31am 
I join the crowed of people how would like to see the WMP dependency gone.

But i can understand if its a low priority thing that get fixed latter.
But on the other hand it may be better to rewrite the problematic code now then alter were the gaem would be bigger and more changes would be needed.
V̟̋ì͚t̪͊r̳͛i͇͛o̦̅l̥ Oct 22, 2013 @ 12:36pm 
I'm still completely unable to run this game, though I should very much like to. Any official word on fixing this?
GrimmSeraph Nov 1, 2013 @ 6:35pm 
I'd just like to take a moment to echo some of the previous posters.

Apparently there was a patch to remove the game's reliance on Windows Media Player, but the game is still doing the whole ' 'TimeLapse' such-and-such has encountered an error and needs to close' that was mainly caused by not having the aforementioned media player.
Babarix Nov 2, 2013 @ 5:21am 
If i understand his post right then he didnt't publish a patch with the changes yet. He jsut reportet what he changed in development so far. The current version should still be:
Sep 23 2013, 3:25pm - Alpha VERSION: 0.1.9.1
V̟̋ì͚t̪͊r̳͛i͇͛o̦̅l̥ Nov 3, 2013 @ 5:33pm 
From the dev blog[www.underrail.com]:

Originally posted by author:
Thursday, 24 October 2013 23:06

Hey guys, here's an update on what's been happening since the Steam release.
It will be a while longer before a new version is ready, sorry.

...
- Changes
- Removed Media Player requirement by popular demand (you will no longer have to have media player windows feature installed in the next version of the game)

Cheers. Looking forward to the next release.
Littlemama Dec 11, 2013 @ 10:19pm 
when does the mediaplayer ? be replaced ..i hate him and i hate him more when i cant play this GAME :(
Babarix Dec 12, 2013 @ 8:07am 
Replace it yourself. Just intall free alternatives like Winamp or Clementine.
Littlemama Dec 16, 2013 @ 4:56am 
thats not funny ...deliver the update 4 month should be enough gggrrrr
and babarix get lost because this game runs only with wmp and thats not a good choice
Babarix Dec 18, 2013 @ 8:46am 
sry thought you mean the WMP in general not in the game dependency. And i guess we can just wait for the next patch.
cyberarmy Dec 25, 2013 @ 10:53am 
I have WMP as a feature and also got both framework 4.0 thingies.
Still getting error when I try to run the game. Played the first demo version without any problems on my crappy lap top before but cannot play this steam version on my gaming rig T_T
Im welcoming any ideas!
Littlemama Dec 29, 2013 @ 7:03am 
next time i wait before buying ... my error
Showing 1-15 of 32 comments
< >
Per page: 15 30 50