Battlefield: Bad Company 2

Battlefield: Bad Company 2

El Fer Jan 12, 2013 @ 9:50pm
Black Screen in gameplay SP and MP
I have this problem isnce i reinstalled the game after a while everytime all i see is the HUD does anyone knows a fix?

My specs
WIn 8x64
4gb of ram
Nvidia 9800gt
C2duo @ 3.0

NVM: i found a solution online turn all the settings to low or returning to a previous forceware
Last edited by El Fer; Jan 12, 2013 @ 9:53pm
< >
Showing 1-15 of 56 comments
kinjahsa Jan 14, 2013 @ 10:19am 
win 8 ....... for tablet pc user ( suck os win 8 )
go win 7 ^^
End! Jan 14, 2013 @ 2:55pm 
oh for real window 7 is better!! b/c i got a window 7 and looking to buy this game!
El Fer Jan 15, 2013 @ 7:13am 
I think is more a bad drives porting instead win 8 :/ cause in older forceware works fine
GizmoMechanic Jan 17, 2013 @ 9:20pm 
check all your drivers and windows updates, check the C++ stuff. and then install them, RESTART YOUR COMPUTER,
THEN,
Start your BFBC2 up go to OPTIONS click "windowed mode" ON.
THEN,
RESTART BFBC2
go into a match and then click ESC, OPTIONS> unclick "Windowed mode" OFF.

that should work.
GizmoMechanic Jan 17, 2013 @ 9:21pm 
just XP or Windows 7.
MrDoitch Mar 2, 2013 @ 12:35am 
Well i use win7 and i have this problem... worked a week ago now nothing.. no updates been done or nothing.. anyone have a confirmed fix to this?
GizmoMechanic Mar 2, 2013 @ 1:00am 
Originally posted by MrDoitch , STOP THE RAGE!!:
Well i use win7 and i have this problem... worked a week ago now nothing.. no updates been done or nothing.. anyone have a confirmed fix to this?

try to use this graphics mod: you can change the settings of all the things in the game for better performance. Gossamers Launcher.

http://www.moddb.com/mods/gossamers-launcher/downloads/version-13
MrDoitch Mar 2, 2013 @ 1:15am 
tryd to no avail ^^ i dont need to tweak it, it runs fine flat out on my pc @ over 150fps just now have black screen except hud. i also tryed updating my graphics drivers, yet still not working :( if you have not experienced this yourself id be happy to make a quick vid to show what is actually happening if that helps
GizmoMechanic Mar 2, 2013 @ 1:28am 
check your graphics updates. install this thing anyways. you can change your Field of view. FOD. it helps in game. when your graphics driver is updated. RESTART your comp. and try again. if you can try to start the GAME in windowed mode then hit esc and go out of windowed mode.
MrDoitch Mar 2, 2013 @ 1:43am 
I have done my graphics update as stated in my previous post and that is followed by a restart. try'd in windowed mode try'd different direct X try'd all levels of quality, still no luck. also changing FOV in a multi-player game were its not a pre-set option can be classed as cheating as it gives you a visual edge over everyone else. :\
GizmoMechanic Mar 2, 2013 @ 1:50am 
what do you say about SLI multi displays? I don't have that anyways. sorry. Im trying to help I know some of the stuff may be obvious but, Im just checking things.

???
Is your resolution on your monitor the SAME as the resolution in game??
-- Check your C++ stuff
== go to your Library > Right Click > local file (cache) ...Click Verify game integrity (of Local files) sometimes windows updates messes with that somehow.
MrDoitch Mar 2, 2013 @ 2:01am 
i have SLI-Multi display... its rubbish for gaming unless its an MMO with lots of information on the screen at once but anyways :P. Yes my resolution is the same, I have also try'd lowering it and using different displays. Like i said in my initial post no updates have been done including windows one's but even still i checked and all is fine :(
GizmoMechanic Mar 2, 2013 @ 2:17am 
gtg for now. check the verify local files.
restart steam
MrDoitch Mar 2, 2013 @ 2:24am 
try'd that still not working.. ohh well i give up. back to planetside it is
< >
Showing 1-15 of 56 comments
Per page: 15 30 50

Date Posted: Jan 12, 2013 @ 9:50pm
Posts: 56