Moosz Apr 7, 2013 @ 4:36pm
Fix for: "Unable to Login. Please Try Again" & "connection to the servers lost"... error
TL,DR: delete the BFBC2 folder in My Documents + disable "remember password" & "autologin"
----------------------------------------------------------------------------

I was getting this error after entering the serial for Bad Company 2 which i just bought in Steam:

"Unable to Login. Please Try Again"

If you have this error too or something similar, the following might work.

https://help.ea.com/article/why-am-i-getting-the-error-unable-to-login-please-try-again-when-i-launch-bad-company-2

I have copied it from the site, incase the the link does not work:

----------------------------------------
Why am I getting the error "Unable to Login. Please Try Again" when I launch Bad Company 2?

This error can be fixed fairly easily. Maybe your password has changed since you last entered it in, or something happened with the saved information.

At the login screen, try unchecking the “Remember Password” box.
- Once you uncheck the box, please try re-entering your password. If you need to reset your password, please visit http://profile.ea.com.


If that does not work, you may need to clear your My Documents (or just Documents for Vista and Windows 7) Bad Company 2 folder to get that saved password out of your game.

- You can either delete the entire BFBC2 folder, or simply move it to your desktop in-case you have special settings or save files you want to keep.

- If you only play online, all your stats and data are kept with the server.

- Once the My Documents/BFBC2 folder is either deleted or moved, please try logging into your game."
------------------------------------------------------

For me option 2 worked. Now I was able to enter the serials and connect. After that first time no serials were needed anymore. Both Bad Company & Vietnam work. Severs come up after first clicking 'search'.

After you have done this you still have to go to the Punkbuster site and do an update of Punkbuster, otherwise a lot of servers will not let you in.

------------------------------------------------------

*****EDIT*****

The above steps seem to only get you past a first set of problems: logging in. So I removed the folder in MyDocuments again, went back in the game and disabled "remember password" and "auto login". Then filled in my EA username and password.

everything works now - login & servers. You just have to manually login each time you start up the game.
Last edited by Moosz; Apr 8, 2013 @ 1:20am
Date Posted: Apr 7, 2013 @ 4:36pm
Posts: 0