Salvation Prophecy

Salvation Prophecy

View Stats:
 This topic has been pinned, so it's probably important
mrmangosir Oct 8, 2013 @ 12:18pm
[support] Linux does not launch
Any one help me diagnose why the game will not launch on Linux?

I click on play within Steam and nothing happens, also when running from desktop icon. Not sure, but checking the steam icon. It says:

steam://rungameid/248450: No such file or directory

When launching? Might be a red herring in terms of the launcher icon.

Last edited by JabberwockyX; Oct 10, 2013 @ 1:11pm
< >
Showing 1-15 of 61 comments
mrmangosir Oct 8, 2013 @ 12:51pm 
Ok, found the files, launched manually gives me this:

error while loading shared libraries: cannot open shared object file: No such file or directory

According to my distro it has libxaw 1.0.12-1 is installed. Not sure if it's the same lib.
JabberwockyX  [developer] Oct 8, 2013 @ 1:19pm 
------ UPDATE Nov 23, 2013 ------
All these libs are now shipped/downloaded with the game.
If you find any more missing libraries, please post them here.

------ previous update ------

I'm copying this info here, so other readers don't have to browse this whole thread to find a solution.

Missing Libraries
If your linux distro is missing libs required to start the game, here is a download link[] where you can get them.

Place these libs inside directory: SalvationProphecy/build/release/lib
That's just inside the lib subdirectory from where you find the SalvationProphecy executable.

No Missing Libraries, Game Wont Start
There's a problem with AMD Catalyst Drivers, version 13.10.
See here for more details.

----- end edit -----

Ahh, the ever-popular game of hunting down different missing libs on different linux distros. ;)

So yeah, it looks like your distro likely has a newer version of libxaw, but does not include the older version linked to by the game.

What distro are you using? 32- or 64-bit?

I'll see if I can hunt down the version of that lib that the game links to, and make it available so you can launch the game.
Last edited by JabberwockyX; Nov 23, 2013 @ 7:13pm
Efrendi Oct 8, 2013 @ 1:40pm 
If you use debian or a derivative it's probably in the package libxaw7 (though on a curious note, why use athena widgets at all, it's a very old legacy widget and one you could probably do without).
JabberwockyX  [developer] Oct 8, 2013 @ 1:49pm 
I'm not linking to libxaw directly, so it must be some of the other middleware I'm using.
Efrendi Oct 8, 2013 @ 2:20pm 
If it's possible to get rid of as a dependency that would be cool, aw hasn't really been used since the early 90s, and it looks pretty fugly.

Anyway, I have to say this looks like a really cool game though, it was instabuy for me, thanks for supporting Linux =)
Last edited by Efrendi; Oct 8, 2013 @ 2:20pm
JabberwockyX  [developer] Oct 8, 2013 @ 3:18pm 
Hey mrmango -

Here's a link to[].

If possible, could you download this, then place it in the SalvationProphecy/build/release/lib directory? That's just inside the lib subdirectory from where you found the SalvationProphecy executable.

After that, give the game a shot, and if there's still trouble let me know the output of launching the game manually. Or even better, the output of "ldd SalvationProphecy" against the game executable.

Last edited by JabberwockyX; Oct 8, 2013 @ 3:20pm
JabberwockyX  [developer] Oct 8, 2013 @ 3:19pm 
@Efrendi - supporting linux was my pleasure! One thing that's great about working with linux guys is how tech savvy you all tend to be, which makes any support issues a lot smoother.
ToXS Oct 8, 2013 @ 6:34pm 
I'm having the same problem. Mint 15 x64
ldd SalvationProphecy => (0xf7705000) => ./lib/ (0xf7090000) => ./lib/ (0xf7050000) => ./lib/ (0xf6f30000) => ./lib/ (0xf6988000) => ./lib/ (0xf6910000) => ./lib/ (0xf6908000) => ./lib/ (0xf68e8000) => ./lib/ (0xf6600000) => ./lib/ (0xf65d8000) => ./lib/ (0xf65c8000) => ./lib/ (0xf65b8000) => ./lib/ (0xf6598000) => ./lib/ (0xf6410000) => ./lib/ (0xf6380000) => ./lib/ (0xf6378000) => ./lib/ (0xf6278000) => ./lib/ (0xf6260000) => ./lib/ (0xf6178000) => /lib/i386-linux-gnu/ (0xf6118000) => /lib/i386-linux-gnu/ (0xf60f8000) => /lib/i386-linux-gnu/ (0xf5f40000) => /lib/i386-linux-gnu/ (0xf5f20000) => /usr/lib32/fglrx/ (0xf5e30000) => /usr/lib/i386-linux-gnu/ (0xf5cf8000) => ./lib/ (0xf5c80000) => not found => not found => not found => ./lib/ (0xf5c10000) => /lib/i386-linux-gnu/ (0xf5c08000) => ./lib/ (0xf5bf0000) => ./lib/ (0xf5af8000) => ./lib/ (0xf5ac8000) => not found => ./lib/ (0xf5a88000) => /lib/i386-linux-gnu/ (0xf5a68000) => /lib/i386-linux-gnu/ (0xf5a58000)
/lib/ (0xf76e0000) => /usr/lib/i386-linux-gnu/ (0xf5a40000) => /usr/lib32/fglrx/ (0xf5a20000) => /usr/lib/i386-linux-gnu/ (0xf59f8000) => not found => not found => not found => ./lib/ (0xf59a0000) => ./lib/ (0xf5918000) => ./lib/ (0xf58f8000) => ./lib/ (0xf5830000) => ./lib/ (0xf57e8000) => ./lib/ (0xf57c8000) => ./lib/ (0xf5738000) => not found => ./lib/ (0xf5728000) => /usr/lib/i386-linux-gnu/ (0xf5720000) => /usr/lib/i386-linux-gnu/ (0xf5718000) => not found => ./lib/ (0xf5710000) => ./lib/ (0xf5708000) => not found => ./lib/ (0xf56b8000)
JabberwockyX  [developer] Oct 8, 2013 @ 6:47pm 
Thanks ToXS - I'm going to bundle up every library that was not found, and upload it to my fileshare.

The game was tested on Mint, so I'm surprised to see so many different libraries missing. But maybe it was 32-bit mint and not 64-bit, which could easily be the difference.

I also thought at least some of those libraries were included with the Steam installation, but I guess I must be wrong. You are running the game through steam, correct?
ToXS Oct 8, 2013 @ 6:48pm 
Yes, through steam.
JabberwockyX  [developer] Oct 8, 2013 @ 8:29pm 
Ok ToXS, here's a new link[] with all the missing libraries.

- click the link
- download all the libs in that folder
- place those libs inside the SalvationProphecy/build/release/lib directory
--- That's just inside the lib subdirectory from where you found the SalvationProphecy executable.
--- you'll see a bunch of other libs in there.

That might work. Or we might end up playing a bit of "whack a mole" if those libs link to other missing libs on your system. Thanks a lot for your patience ToXS - whatever we can work out will be used to update the linux installer to help out other Mint 64-bit users.
ToXS Oct 9, 2013 @ 3:00am 
That fixed it. Thank you.
JabberwockyX  [developer] Oct 9, 2013 @ 3:00am 
Awesome, thanks for posting back ToXS.
mrmangosir Oct 9, 2013 @ 9:40am 
Wow! Ok thanks guys I will check the info! I am using Manjaro 64bit for the main machine (where the problem is occuring) and Arch (not tested on this yet ) on the other. So yeah perhaps I have a later version. Let me check and see if this works.
Last edited by mrmangosir; Oct 9, 2013 @ 9:41am
mrmangosir Oct 9, 2013 @ 9:58am 
You are GLORIOUS! Worked fine fella. Thanks for the libs, downloading them into the lib directory worked a treat.
< >
Showing 1-15 of 61 comments
Per page: 15 30 50