Salvation Prophecy

Salvation Prophecy

View Stats:
 This topic has been pinned, so it's probably important
Lt.Marlow Jul 3, 2015 @ 7:19am
.EXE CRASH FIX, GET IT HERE
Alright, tried all the major fixes listed, was considering deletion before I fixed an older game by adding a Data Execution Prevention to the .exe file.

Here is a basic walkthrough of how to add Salvation Prophecy.exe to the exceptions list.

https://4sysops.com/archives/how-to-turn-off-data-execution-prevention-dep/

I've been trying this with other games that have devolped mysterious .exe crashes and it seems to work %80 of the time.

Give it a try and devs, goond on you guys for sticking around.
< >
Showing 1-10 of 10 comments
JabberwockyX  [developer] Jul 5, 2015 @ 1:27pm 
Thanks lt. There has been one mystery error that prevents a small number of players from launching the game. It would be great if this was the fix! Hopefully we get some more feedback on this.
ReaperV Jul 25, 2015 @ 4:29pm 
1000x THIS! I read every other thread on this invisible error (game simply never starts), and the second I add this to the exceptions list of the DEP, along with Ex Machina Hard Truck Apolcalypse, this game finally runs!

My system is:
- Windows 8.1 (going to be "special" and update to Windows 10 next week)
- i7 4820K
- 32GB RAM (2100mhz)
- 2x XFX 280x Black Edition 2GB in CrossfireX mode

I was not going to re-install the OS over this game, even though I read a TON of stuff in the forums and it's exactly the type of game I want to play, and quite frankly everything else worked fine other than this game.

Adding the game to the DEP exceptions where one of the world's buggiest games ever also had to be added, finally made the difference... and considering that I loved the other game and don't regret messing with it either, I have a feeling this is going to be an awesome game!

I highly recommend adding this to a Sticky for people who have Windows 7-8.1 and can't even get the game to launch at all. I don't know why we are the chosen few "special" people with this problem, but the DEP fix should probably cover the remaining few people with this issue.
Last edited by ReaperV; Jul 25, 2015 @ 4:30pm
JabberwockyX  [developer] Jul 26, 2015 @ 9:36pm 
Cool, thanks for confirming the fix, ReaperV. And thanks again Lt.Marlow for finding it. Seriously much appreciated!

I'll definitely sticky this, or merge the info into the stickied thread. I'm just going to read up on what this DEP thing is first, so I understand what's going on.
ReaperV Jul 27, 2015 @ 1:25pm 
I can explain it like this: You are an indie developer. Not that many played this game (unfortunately). On some systems, Windows recognizes something in the code of your game as an uncertified malicious software and keeps it from Executing the Data, even if you run the game as Administrator and click on the "yes" to run it.

I have active anti-virus system protection through Spybot, Windows Defender, and CCleaner however they have not detected anything malicious for a long time, and my system runs great... however even after validating files multiple times this program is still of unknown origin to Windows for some reason, and simply running as Administrator does not work for me... it usually does for other games, and I have played at least 10 various blockbuster and indie games on this system over the last year... so far it was this game, Rock of Ages, and Ex Machina Hard Truck Apocalypse that have caused me problems... well, Hard Truck had waaaay more problems over-all, so this was far from the only fix I had to do to play that game... the key is to never give-up! lol :D

I'm a gamer from the 90's... and I was an early adopter of AMD graphic cards... I'm used to having to work a little to make stuff work so that I can play. >:3
Last edited by ReaperV; Jul 27, 2015 @ 1:29pm
JabberwockyX  [developer] Jul 28, 2015 @ 11:10am 
Yep, that's pretty much what I've gleaned as well ReaperV, regarding the system security angle.

The only thing I'm still unclear on is the technical aspect. What exactly "executing the data" means? That's a weird phrase - normally a program "executes the code", not the data. As far as I'm aware, my game, nor any of the libraries I use execute any data. It executes code, that operates on data. Weird.

The other thing that annoys the crap out of me about this "protection" is that it gives no proper error message to the user. (Correct me if I'm wrong.) That's a massive pile of BS. An operating system, or security software should never intentionally cause a program to crash without any meaningful error message to the user. I am seriously unimpressed with this all.

*grumble*

I just needed to get that off my chest. ;)

Ok, thread pinned.
ReaperV Jul 28, 2015 @ 12:13pm 
Well, by "data" I'm pretty sure that's in layman terms for the average user to understand. It basically keeps your program from working, so it does not even really "crash" (no crash logs generated), it just blocks the code from being executed. What in your code/how you access resource libraries with this specific game seems to be triggering it... I have no idea if it's because my Windows 8.1 configuration sees it as potential malicious attack that it blocks ahead of time because it matches some other code out there in cyber space, or if it's a completely coincidence due to some sort of random Windows update installing in the wrong order from some other update.

Honestly, if it affects so few people, odds are that it's nothing you did wrong on your end.

Somebody in another thread with a similar problem had Windows 7 and reinstalled his entire OS to make this game work... so something was certainly added to the system (I'm assuming in a security update) caused the problem. I have seen this happen before with games even as high-profile as BF4 when it first came out. There was even some weird update that caused only half the screen display for some reason in certain games.

**** happens... no get ready for Windows 10 to be available tomorrow! *Evil laugh* >:D

EDIT: Just to be clear, I did NOT have an error or a crash... the game completely failed to start. A crash generates an error and a log, where-as in my situation simply nothing happened past the clicking of the "Play" button in Steam or launching EXE directly in the game directory. So really this fix is not just for "crashes", but in case the game does not run at all before it even has a chance to crash.
Last edited by ReaperV; Jul 28, 2015 @ 12:18pm
I had some issues getting the game to run under Windows 8.1 (Maybe that's the issue?). It works after the upgrade to Windows 10 though without any tweaks.
JabberwockyX  [developer] Aug 14, 2015 @ 1:24am 
Cool, thanks for letting me know Rev. Glad to hear the game is working on Windows 10 (haven't upgraded yet myself).
Nothing i have tried has worked every other single game has worked for me except for CS GO i vertified game cache,restarted computer ran steam and the game as administrators idk what to do... its ♥♥♥♥♥♥♥t that im one of these unlucky people
JabberwockyX  [developer] Feb 5 @ 7:30am 
Hi GamingRecords -
I don't see Salvation Prophecy listed under games you own. Are you having problems with CS GO? This is the wrong place to find help for that.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50