kisguri  [developer] Apr 23 @ 9:52am
Steam Workshop Download/Upload Tool
This tool linked below will allow you to access files in the workshop that you have subscribed to. Once a few users have checked it out and verified it works as expected it will be embeded under the tool tab in CF2.5

http://download.clickteam.com/misc/en/steam/SteamWorkshopTool.exe
Showing 1-15 of 28 comments
< >
kisguri  [developer] Apr 23 @ 2:31pm 
Note we are working on getting subscriptions to download automatically, currently you have to grab them manually though the tools Download section.
Wasabito Apr 23 @ 8:27pm 
the tool works fine. I already downloaded a few examples. I was a little bit worried when I saw the pop up window asking the version I was using (MMF2 developer, MMF2, gamemaker) as some extension installers don't work with CF 2.5, but what I've downloaded so far works fine. The path on download is a little bit annoying, but nothing to be worried about. The thing is that I have to remember where the workshop item went to, as the steam folders use numbers instead of a more user friendly tag. Nice work Kisguri.
Wasabito Apr 24 @ 6:42am 
The LAUNCH button doesn't work for me. The tutorials I've dowloaded are listed, but nothing happens when I click on Launch button. I have to go to the menu and select "Open file" to be able to run/unzip the files. At least that's the way you don't need to remind the annoying path =)
Wasabito Apr 24 @ 6:43am 
Another thing for testers: I had to be connected to steam for the tool to work.
Sue Apr 24 @ 8:44am 
I can't seems to download any addon by the tool :/
Here's what the logs gives:

Steam connecting...
Steam connected!
Downloading content file with id '252386157'...
Downloading content preview with id '252386157'...
Failed to download content file with id '252386157' to 'D:\Games\Steam\userdata\58781652\248170\local\ugc\zoomstar.zip' error 'statusErrorAccessDenied'!
Failed to download content preview with id '252386157' to 'D:\Games\Steam\userdata\58781652\248170\local\ugc\zoomstar_preview.jpg' error 'statusErrorAccessDenied'!
Finished downloading!
Sue Apr 24 @ 8:46am 
I have checked those path and there's no "ugc" folder, probably it's the culprit.

EDIT: Yep, I created the folder manually and the download is now worked.
Last edited by Sue; Apr 24 @ 8:47am
kisguri  [developer] Apr 24 @ 9:44am 
Strange!
kisguri  [developer] Apr 25 @ 9:16am 
I added 5 new files today.
Wasabito Apr 28 @ 8:45pm 
There are some files that need extension not included in the extension manager (I assume they are from mmf2). Also there are examples that are missing some files (error messages when opening them). But the tool works for dowloading the workshops, so I think it covers its purposes.
kisguri  [developer] Apr 29 @ 7:32am 
Which package is missing Extensions
Wasabito Apr 29 @ 11:36am 
hmm I'll have to go again and check, but I remember that Black eagle agent is missing a jpg or something like that (not an extension), and when I run the application I only see dark screen with a "car-light" like image that moves when I press the arrow keys, but I can't see the agent, enemies or anything else. I'll check again later which one doesn't have a cf2.5 extension.
kisguri  [developer] Apr 29 @ 6:19pm 
Has anyone besides Sue attempted to upload a file?
nicoper Apr 30 @ 9:46am 
Originally posted by kisguri:
Has anyone besides Sue attempted to upload a file?
I just did and it worked fine http://steamcommunity.com/sharedfiles/filedetails/?id=254843214&searchtext=
Last edited by nicoper; Apr 30 @ 9:47am
kisguri  [developer] Apr 30 @ 10:17am 
Nice!
Wasabito Apr 30 @ 11:05am 
Greatwork.mfa: INI++ v1.5 extension missing
Retrocraze: extension missing Kernel object (fcKernel.mfx)
Showing 1-15 of 28 comments
< >
Per page: 15 30 50