Paranormal > General Discussions > Topic Details
StemeliaGameGirl Oct 29, 2013 @ 7:56pm
The Demo ran fine at max settings, but this runs like ♥♥♥♥ at minimum?
I ran the beta at maxed out settings withotu having ANY issue, but this new version barely meets 10fps on LOW settings, can I just say; "what the ♥♥♥♥!?"
Showing 1-7 of 7 comments
< >
ghoulshow Oct 29, 2013 @ 9:02pm 
Agreed, I can barely get it to run on lowest settings. Terribly ♥♥♥♥ed off at this purchase. WAY MORE THAN MEET SPECS.
StemeliaGameGirl Oct 29, 2013 @ 9:22pm 
Same with me! I have a $1,000+ gaming PC with windows 7 and really high specs.
they need to fix this, there must be some issue with the optimization in the current build.
MattDementous  [developer] Oct 30, 2013 @ 7:30am 
What's your computer's specs? Also note that the game is still in development and is constantly being optimized and changed.
StemeliaGameGirl Oct 30, 2013 @ 7:58am 
Redeon 4860 Graphics Card (I can run Crysis at full specs) My computer says my graphics cards are up-to-date. I have 5GM ram, my Windows 7 Version is Premium 64, and I have a 3GHZ Quad Core Processor

-Edit-

P.S. I also am away that this game is still in development.
Last edited by StemeliaGameGirl; Oct 30, 2013 @ 7:59am
MattDementous  [developer] Oct 30, 2013 @ 8:06am 
You should totally be able to run the game at at least 30 fps. I plan on optimizing the game heavily in the next major update. I'm sorry the game isn't running as well as it should! My goal is to double the performance in the future :)
Last edited by MattDementous; Oct 30, 2013 @ 8:30am
StemeliaGameGirl Oct 30, 2013 @ 8:40am 
Thank you! Please let me know around update time ;-)
Yardbomb Nov 2, 2013 @ 6:01pm 
Having the same kind of problem here. I really want to like the game, but at the moment it runs really choppy for whatever reasons.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50