Democracy 3 > General Discussions > Topic Details
robz (Banned) May 15, 2014 @ 3:27am
Democracy 3 not working - dont buy the latest DLC!
After installing the latest DCL I can no longer play the game!!!

Getting errors after errors. Seems poitech are blaming steam but I think they had not tested the dlc enough.

Pull you finger out and fix the problem!!!! or refund everyones money and pull the new DLC until fixed
Showing 1-15 of 20 comments
< >
robz (Banned) May 15, 2014 @ 3:29am 
I have updated the game ( 1.14 ), unistalled and installed. bla bla bla.
O. B. I. E. May 15, 2014 @ 3:48am 
Exactly the same issues for me. Drivers updated, game uninstalled & installed. It keeps crashing when you launch a new game after the country selection screen.
Vraizyn//Blight May 15, 2014 @ 4:14am 
Yeah got the same error here.
DissonantGamer May 15, 2014 @ 4:34am 
Same issue here. I even tried installing the game to another drive, verifying, etc.
amankaila May 15, 2014 @ 4:37am 
I can't even download the 1.14 patch because it doesn't work.
Sam May 15, 2014 @ 5:48am 
Same with me. I can no longer play.
XerxesTheUndead May 15, 2014 @ 5:50am 
Yeah whenever I try to load my old saved files it doesn't work and it crashes.
Kepler-452b May 15, 2014 @ 6:17am 
same here
Matze May 15, 2014 @ 6:26am 
same here
cliffski  [developer] May 15, 2014 @ 6:29am 
Hi, this was a steam issue but it should be fixed now. Just checking its also not an issue for mac & linux...
ryan.adale May 15, 2014 @ 11:57am 
Same
wusch May 15, 2014 @ 12:55pm 
It worked for me after I installed Version 1.14.
yhishtchie May 16, 2014 @ 1:53pm 
I have version 1.14, bought the Extremism expansion and downloaded it and installed it, and the expansion still doesn't work. No new policies, nothing in my mods list pertaining to Extremism. There doesn't seem to be anything in my Democracy3 folder for Extremism, either.
I bought it off the positech webpage, and downloaded Extremism from the link emailed to me.
Last edited by yhishtchie; May 16, 2014 @ 1:58pm
cliffski  [developer] May 16, 2014 @ 1:58pm 
this is through steam? is it a mac linux or windows version? is there a file called extremism.txt inside steamapps/common/democracy3/data/mods?
Have you tried uninstalling and reinstalling the DLC?
yhishtchie May 16, 2014 @ 2:06pm 
I bought it off the positech site, and am using Windows 8.
Showing 1-15 of 20 comments
< >
Per page: 15 30 50

Democracy 3 > General Discussions > Topic Details
Date Posted: May 15, 2014 @ 3:27am
Posts: 20