ENSLAVED™: Odyssey to the West™ Premium Edition
cryohellinc 2013 年 10 月 26 日 @ 下午 1 時 10 分
Fixing resolution issues, Improving Graphics and Adjusting it for your own Taste
Ok after redownloading my shadow bug vanished, however game has some amazing config troubles.

First is the silly resolutions they offer. They dont work, so you have to manually make the game use your native resolution combined with some other tweaks. After I have done that game was looking much better for me.

So to do the following you need to go to:
c:\Program Files\Steam\SteamApps\common and find game folder there (path is example one, you may have it differently)
Anyways once you are in the game folder go to \Enslaved\Engine\Config

Locate file called BaseEngine.ini open it with Notepad ( and make a backup just in case )

Now we need to change the following:
ResX=1280 ResY=720 <- This is the resolution your game uses. Even thou I put 1920x1080 in game options, game will be using this one. Now you may ask " Man what the hell? I changed resolution " Well I have same question.... Anyways change it to your native monitor resolution for best effect. Example - My monitor is full HD = 1920x1080 is my native, so I changed ResX and ResY to -> ResX=1920 and ResY=1080

Are we done? No.

Next.

MaxAnisotropy= Put this to 16 This is texture filtering, no performance loss however better looking textures, more detail

DetailMode= put this to 5 ( default is 2, 5 is maximum you can put, put 6 game crashes, increases the detail of the game )

ShadowFilterRadius= put this to 5 ( default is 2 ) Changes the smoothness of shadow edges, the higher the value, the smoother, imo best balance - 5

Now jagged edges and AA you have 2 options

1) change MaxMultisamples=1 to MaxMultisamples=4 or 8 or 16

or

2) Go to your video card control panel and apply AA to the game through there.

I use number 2 as Nvidia AA gives me better performance.


Ok now Framerate CAP and Vsync

UseVsync=False ---- Is Off by default, everyone knows what Vsync is so if you need it put True, if not keep it as it is.

bSmoothFrameRate=TRUE <-- Good old framerate cap, put FALSE ( and YES USE CAPS :O ) if you want to cancel it.

if you keep it at TRUE there are two options
MinSmoothedFrameRate=22 <-- keep it as it is
MaxSmoothedFrameRate=62 <--- now this one is a ♥♥♥♥♥♥♥, basically first of all depending on the REFRESH RATE of your MONITOR most of you will have 60hz monitor some may have higher refresh rate , like me for example, so there are two options

If you have 60hz monitor put MaxSmoothedFrameRate=60 --- that will prevent tearing with vsync turned on and prevent tearing in general

If you have HIGHER then 60hz monitor, in my case as an example I have Asus 144hz monitor, so I put this to MaxSmoothedFrameRate=144. Basically if you have higher then 60hz try to put the refresh rate of your monitor.

Thats it folks, feel free to play with settings and always backup the file, also make sure AFTER you tweak and are ready to play make the file READ ONLY

Right click BaseEngine.ini--> Properties --> General --> lower left corner tick READ ONLY --> Apply--- > Ok. And we are done, basically why you need to do this as game will at random times reset stuff to default, and read only prevents it from doing so.

So tweak around but dont tweak too much, theres a setting that makes the hot girl look like a fatass :o

Feel free to ask any question

Peace.



UPDATE 1



The ANNOYING as HELL intro videos that you cannot skip.

To remove them and Get right to the first menu ( saves time as well and nerves ( jup )) you need to do the following:

Get to the game folder, next navigate to \Enslaved\MonkeyGame\Movies

Now all you need to do is move the following files to some backup folder of your choice

OR

( in rare cases steam may check files before it loads the game and tell you something like
" bla bla bla missing files, redownload them " so do not move them, simply add .bac in the end of each of those files listed below.
Example : Legal_Screen.bik.bac

( what this will do is basically IF your steam forces you to redownload them, after the rename files are still there, but they are different extension so the steam sees them and game cant read them so we get same result of not seeing the videos.

File that we need to move are the:

Legal_Screen.bik
loading.bik
Namco.bik
NamcoBandai.bik
Ninjatheory.bik
Unreal.bik

6 in total

Now if you do not have file extentions enabled in Windows, that means you see not NamcoBandai.bik but just NamcoBandai file, you will not be able to rename the extention as it is hidden. So to change that you need to do the following:

in ANY folder Top left click View --> Options --> Change Folder and Search Options --> ( new windows pops out ) ---> View --> Scroll down a bit and find " Hide extensions for known file types " Untick it --> Apply --> OK


UPDATE 2

MAY CAUSE FPS DROPS

The following increases shadow quality " less edges on shadows and in general better shadowing "

MinShadowResolution=32 change to 64 or 128 ( using 128 myself )
MaxShadowResolution=512 change to 2048 or 4096 ( using 4096 myself )


UPDATE 3

ENSALVED.exe is located in ENSLAVED/BINARIES/WIN32/Enslaved.exe

Next small lag SPIKES or HANGS after videos or cutscenes or scripted scenes have been reported by people. I had them as well and managed to either get rid of them completelly or makes them less then a second so they are bareley noticible.

My bet is that they are caused by your PC loading the next scene or script combination and developers put a lot of scripts at same time, that is what causes them AND as well Motion Blue in this game seems to cause that, I had random spikes when I was turning around very fast.

So we will do 2 things hopefully helping you sort it out

MotionBlur=True make it MotionBlur=False
MotionBlurPause=True make it MotionBlurPause=False as well

If you dont know what motion blur is, its basically an effect that blurs your screen when you turn around and in certain other conditions. if you really like and dont have spikes, keep it on.

Next thing is a small tool you will have to download, what it does is allows the game to use more then 2 Gig's of RAM which in result helped me to decrease the spikes. Basically it allows the game to use as much RAM as the game needs which will result in better loading times and slight increase in performance.

Download link - https://dl.dropboxusercontent.com/u/93086876/Large%20Address%20Aware.exe

Here is the link to Virus Total where I have scanned the file for virus ( for those of you thinking its a hacker tool or virus or what ever you think it is)

https://www.virustotal.com/uk/file/7c8f166f1b0ce555480791e20687f63b86f2682818633a97ccbd31b45fd0514a/analysis/1382880040/

Download, put it into same folder as the " Enslaved.exe "

Next make a backup or Ensalved.exe just in case

Run " Large Address Aware.exe " as ADMIN ( right click on file ---> Run as Admin )

Window will pop out --> Step 1 click the 3 dots " ... " icon on the right choose " Enslaved.exe " click Open --> In step 2 make sure the Tick Box is Ticked ---> Click Save

You are done, hopefully that will help you get rid of those annoying spikes.

UPDATE 3.1
People are reporting that disabling in game Vsync also fixes the issue ( or minimises it )

To disable it use: UseVsync=False as a workaround if you have a lot of screen tearing, try using Nvidia or ATI Vsync (apply it to .exe file). If it persists with ATI/Nvidia Vsync, disable that as well and try playing the game without any Vsync what so ever.

Basically play around with those settings untill you find the best combination for you.


UPDATE 4

For those using controller and even after turning off vibration still have it, do the following:

All the credits for that go to the original author of the post; Backup the files you are about to overwrite if you want to have vibration back later on.
Pseudohalogen 發表:
Put these modified http://www.mediafire.com/download/idvu3rsyb5aa4hm/xinput1_3.dll in your Enslaved\Binaries\Win32 dir if you disable Force Feedback.




最後修改者:cryohellinc; 2013 年 11 月 2 日 @ 下午 2 時 14 分
顯示 1-15,共 161 則回應
< >
Omega Proxima 2013 年 10 月 26 日 @ 下午 2 時 36 分 
need help adjusting the camera turning speed or mouse sensitivity
cryohellinc 2013 年 10 月 26 日 @ 下午 2 時 53 分 
Well that you can do in Options of the game. Go to Options --> Controls and you will see X and Y sensitivity, adjust as you like
Spuzaw 2013 年 10 月 26 日 @ 下午 2 時 54 分 
cryohellinc 發表:
AllowD3D10=False Change to AllowD3D10=True This will enable DX10 in the game ( why the hell add the feature and remove it from options and make game use dx9 as default
http://i2.kym-cdn.com/entries/icons/original/000/004/592/my-brain-is-full-of-♥♥♥♥.jpg ) DX10 will add better effects to the game. ( Visuals aww yeah )
DX10 won't magically add "better effects". The developers need to actually add effect for there to be effects. Changing the game to run in DX10 won't make the game look any different.
HappyZavulon 2013 年 10 月 26 日 @ 下午 2 時 58 分 
Actually I think the DX10 rendering made it look a bit nicer, the shadows are a bit of a mess though on characters, they look grainy.
Omega Proxima 2013 年 10 月 26 日 @ 下午 3 時 02 分 
cryohellinc 發表:
Well that you can do in Options of the game. Go to Options --> Controls and you will see X and Y sensitivity, adjust as you like
Doesnt work unless it changes it by 0.000001
最後修改者:Omega Proxima; 2013 年 10 月 26 日 @ 下午 3 時 08 分
Smoker 2013 年 10 月 26 日 @ 下午 3 時 08 分 
Warning changing AllowD3D10= can crash some games.
cryohellinc 2013 年 10 月 26 日 @ 下午 3 時 24 分 
wazups2x 發表:
cryohellinc 發表:
AllowD3D10=False Change to AllowD3D10=True This will enable DX10 in the game ( why the hell add the feature and remove it from options and make game use dx9 as default
http://i2.kym-cdn.com/entries/icons/original/000/004/592/my-brain-is-full-of-♥♥♥♥.jpg ) DX10 will add better effects to the game. ( Visuals aww yeah )
DX10 won't magically add "better effects". The developers need to actually add effect for there to be effects. Changing the game to run in DX10 won't make the game look any different.
You didnt even test it did you? It does improve the image.


Omega Proxima 發表:
cryohellinc 發表:
Well that you can do in Options of the game. Go to Options --> Controls and you will see X and Y sensitivity, adjust as you like
Doesnt work unless it changes it by 0.000001
Odd, mine works.


Smoker 發表:
Warning changing AllowD3D10= can crash some games.
3 hours on with dx10, 0 crashes.
Spuzaw 2013 年 10 月 26 日 @ 下午 3 時 45 分 
cryohellinc 發表:
wazups2x 發表:
DX10 won't magically add "better effects". The developers need to actually add effect for there to be effects. Changing the game to run in DX10 won't make the game look any different.
You didnt even test it did you? It does improve the image.
No, I don't see the point. I've never heard of a time when changing the renderer from DX9 to DX10 in a UE3 games has ever made a difference in the way the game looks. It requires the developers to use the DX10 features for there to be DX10 features.

Can you at least explain what about the game looks better with DX10? I guess I'll give it a try but I really doubt there's any difference.
最後修改者:Spuzaw; 2013 年 10 月 26 日 @ 下午 3 時 46 分
cryohellinc 2013 年 10 月 26 日 @ 下午 3 時 47 分 
Updated first post.

HappyZavulon 發表:
Actually I think the DX10 rendering made it look a bit nicer, the shadows are a bit of a mess though on characters, they look grainy.
Well problem is they look exactly the same in dx9 mode, I am trying to figure out what causes that. Increasing shadow quality makes them look worse for some reason. I will try to experiment a bit with settings. Game doesn't look bad but shadows are just one minor problem left.
He11y^ 2013 年 10 月 26 日 @ 下午 3 時 48 分 
wazups2x 發表:
cryohellinc 發表:
AllowD3D10=False Change to AllowD3D10=True This will enable DX10 in the game ( why the hell add the feature and remove it from options and make game use dx9 as default
http://i2.kym-cdn.com/entries/icons/original/000/004/592/my-brain-is-full-of-♥♥♥♥.jpg ) DX10 will add better effects to the game. ( Visuals aww yeah )
DX10 won't magically add "better effects". The developers need to actually add effect for there to be effects. Changing the game to run in DX10 won't make the game look any different.

This option don't affect anything, like in another UT Engine games like a UT, ME2/3 and etc witch ones don't oficial support it. Some of you can CTD while try it enable, some not, but it 100% and more 200% don't affect anything else.

"DetailMode=2" if i still clearly remeber, 2 is a maximum number for all last generation UT engine games.

"SkeletalMeshLODBias=0"
"ParticleLODBias=0"

LOD Bias affects the clarity of textures, by determining how Mipmapped textures appear. Higher positive values make things blurrier.
You can use value "-1" and try it. (do not use values lower then "-1"
).In my ME3/2 configs and Bulletstorm i use this values for more sharper things.

About mouse, same section, but another config - "MonkeyInput.ini"

"MouseSensitivity=20.000000" (sensetivity)
"bEnableMouseSmoothing=True" (mouse acceleration, "True" by default, change it "False" to OFF, but zoomed sens will still be horrible)

最後修改者:He11y^; 2013 年 10 月 26 日 @ 下午 4 時 00 分
cryohellinc 2013 年 10 月 26 日 @ 下午 3 時 49 分 
wazups2x 發表:
cryohellinc 發表:
You didnt even test it did you? It does improve the image.
No, I don't see the point. I've never heard of a time when changing the renderer from DX9 to DX10 in a UE3 games has ever made a difference in the way the game looks. It requires the developers to use the DX10 features for there to be DX10 features.

Can you at least explain what about the game looks better with DX10? I guess I'll give it a try but I really doubt there's any difference.
You are correct that it does Not introduce any new effects, however for me it makes the picture a bit more smooth and juicy. Difference is minor at best, however if there is an option to use something that is there, I don't skip it.
Spuzaw 2013 年 10 月 26 日 @ 下午 4 時 08 分 
Just did a comparsion. There is absolutely zero difference when using the DX10 renderer. If anything it looks worse. It's just a placebo, it's not "more smooth and juicy".

Guess what which is which:

http://steamcommunity.com/sharedfiles/filedetails/?id=189362589
http://steamcommunity.com/sharedfiles/filedetails/?id=189362611
Edit: Labled them.
最後修改者:Spuzaw; 2013 年 10 月 26 日 @ 下午 4 時 38 分
cryohellinc 2013 年 10 月 26 日 @ 下午 4 時 23 分 
wazups2x 發表:
Just did a comparsion. There is absolutely zero difference when using the DX10 renderer. If anything it looks worse. It's just a placebo, it's not "more smooth and juicy".

Guess what which is which:
http://steamcommunity.com/sharedfiles/filedetails/?id=189362589
http://steamcommunity.com/sharedfiles/filedetails/?id=189362611
Screenshot 1 looks by far better. However its up to you, dont like dont use, no need to be stuck about it. It doesn't make it looks worse in any case.
Spuzaw 2013 年 10 月 26 日 @ 下午 4 時 28 分 
Yep, screenshot 1 does look far better. And screenshot 1 is DX9.

Now you've said it yourself, DX9 looks far better than DX10 in this game.

Edit: Also, for some reason in this game DX10 prevents AA from working.
最後修改者:Spuzaw; 2013 年 10 月 26 日 @ 下午 4 時 39 分
cryohellinc 2013 年 10 月 26 日 @ 下午 5 時 06 分 
Ok after round 30 minutes of testing, and comparing static screens, you are very correct. It does look better, I guess that was placebo indeed. However on my rig I can still say that certain screenshots have better more clearer lighting conditions. But DX9 is more pleasing, and Yes tested in game AA, it doesnt work in dx10 for some reason. Didnt notice that before as was forcing AA through nvidia control panel.

Removed the dx10 thing from post. Cheers
顯示 1-15,共 161 則回應
< >
每頁: 15 30 50