ENSLAVED™: Odyssey to the West™ Premium Edition
cryohellinc Oct 26, 2013 @ 8:32am
Ugly Shadows
Hello guys

Everything works great, however those shadows are simply horrible. Is there a way to fix this in config maybe?

https://dl.dropboxusercontent.com/u/93086876/Enslaved_2013_10_26_16_19_55_767.png

Can anyone suggest?
Showing 1-15 of 15 comments
< >
MadAsAHatter Oct 26, 2013 @ 11:53am 
You can turn them off completely in the engine.ini.
Spuzaw Oct 26, 2013 @ 12:05pm 
I don't remember any of the shadows looking like that when I played. Not sure what could be causing it.
cryohellinc Oct 26, 2013 @ 12:07pm 
Well, reinstalling the game, maybe something got messed up. "shrug"
Spuzaw Oct 26, 2013 @ 12:09pm 
Originally posted by cryohellinc:
Well, reinstalling the game, maybe something got messed up. "shrug"
Try "verifying the integrity of game cache" before you reinstall. It'll save you a lot of time if that fixes it.
cryohellinc Oct 26, 2013 @ 12:29pm 
Originally posted by wazups2x:
Originally posted by cryohellinc:
Well, reinstalling the game, maybe something got messed up. "shrug"
Try "verifying the integrity of game cache" before you reinstall. It'll save you a lot of time if that fixes it.
I did it, and it didn't find anything. My guess is some file got corrupt.
HappyZavulon Oct 26, 2013 @ 2:55pm 
What card are you using? It seems like you are the only one with this problem for now.

Try messing with the shadow settings, here is a nice guide http://steamcommunity.com/app/245280/discussions/0/792924952664793625/
cryohellinc Oct 26, 2013 @ 3:26pm 
Yeah the guide that I've made.... LOL

And I've sorted it, it was corrupt game file. :)
HappyZavulon Oct 26, 2013 @ 3:43pm 
Oops, I tend to not look at nicknames XD
Blazor26 Oct 28, 2013 @ 12:36pm 
How do I fix the problem with shadows or is this how they look, I verified cache and all is good.
here is a picture
http://postimg.org/image/o8e86g1lx/
[TF] Fallen Nov 14, 2013 @ 7:37am 
Shadow Fix:

LightEnvironmentShadows=False << Make sure this is set to false in baseengine.ini
Sweetz Nov 14, 2013 @ 1:05pm 
Those ugly character self shadows are typical of early UE3 games. Mass Effect 1 in particular had the exact same problem.

If you don't want to disable the dynamic shadows entirely, try changing the DepthBias or ShadowDepthBias setting (only one or the other will be present, name was changed in later versions of UE3). This basically determines the threshold at which the engine determines something "needs" shadow. Higher values = only larger features will cast shadows, lower values = smaller features will cast shadows. E.g. at a very low value the game will try to render dynamic shadows for things like a character's nose casting a shadow on their cheek - which tends to look ugly. At higher settings only large features will cast shadows, like a character's whole head casting a shadow on their body.

Off hand I'm not sure what Enslaved's value is set to - most early UE3 games defaulted to 0.012 (which is also what Mass Effect initially defaulted to), so I'm guessing that's probably Enslaved's default value. Try changing it to 0.030, that's the suggested "go to" value for most other games with the same problem. If it still looks ugly, try bumping it up in increments of 0.01 until you get a desired result.
Last edited by Sweetz; Nov 14, 2013 @ 1:11pm
ChuchoFett Dec 26, 2013 @ 10:02am 
Originally posted by Sweetz:
Those ugly character self shadows are typical of early UE3 games. Mass Effect 1 in particular had the exact same problem.

If you don't want to disable the dynamic shadows entirely, try changing the DepthBias or ShadowDepthBias setting (only one or the other will be present, name was changed in later versions of UE3). This basically determines the threshold at which the engine determines something "needs" shadow. Higher values = only larger features will cast shadows, lower values = smaller features will cast shadows. E.g. at a very low value the game will try to render dynamic shadows for things like a character's nose casting a shadow on their cheek - which tends to look ugly. At higher settings only large features will cast shadows, like a character's whole head casting a shadow on their body.

Off hand I'm not sure what Enslaved's value is set to - most early UE3 games defaulted to 0.012 (which is also what Mass Effect initially defaulted to), so I'm guessing that's probably Enslaved's default value. Try changing it to 0.030, that's the suggested "go to" value for most other games with the same problem. If it still looks ugly, try bumping it up in increments of 0.01 until you get a desired result.

i've tried this and had no improvement .. it keeps looking with that ugly casted mini shadows .. :/ it's mostly in the body models .. haven't seen it yet in other model.
eqzitara Dec 26, 2013 @ 3:27pm 
@chunchofett
I wrote about it, has to do with new patch.
Solution here
http://steamcommunity.com/app/245280/discussions/0/630800443723006141/
Last edited by eqzitara; Dec 27, 2013 @ 12:17am
Marlowe Jan 31 @ 1:06pm 
Originally posted by TF Fallen:
Shadow Fix:

LightEnvironmentShadows=False << Make sure this is set to false in baseengine.ini

This worked for me. Thanks.
SleepyDroid Jun 22 @ 2:33am 
I got t

Originally posted by Marlowe:
Originally posted by TF Fallen:
Shadow Fix:

LightEnvironmentShadows=False << Make sure this is set to false in baseengine.ini

This worked for me. Thanks.

I will try this.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50