ENSLAVED™: Odyssey to the West™ Premium Edition
Bladderfish Oct 26, 2013 @ 8:08am
Games Hangs at First Mech
Is anyone else having a problem where, when you attack the first mech after getting your weapons, the game hangs completely? I've tried amending various graphic options, but nothing seems to make a difference. It's made the game a wipeout, and I'll have to see if I can get a refund if I can't solve it.

Thanks
Showing 1-2 of 2 comments
< >
Molested Bunny Feb 2 @ 10:36am 
This seems to be a bug in the tutorial section rather than a real crash. I had this happen several times(with the addition of Monkeys model disappearing once during the headband kill movie that restarted the checkpoint :D). I tried randomly changing the settings to no avail.
Then when the screen freezing happened and mouse cursor appeared again, i just pressed the attack defense and special attack buttons repeatedly, somehow that cured it, the game unpaused, and i could go on.
Bladderfish Feb 2 @ 1:01pm 
Yeah, I figured this out eventually. Really bad tutorial, but maybe it's something to do with the port over from console, something being lost in translation.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50