ENSLAVED™: Odyssey to the West™ Premium Edition
adrianovaroli Dec 2, 2013 @ 5:01am
Enslaved crashed after selecting "start / continue journey"
I had just installed the game on Windows 7 64bit, and could not get past the game menu. Every time I selected "start new journey" the game would crash. I tried the graphical fixes recommended or mentioned in this forum, and also made sure the game was running with my nVidia GPU, not the integrated Intel GPU my notebook also has. All this was useless. The solution for me was to find the game's binary, Enslaved.exe, and check "always run as administrator" from its properties.

It would have been nice to know.
Showing 1-4 of 4 comments
< >
RadRick01 Dec 4, 2013 @ 12:35am 
I have same issue but mine also crashes in setup menu sometimes. After set up it will loose some of the keyboard settings I put in. Are you using Commodo antivirus? I just switch to it and have had trouble with a few other games untill I whitched to gaming mode. I switched for this but it still crashes.
adrianovaroli Dec 4, 2013 @ 7:48am 
I'm not running Commodo, and have not touched the keyboard settings (I'm playing with a controller only). It seems you're running into some other problem.
RadRick01 Dec 8, 2013 @ 1:02am 
do you have a logitech wireless keyboard and mouse combo? My mouse works poorly in the setup menus.
adrianovaroli Dec 8, 2013 @ 4:17am 
I don't think we're talking about the same problem. Mine was the game crashing after I selected "Start / Continue Journey", you seem to be talking about something else.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50