ENSLAVED™: Odyssey to the West™ Premium Edition
eqzitara Dec 21, 2013 @ 11:24pm
Was new patch done by someone who just guessed at values? [Details inside. Also fix for shadow issues]
[The settings discussed below only matter if you set the game to HIGH]
Unfortunately when people were posting custom solutions[No offense but random] to improving the game they used it looks like the dev's edit-copy-pasted it. There are many self-shadowing anomalies caused by new patch. They are very apparerent during cinematics/story scenes. I'm not trying to be harsh on dev since I really like this game but these values were not tested and lack common sense.

Incase you think I am making this up please go here -> http://segmentnext.com/2012/03/26/tribes-ascend-tweaks-guide-how-to-edit-config-file/
[Its good because it mentions literal max settings allowed by UE3 [non-premium version]]

My solution for anyone with these issues [Im pretty sure its everyone].
Go to.. C:\Users\...\Documents\my games\UnrealEngine3\MonkeyGame\Config\MonkeyEngine.ini
change
MaxShadowResolution=2056
to
MaxShadowResolution=512
[I wanted to use 1024 which is the plausible highest, but exceeding 512 is part of the problem]

change
MaxMultisamples=16
to
MaxMultisamples=1
[This is Multisampling AA. 16x is crazy high... it doesnt matter because this game doesn't even allow Multisampling to work]

ShadowFilterQualityBias=2147483647
to
ShadowFilterQualityBias=8

2056 is an insane value. Its not impossible, some UE3 games will work with that value. Though this is certainly not one of them. NO UE3 game will allow that as a default setting. You would have to modify it yourself if you wanted a value that high. Open any of the latest/oldest UE3 games. Highest value is 1024... Doubling it in an old game without testing will/does cause issues.
The multisamples value is downright INSANE. The highest without modification offered in UE3 is x 4! I actually think that was a miskey because of a Anisotropy [that value is usually 16]. x16 "would" make your game look just as sharp as a 4K display at 720p lol [If the game were to support it, which it doesnt].
ShadowFilterQualityBias=2147483647 Looks more like a phone number then a serious value.
I've looked at over 6 UE3 game's and these are definetly wrong/exceedingly high values.

THESE ARE JUST VALUES I NOTICED.... THERE ARE ALMOST CERTAINLY MORE! I stopped looking after I found my solution.
Last edited by eqzitara; Dec 22, 2013 @ 6:43pm
Showing 1-7 of 7 comments
< >
Amerika Dec 22, 2013 @ 7:38pm 
I think you must have had some of those values in there modified from default because all of the ones you speak of were at the defaults you mentioned and weren't above what the game supports (according to your post). There is a post on here that changes a lot of the values that you mentioned to the exact values you were seeing. So I have a feeling you made those changes as per that guide and then forgot. I also looked at SahdowFilterQualityBias and it defaulted to 0 in my config. I just downloaded the game last week and got the 1.3gb patch recently.
eqzitara Dec 23, 2013 @ 2:53pm 
I deleted my config folder twice and restored it via starting game. I downloaded it yesterday. I also spoke to someone else with game and new patch had same shadow issues I mentioned.

---------------------------------
Did you change you graphic settings to : High?
Last edited by eqzitara; Dec 23, 2013 @ 5:07pm
Morente Jan 31 @ 5:49am 
I still have those ugly rippling stairlike shadows. Any further suggestions?
Jedia Kyrol Jun 19 @ 8:18pm 
can verify that all of that is default from a fresh install...even the ShadowFilterQualityBias. It is also 2^31...meaning the largest number possible in a 32 bit signed ineger...so it's basically a [NULL]
klompf Jul 6 @ 1:52am 
this got it fixed, thanks
shadows still look a bit odd and jumpy at times, but way wayy better anyway
+1 for the phone number pun
soc hexum Jul 6 @ 5:55pm 
Yes this improved it for me
chinaboos Jul 7 @ 11:07am 
OK .........
Showing 1-7 of 7 comments
< >
Per page: 15 30 50