ENSLAVED™: Odyssey to the West™ Premium Edition
I Smell Like Beef Jan 25, 2014 @ 9:10am
So freaking laggy
This game is unplayable for me. I can usually run games on immensely high settings on my computer, but I can't even get decent FPS on low quality with this game. What gives? I'm kind of really annoyed because I dropped 20 bucks on this and now it's unplayable due to the incredible lag I'm experiencing.
Showing 1-8 of 8 comments
< >
Gamer X Jan 31, 2014 @ 10:40pm 
same issue, no idea why but I've tried toying with motion blur and vsync and even low graphcis still ♥♥♥♥ framrate
Gamer X Feb 1, 2014 @ 12:02am 
hopefully I get a dev response at some point as I was really interested in this game but I have to uninstall for now due to unplayability.
terranrus64 Feb 1, 2014 @ 12:05am 
What are your specs?
I Smell Like Beef Feb 1, 2014 @ 9:33am 
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130828-1532)
Language: English (Regional Setting: English)
System Manufacturer: HP-Pavilion
System Model: NY553AA-ABA e9220y
BIOS: BIOS Date: 08/31/09 13:56:34 Ver: 5.02
Processor: AMD Phenom(tm) II X4 910 Processor (4 CPUs), ~2.6GHz
Memory: 8192MB RAM
Available OS Memory: 8184MB RAM
Page File: 5143MB used, 11222MB available

These are my specs. As you can see, I should be fine...
Gamer X Feb 1, 2014 @ 11:44am 
OS: Windows 7 Pro
RAM: 8 GB
CPU: AMD Phenom II X3 740 (3.00 GHz
GPU: GeForce GTX 570

I think this is all the pertinent info
Red Mage Feb 22, 2014 @ 11:55pm 
Yep same issue here. Nothing will bring my FPS up.
saganist Jun 19, 2014 @ 1:31pm 
I thought this game would perform well considering it's using Unreal Engine 3.
zeroxxx Jun 19, 2014 @ 5:05pm 
It's working silky smooth on my rig.

GT645m + i7 3517u + 6 GB RAM.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50