ENSLAVED™: Odyssey to the West™ Premium Edition
Wiesenberg Jun 22 @ 5:48pm
Chapter 3 Mech Boss
Is anyone else experiencing a glitch in the fight where the mech doesn't break through the wall and just appears? I've reloaded the checkpoint three times and it keeps having the same result with the wall intact. I'm unable to complete the chapter because of this.
Showing 1-15 of 29 comments
< >
robs07mazda6s Jun 22 @ 7:12pm 
Im past chapter 3 and did not have that problem. Are you taunting him so he charges?
Wiesenberg Jun 22 @ 7:15pm 
That's just it, it does the mini cutscene where it shows the wall and you can hear him busting through it but the wall doesn't budge and he doesn't appear until you move around or taunt after a few seconds of the cutscene happening.
robs07mazda6s Jun 22 @ 7:39pm 
So after he appears can you not defeat him?
Wiesenberg Jun 22 @ 8:12pm 
I can. But the wall is still there. I can't go through.
robs07mazda6s Jun 22 @ 8:14pm 
That is a odd problem, i hate to say it but you might need to uninstall and then reinstall the game. Back up your save first if you can and also try to verify the game cache integrity before you go through the trouble of reinstalling.
TheCakeIsaPie Jun 22 @ 8:39pm 
I am having the exact same problem. If robs' advice doesn't work I'll comment again.
Wiesenberg Jun 22 @ 8:48pm 
It'll be one of the first things I shall try tomorrow.
Atomicnoise Jun 22 @ 8:59pm 
I have the same glitch. You drop down, fight the enemies, then the boss "breaks through the wall" (but the wall is still there, he actually doesn't appear, you hear him, see the dust form the wall "breaking", then he teleports in.) You can fight him just fine, although hes a bit derpy, if he charges too close to a wall, he will just keep running at the wall infinitely. If you manage to beat him, Trip drops down, and tries to run at the wall, infinitely. I have restarted the level completely, I have verified game files multiple times etc. Nothing fixed it. How do I make sure the save files are backed up before a re-install again?
Atomicnoise Jun 22 @ 9:07pm 
OK guys! I figured out an easy solve! Before/during the boss fight, just switch your graphics settings to high! I read this on a previous post about the issue, so credit goes there, sorry. Something to do with higher setting ACTUALLY having completely different physics! He will even break down the little barrier walls! WTF?!?! Who the hell programmed this game!?!? Anywho, its an easy fix, just keep an eye out for similar issues with this physics change further into the game. But seriously, wow.
TheCakeIsaPie Jun 22 @ 9:11pm 
Wow is right. OK, thanks for the help! It's frustrating to be a poor peasant who can't afford a fancy rig.
Wiesenberg Jun 22 @ 11:01pm 
Thank you so much Atomic. I needed that XD I just bought it like 2 days ago lol
Miglo Jun 23 @ 9:44am 
Thanks!!
robs07mazda6s Jun 23 @ 6:07pm 
LMBO that is indeed dumb but no wonder I did not experience this glitch since im playing with max settings.
Cleo Jun 23 @ 6:12pm 
the wall breaking isnt the only thing that shows up on high graphics setting. The mines and the deactivated bots have blue rings around them that tell you how close you 'shouldnt' get to them.
Wiesenberg Jun 23 @ 6:34pm 
I just noticed that too Cleo. The high graphics setting trick worked. Wish they'd patch it so you can keep the setting low though. That would help greatly
Showing 1-15 of 29 comments
< >
Per page: 15 30 50