Krayzel Nov 17, 2013 @ 8:29pm
Finally solved the "moving left" issue!
Okay guys, I'm not saying this is gonna work for everybody, but it might help some people so I'm sharing the tip with you.

I'm using Windows 7 64-bit on a laptop, with no controller ever plugged, and I was having that issue where the game (and not any other one) was acting like my left key was stuck. I had tried both the stable and unstable build but without success.

And then, I remembered that in order to get the Bêta Steam Hardware badge, I had installed that software called vJoy that allows you to emulate a virtual joystick on your computer. It wasn't even launched so I didn't think that could cause a problem, but since I had no use for that software anymore, I just uninstalled it. And guess what... the game works perfectly now.

So if anyone has vJoy or something like that on his/her computer... you know what to do.

Have fun!

EDIT: Thanks for the pin, hoping it helps!
Last edited by Krayzel; Nov 18, 2013 @ 7:50pm
Showing 1-15 of 15 comments
< >
Black Majic  [developer] Nov 18, 2013 @ 7:48pm 
Installing vJoy did indeed cause this issue to start on my Win7/x64 machine. Uninstallation resolved it.
I'm about to contact the developers so we can work on a proper fix, but at this time, the only solution we have is to uninstall vJoy.

IF uninstallation of vJoy does not resolve the issue for you; please post your system and os specs.
Andy Anderson Nov 19, 2013 @ 1:44am 
This did the trick. It's finally solved. Thanks!
DzejPi Nov 22, 2013 @ 11:04am 
I found another way, guys. I had the same problem caused by vjoy, so I uninstalled it, but it still didn't work. I found out that vjoy is still active in your computer as a device. So you have to delete vjoy from Device Manager too.
How can you make it? It's not hard. Run console - type "cmd" into Start. And write:
joy.cpl
there. You will get it's name as device. It's name probably will be "Generic Virtual HID Driver". So now you have it's name. Now type "Device manager" into Start and press enter. Find it there, right click on it and forbid it or uninstall it, if you are hardcore! And that's all, this solved problem for me!
Last edited by DzejPi; Nov 22, 2013 @ 11:07am
da_wrecka Dec 2, 2013 @ 1:33pm 
The problem is that this game has ♥♥♥♥-poor controller support. Using my 360 controller, (And I've never even HEARD of this vJoy thing before this thread) I try to rebind the controls and it instantly skips Up. Then when I press my analogue stick down - the D-pad does nothing - it instantly skips over Left and Right too, assigning all three directions based on one tiny push.

So yeah. This game is unplayable with controller.
Black Majic  [developer] Dec 3, 2013 @ 11:30am 
@da_wrecka Joysticks and the 360 dpad function the same way since the engine handles them all as axis. The keybinding screen takes input from them only for UDLR and disregards them, leaving all joystick input to be -x = left, x = right, y = up, -y = down. It is possible that your joystick centrepoint is offset causing this issue. Try calibrating it - http://support.xbox.com/en-GB/xbox-360/accessories/calibrate-controller-for-windows-pc

@boazlaurens You're the first case I'm aware of this happening on a mac. I'd be glad to work with you to try and resolve the issue. Are you moving left without the controller plugged in? if not, it could again be the calibration.
Black Majic  [developer] Dec 4, 2013 @ 9:27am 
@boazlaurens Use the mouse to navigate to the options menu and then select rebind controls.
@Liko On Mac? Try rebinding the controls from the options menu.
Liko Dec 4, 2013 @ 11:52am 
I'm on windows. It's very hard to rebind controls. Generaly, just move to one direction with the pad take two or three controls (for example, for the Up control, I push the pad to Up, but it take Up and left or whatever control after the Up control). Hope you understand, my english is kind of approximative.
Liko Dec 4, 2013 @ 1:04pm 
After looking carefully, just the Right and Left control are skipped. I can set the Up and Down, but I an just see a flash of right and left controls, and then I see Jump control. My controller is perfectly calibrated, works fine on other games. I use a Thrustmaster Dual Analog 4 with x360ce. I tried without, it's the same.
Black Majic  [developer] Dec 4, 2013 @ 1:28pm 
The keybinding should ignore the joystick, it's mainly meant for buttons.
Does the selection box move when the joystick is not plugged in?
Jave Dec 21, 2013 @ 8:28pm 
I'm still having the issue. I use a Mayflash Wii Classic Controller to USB adapter, and it works with most other games. At worst I use Joy2Key if it doesn't. But in ESJ I have constant left motion. The problem wasn't there when I first got the game around August, but I also updated my gamepad drivers around then so that could be related. Unplugging my controller solves the issue but this is not a game I want to play on a keyboard. Could you at least add an option to just disable gamepad input so I can use Joy2Key to play this?
waste Dec 24, 2013 @ 2:52am 
I also have the problem with Left - Right. The game does not accept the Joystick Input (POV Input) Up and Down Input works.
Last edited by waste; Dec 24, 2013 @ 3:00am
Roll Jan 19 @ 6:35am 
Originally posted by Jave:
I'm still having the issue. I use a Mayflash Wii Classic Controller to USB adapter, and it works with most other games. At worst I use Joy2Key if it doesn't. But in ESJ I have constant left motion. The problem wasn't there when I first got the game around August, but I also updated my gamepad drivers around then so that could be related. Unplugging my controller solves the issue but this is not a game I want to play on a keyboard. Could you at least add an option to just disable gamepad input so I can use Joy2Key to play this?

I'm also using the same exact controller and get this issue. A disable gamepad function would be great so that we can assign the buttons to the keys instead. I really prefer playing platformers with a controller and would greatly appreciate this.
rio Jan 21 @ 10:24am 
same problem. unplayable. If i press a button on my controller (thrustmaster upad) it moves to left and top instantly. Please fix that.
Last edited by rio; Jan 21 @ 12:21pm
Vilacinha Feb 21 @ 3:56pm 
Originally posted by DzejPi:
I found another way, guys. I had the same problem caused by vjoy, so I uninstalled it, but it still didn't work. I found out that vjoy is still active in your computer as a device. So you have to delete vjoy from Device Manager too.
:explore: How can you make it? It's not hard. Run console - type "cmd" into Start. And write:
joy.cpl
there. You will get it's name as device. It's name probably will be "Generic Virtual HID Driver". So now you have it's name. Now type "Device manager" into Start and press enter. Find it there, right click on it and forbid it or uninstall it, if you are hardcore! And that's all, this solved problem for me! :B1:
I did this and now i can't move at all... please help

EDIT: i solved it, i went to >options>reset control bindings and now it works! :D
Last edited by Vilacinha; Feb 22 @ 10:17am
kaserei Oct 19 @ 2:41pm 
Originally posted by Black Majic:
Installing vJoy did indeed cause this issue to start on my Win7/x64 machine. Uninstallation resolved it.
I'm about to contact the developers so we can work on a proper fix, but at this time, the only solution we have is to uninstall vJoy.

IF uninstallation of vJoy does not resolve the issue for you; please post your system and os specs.

Sorry to say I don't play your game, but I have written a vJoy feeder application for rudder pedals recently and know why this happens and what to do about it.

I had exactly the same problem in ALL games that recognise the 1st Direct Input device on the development machine after using my rudder mapping program. My program takes x and y axis of a selected Direct Input device, and maps them to a centre resting single X-axis on vJoy Device #1. When terminated I simply relinquished the input and output devices, leaving the vJoy device axis centred, ie. half way up. This effect is persisted on the device, even following reboots.

To Fix, I simply added a call to the vJoy device ResetAll() in the close down code that unpresses all buttons, and sets all axes to 0. It might be possible for your application to do something similar before startup, to make sure any vJoy device axis are zero'd.

Hope this helps.

ps. I was actually looking for help with disappearing vJoy devices when I came here..


Showing 1-15 of 15 comments
< >
Per page: 15 30 50