Foul Play > General Discussions > Topic Details
Stümmel im Getümmel Nov 3, 2013 @ 9:42am
Game doesn't start (Linux)
Sadly, i'm unable to start this game.
Actually it's starting up in my system monitor, this is where i need to kill the process, but theres no window or any clue that the game's started on my desktop, except when i try to start it again via steam a message pops out that this game is already running.

I've tried to start it out of a terminal, but it looks like that everythings goin on normally.


Any suggestions?

Thanks in advance

edit: opensuse 12.3 64bit
Last edited by Stümmel im Getümmel; Nov 3, 2013 @ 9:45am
Showing 1-10 of 10 comments
< >
Tak! Nov 9, 2013 @ 9:12am 
Same here (ubuntu 13.10 x86-64)
Backtrace:
Starting program: /home/levi/Steam/SteamApps/common/Foul Play/./foul_play
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Setting breakpad minidump AppID = 244810
Steam_SetMinidumpSteamID: Caching Steam ID: 76561197988608600 [API loaded no]
[New Thread 0xf0105b40 (LWP 5899)]
[Thread 0xf0105b40 (LWP 5899) exited]
[New Thread 0xf0105b40 (LWP 5900)]
foul_play: malloc.c:3637: _int_malloc: Assertion `(unsigned long)(size) >= (unsigned long)(nb)' failed.

Program received signal SIGABRT, Aborted.
0xf7fdb430 in __kernel_vsyscall ()
(gdb) bt
#0 0xf7fdb430 in __kernel_vsyscall ()
#1 0xf7b2baff in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#2 0xf7b2f083 in __GI_abort () at abort.c:90
#3 0xf7b72d79 in __malloc_assert (assertion=assertion@entry=0xf7c6c518 "(unsigned long)(size) >= (unsigned long)(nb)", file=file@entry=0xf7c67aed "malloc.c", line=line@entry=3637,
function=function@entry=0xf7c67deb <__func__.11065> "_int_malloc") at malloc.c:288
#4 0xf7b75b7e in _int_malloc (av=av@entry=0xf7cad440 <main_arena>, bytes=bytes@entry=696) at malloc.c:3637
#5 0xf7b76d08 in __GI___libc_malloc (bytes=696) at malloc.c:2859
#6 0xf7f8087c in ?? () from /home/levi/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#7 0xf7f70dca in SDL_VideoInit () from /home/levi/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#8 0xf7f47252 in SDL_InitSubSystem () from /home/levi/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#9 0xf7f472eb in SDL_Init () from /home/levi/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#10 0x081131c7 in renderer_t::renderer_t (this=0x81d52b8) at src/renderer_gl.cpp:43
#11 0x080c8e0e in real_main (argc=1, argv=0xffffd014) at src/main.cpp:88
#12 0x0804ae3b in main (argc=1, argv=0xffffd014) at src/main_linux.cpp:7
Scampwick  [developer] Nov 19, 2013 @ 3:33am 
Hey guys,

It sounds like something display related if the process is recognised as running in the system monitor but not visually running... I'd suggest giving the following steps a try:

-In your Game Library on Steam, right click Foul Play.
-Under the 'GENERAL' tab, select "SET LAUNCH OPTIONS"
-In the "Launch Options" box that opens, type: -force_windowed
-Try launching the game - it should now be in windowed mode.
-Customise the 'DISPLAY' settings in option as you see fit.

Hopefully this solves the issue. Please let us know.
Stümmel im Getümmel Nov 19, 2013 @ 8:08am 
Yay, thats it. Thank's a lot
Tak! Nov 20, 2013 @ 6:45am 
Hm, that lets me load the game, but I can't set any of the fullscreen modes.
Tak! Nov 29, 2013 @ 2:20pm 
Aha - for me, it's actually my gamepad (a ps3 controller connected via bluetooth) that triggers the issue. I can launch in fullscreen or windowed mode without it; can't launch at all with it. I never tried without the gamepad until I read the force_windowed suggestion, and I was somewhere without it at the time.
cicyractu Dec 15, 2013 @ 2:18pm 
I too have this problem (on Ubuntu 13.04 x86-64) when two gamepads (of any type) are connected at game launch. Tried different combinations of two PS3 controllers via bluetooth and a Genius USB gamepad. No luck. The game starts fine when only one controller is present (however, it won't detect newly connected ones).
D. Mouse Dec 22, 2013 @ 2:20pm 
The two-controller factor could be what I'm experiencing, too. Earlier on when one controller was connected the game launched and was visible first time, but when I had two controllers the game didn't display and I had to kill it via htop; the second time I ran it (still with two controllers), it displayed okay.

I'm using two Wireless Xbox 360 controllers via one wireless receiver.
Last edited by D. Mouse; Dec 22, 2013 @ 2:20pm
HexDEF6 Dec 24, 2013 @ 2:23am 
same problem here, with logitech G13 + ps3 controller the game does not start (the process run but nothing showing up), if I disconnect the ps3 controller the game start
weaponx69 May 29, 2014 @ 8:55pm 
I got the same issue. Will this issue be fixed soon?
Melo Jul 18, 2014 @ 2:56am 
Strangely enough Foul Play refuses to start as soon as I add the --force-feedback option as argument when starting xboxdrv. Does Foul Play support force-feedback at all?
Showing 1-10 of 10 comments
< >
Per page: 15 30 50

Foul Play > General Discussions > Topic Details