Foul Play > General Discussions > Topic Details
Suspicious Cat Dec 1, 2013 @ 9:59am
Foul Play crashes like crazy, controller is terribly mismapped.
The game crashes pretty much any time I try to run it. The first thing that shows up is the screen concerning configuring the controller. If I try to configure, it crashes right away. If I skip this step, it loads to the menu but everything is mismapped. Using a wired 360 controller (and the same issues with a PS3 controller) I have issues like the start button being ignored, A and B are swapped, the game only recognizes certain directions from the joystick, such as recognizing an up but not a down command. I have verified the integrity of the cache and uninstalled and reinstalled the game to no avail.

System info: Windows 7 Ultimate 64 bit. I am running on a mid-2009 MBP, but I honestly don't think that's the cause. I got the driver package for Boot Camp from Apple's site, the only driver that wouldn't install was the Nvidia driver, which I was able to obtain from their website.

I'm inclined to believe this is an issue with Foul Play and not my system, as every other game/ function is working perfectly. I just used the controller with Castle Crashers and it played without issue. If there's anything that I can test or check I'll be happy to try it out.
Showing 1-9 of 9 comments
< >
TitanicTitan Dec 7, 2013 @ 5:08am 
I have a system near enough the same and foul play has never crashed/bugged etc. I don't know about the controller problems though, because I completed the thing with keyboard.
[TGR] brazenhead89 Dec 7, 2013 @ 2:09pm 
I'm having similar problems. Have since given up on the developers doing anything about it.
TitanicTitan Dec 7, 2013 @ 2:13pm 
Originally posted by TGR brazenhead89:
I'm having similar problems. Have since given up on the developers doing anything about it.
as stated above, I have never encountered these problems, and I have a set-up near enough the same
Suspicious Cat Dec 7, 2013 @ 4:04pm 
Originally posted by TitanicTitan26:
Originally posted by TGR brazenhead89:
I'm having similar problems. Have since given up on the developers doing anything about it.
as stated above, I have never encountered these problems, and I have a set-up near enough the same

Honestly not to sure how helpful "I'm not having this issue" is. Still though, what kind of system are you on? Are you using a Windows Partiton on a MacBook Pro? What's the model of the MBP and what version of Windows are you running?
TitanicTitan Dec 8, 2013 @ 3:36am 
Originally posted by Dogma:
Originally posted by TitanicTitan26:
as stated above, I have never encountered these problems, and I have a set-up near enough the same

Honestly not to sure how helpful "I'm not having this issue" is. Still though, what kind of system are you on? Are you using a Windows Partiton on a MacBook Pro? What's the model of the MBP and what version of Windows are you running?
Windows 7 home premium, NOT running on a MacBook, 64 bit, and I never used anything from apple, stating again NOT a MacBook, the problem could be that Foul Play doesn't support Mac
Suspicious Cat Dec 8, 2013 @ 8:49am 
Originally posted by TitanicTitan26:
Originally posted by Dogma:

Honestly not to sure how helpful "I'm not having this issue" is. Still though, what kind of system are you on? Are you using a Windows Partiton on a MacBook Pro? What's the model of the MBP and what version of Windows are you running?
Windows 7 home premium, NOT running on a MacBook, 64 bit, and I never used anything from apple, stating again NOT a MacBook, the problem could be that Foul Play doesn't support Mac

Then how is that a similar system? That's about as different as it gets haha. For the record, it does support Mac, there is a Mac version of the game on the Steam store. It also shouldn't make a difference that I'm running on a MBP, because it's a separate Windows partition and all the drivers are there. I'm also inclined to believe it's a problem with Foul Play itself, because every other game on the Windows partition has run perfectly, with and without a controller.

I also have it installed on Steam for OSX and it runs fine there. It could be an issue with Ultimate maybe.
micmon Dec 24, 2013 @ 4:37am 
No crashes or other issues encountered on Linux so far
Frono Trigger Dec 24, 2013 @ 6:21pm 
Same. incredibly disappointed because it runs fine until it's time to actually play. On Windows Vista Home Premium
Last edited by Frono Trigger; Dec 24, 2013 @ 6:28pm
TitanicTitan Dec 25, 2013 @ 1:13am 
Originally posted by Frono Trigger:
Same. incredibly disappointed because it runs fine until it's time to actually play. On Windows Vista Home Premium
Windows vista is buggy as hell.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50