King Arthur II - The Role-playing Wargame
~Wrath~ Jun 22, 2013 @ 3:37am
For those with performance issues.
I just bought this game and spent a frustrating hour trying to understand why it ran so poorly on my high end rig,

Looking at few forum enteries I saw that I wasnt the only one, game has an odd issue I suspect caused by admin mode and way steam accesses files on 64bit systems, if you where to start game through game library, if anything like me, you would experience incredibly long loading times and the game its self would work slow and choppy with horrible fps.

Solution 1 would be to go to c/program86/steam/steamapps/common/kingarthur2 and run KingArthurII_AutoSetup In admin mode, i know seems like a dumb solution but it works

Solution 2, alternatively if you still having issues you may instead run CoreTech2_x64_11 located in same folder as solution 1, for me this is the one that reduced 3 minute loading times to 10 seconds giving an insane fps/performance boost as well.

If this helped, then Cheers :)
Showing 1-9 of 9 comments
< >
Roslof Jun 23, 2013 @ 8:37pm 
Solution 1 seemed to work for me in the prologue but in the main campaign im getting that unit stuttering again. Ill have to check out solution 2 later.
Roslof Jun 24, 2013 @ 6:54pm 
I wasnt able to get to a battle with the 2nd option I ended up crashing.
~Wrath~ Jun 24, 2013 @ 8:08pm 
from what I read it has to do with your windows, the low performance fix above is for the 64 bit windows versions, the 32 bit people should have no issues. That particular .exe when ran in admin was for the dx11 campatable videocards on 64 bit windows, try one of the other once based on your specs, hope it works!
Roslof Jun 25, 2013 @ 12:19pm 
Well I have tried the one for 64 and that doesnt work either. I have to redirect the launch from steam since if i just do it from the folders im not able to load a game. In the main game I am now getting choppy unit animations and the game crashes when i try to bring a unit from the reserve to my main army. None of this happened after my first initial fixes for the prologue.
~Wrath~ Jun 25, 2013 @ 3:13pm 
ugh, something seems broken XD try running that verify file integrity thing from steam XD
CorporateHammer Jul 11, 2013 @ 3:55pm 
2 worked but had to run as admin, win 7 64bit
~Wrath~ Jul 11, 2013 @ 4:56pm 
good to hear :) yeah you gotta run as admin or load/save/campaign doesent show up XD
kamilkulczyk Jul 20, 2013 @ 12:14pm 
DEVELOPERS :
Please,please,please fix those issues. Game looks fantastic and its exactely what I want to play. Fix those bugs and i will not wait for promotion to buy it!!!!!!!!!
~Wrath~ Jul 20, 2013 @ 3:02pm 
Originally posted by kamilkulczyk:
DEVELOPERS :
Please,please,please fix those issues. Game looks fantastic and its exactely what I want to play. Fix those bugs and i will not wait for promotion to buy it!!!!!!!!!

Unfortnately the game came out early 2012, its mid/late 2013, we cant expect them to release any fixes so will have to rely on the comunity for a self fix XD, a pity since a game its self is very decent.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50