King Arthur II - The Role-playing Wargame

King Arthur II - The Role-playing Wargame

View Stats:
Viadric Apr 22, 2014 @ 3:36pm
LOW FPS?
I have:
Nvidia780TI
16 GB 1600 MHz RAM
I-5 3570K
Windows 8.1 64 bit

The game is running at 17 fps on ultra on DX11. I don't know what's going on?
< >
Showing 1-6 of 6 comments
Sir Jonas, der Große Apr 24, 2014 @ 9:14am 
Yeah. I know the problem. The fps balance of the game is ♥♥♥♥!!!
But I dont have an idea how to fix it....
Phantus Apr 28, 2014 @ 12:07pm 
You have to run it outside of Steam. Go to your Steamapps folder and run hte .exe from there. It's the only way to play it. FPS should be much better.
Sir Jonas, der Große May 2, 2014 @ 11:59am 
Originally posted by Phantus:
You have to run it outside of Steam. Go to your Steamapps folder and run hte .exe from there. It's the only way to play it. FPS should be much better.

Thanks! That sounds good! I will try it!
Locked,Cocked n Lewded May 6, 2014 @ 8:09am 
could be your cpu's bottlenecking the gpu. . .for everything @ultra settings,i5s blow fat ones.
Viadric May 7, 2014 @ 7:05pm 
Originally posted by Sly_Koopa:
could be your cpu's bottlenecking the gpu. . .for everything @ultra settings,i5s blow fat ones.
'
yeah nice try little ♥♥♥♥♥
[☥] - CJ - May 16, 2014 @ 10:24pm 
Umm.. an i5 3570 is not a bottleneck, especially if overclocked..
So someone doesnt know what theyre talking about.

Off hand, id say make sure the GPU is actually running in 3D mode instead of 2D/idle.
If theres a problem with the drivers or if the driver crashes that tends to happen which is what gives such low fps.

The game doesnt really need to be in Ultra though for it to look good even if you have the proper hardware, which you do.
Last edited by [☥] - CJ -; May 16, 2014 @ 10:26pm
< >
Showing 1-6 of 6 comments
Per page: 15 30 50