Divekick > General Discussions > Topic Details
Mega SlowBro, Eh Aug 21, 2013 @ 1:41pm
Slowdown. unplayable, regretting my purchase.
I cant go to the forums because im currently locked out of my e-mail. (cant activate account). but I really need some help. The game is running slow for me, the menus are slow, the matches are slow, everything is slow. for example if I get into a match, it taks nearly two minutes to start fighting. I cannot even play. It makes no sense I have a powerful PC, I can run any other games fine, but why is this the one to break my pc? I mean look at it... Is anyone else getting any problems with extreme slowdown? not just low fps but seriously slow. Please help, or give me some suggestions on what I might be able to do.
Showing 1-15 of 19 comments
< >
Keits Aug 21, 2013 @ 2:03pm 
I'd like to see the DxDiag.exe output from your PC to see what you have under the hood. The first thing to try is to make sure your in-game video settings are fullscreen, 720p, UI set to low.

Can you run other modern games?
TheRealDealReece Aug 21, 2013 @ 2:10pm 
I am playing at 1080p at high and no lag at all, it is probably an optimization issue, I would say to make a new email and send in your system specs to the support forums when you get the chance.
Miss Fish Aug 21, 2013 @ 2:32pm 
Lower the graphics settings and your game's resolution.

Don't blame the game for you computer problems.
Darxio Aug 21, 2013 @ 3:43pm 
We need more info if you want us to help ya, OP.

For all we know you could be on Windows ME(Oh god I hope not).
doc Aug 21, 2013 @ 4:48pm 
Why do people say they have problems running a piece of code, then provide nothing to help other people diagnose the issue?

dxdiag.exe output would be A+

Basic computer stats would be good.

An explanation of what you've tried would be swell.

Perhaps the current settings you are using would also be neato.

Really anything but "ITS SLOW."
Keits Aug 22, 2013 @ 10:09am 
If you no longer need help, let us know you fixed it!
Mega SlowBro, Eh Aug 23, 2013 @ 10:58am 
------------------
System Information
------------------
Time of this report: 8/23/2013, 14:55:38
Machine name: ANDREW-PC
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130318-1533)
Language: English (Regional Setting: English)
System Manufacturer: MSI
System Model: MS-7599
BIOS: Default System BIOS
Processor: AMD Phenom(tm) II X4 905e Processor (4 CPUs), ~2.5GHz
Memory: 8192MB RAM
Available OS Memory: 8192MB RAM
Page File: 6160MB used, 10220MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 64bit Unicode


Sorry for the late reply. I was in the hospital :P
Keits Aug 23, 2013 @ 11:06am 
Oh wow, I'm sorry to hear that. I hope everything is okay.

Have you tried different graphics settings? We recommend running at fullscreen 720p with UI set to low. It might also be good to run a virus scan and make sure all other programs are closed when playing just to be sure your system isn't somehow bogged down.

Your system is more than enough to run this, and we've seen it run flawlessly on similar setups, so it will be tricky to diagose what might be wrong.
Mega SlowBro, Eh Aug 23, 2013 @ 11:19am 
Alright, Ill run a scan and then try running it with those settings.
Thanks.
Mega SlowBro, Eh Aug 23, 2013 @ 12:06pm 
I did a scan and removed some junk I found, then tried the game with those settings. Still no luck... The menus are very slow, and then after I select things, for example my character there is a long delay before the game goes to the next part. then the loading screens are around 4 minutes. and the actual game seems to be going at 1/3 its normal speed. what other info could I give you that may help? I really dont know whats wrong because I can run any other games fine, me and my friend have been playing through dead space 3 and ive got that maxed out with no lag. Is this just a bad pc port?
Darxio Aug 23, 2013 @ 12:27pm 
Just wondering... is this a Desktop or Laptop? I'm assuming desktop due to hospital stay.

Edit: Also, what graphics card are you running in it? Didn't see it in the dxdiag(Unless I'm blind)
Last edited by Darxio; Aug 23, 2013 @ 12:30pm
Keits Aug 23, 2013 @ 1:40pm 
Is your monitor set to run at under 60 fps?
Mega SlowBro, Eh Aug 23, 2013 @ 2:05pm 
Im not sure... Where do I check that?
Darxio Aug 23, 2013 @ 2:13pm 
In windows 7, right click your desktop background and select screen resolution. Click Advanced settings, click the monitor tab, and it should show the refresh rate. Ideally you want the number there to be 60.

Also, what's the graphics card in your computer? Or is it integrated?
Last edited by Darxio; Aug 23, 2013 @ 2:14pm
Mega SlowBro, Eh Aug 24, 2013 @ 5:58pm 
Ive got a radeon 6850, and my refresh rate was set to 60...
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Aug 21, 2013 @ 1:41pm
Posts: 19