realMyst: Masterpiece Edition

realMyst: Masterpiece Edition

View Stats:
*Emberfall* Feb 27, 2014 @ 4:30pm
Patch is up.

"Thanks everyone for your feedback and for your patience while we were working on addressing the critical issues for this update!

We've made many bug fixes and optimizations to realMyst: Masterpiece Edition and here's what's new:

- Optimized a whole bunch!
- Improved performance quite a bit!
- Fixed a possible crash bug
- Figured out that those black boxes are a motion blur bug on Mac AMD cards
- Optimized and improved the Auto-Quality system
- Reduced the application size just a bit
- Optimized and fixed some bugs in Hint Overlay system
- Optimized the cursor system a little to improve performance
- Optimized the Auto-save system
- Adjusted the High Quality setting details
- Re-ordered the graphic options in the advanced list by resource cost
- Removed the Auto-save panel (because… well, it’s just not needed)
- Adjusted the position of the New Game panel
- Updated the opening credits
- Added a check when the App quits for non-valid reasons when auto-saving
- Adjusted the text of the Quit Dialog
- Corrected the direction rotation sounds in Mechanical
- Squished a bug on the Imager Panel
- Fixed potential bug with right click rotating in node mode in elevator
- Corrected Mechanical Linking Book video
- Added more help to the Help Guide"

Woo Hoo!! Thanks Cyan!!

(Time for a little test drive).


I am so happy to report that the micro-freeze (stutter) bug has been thoroughly squashed!! Rest In Peace (Pieces) bugs. :)

For all of you at Cyan - You ROCK!!
Last edited by *Emberfall*; Feb 27, 2014 @ 5:06pm
< >
Showing 1-15 of 36 comments
Asses of Fire Feb 27, 2014 @ 5:16pm 
Great fixes. Now please add an option to keep the cursor fixed in the middle of the screen. It's irritating having to hold the right button down to look around.
jaustin Feb 27, 2014 @ 5:56pm 
Any change to the completely unplayable controls with no customization options? Otherwise it's still a huge "don't bother". I really want to play this game but the controls are too tedious to make it any fun at all.
Last edited by jaustin; Feb 27, 2014 @ 5:57pm
Snegdod Mar 1, 2014 @ 6:18pm 
And THAT is how you patch a game! Thanks Cyan! Quick work that turned a stuttering unplayable game into good times! Other gaming companies should take note....I'm looking at you InfinityWard / Activision.
amfomy Mar 3, 2014 @ 1:49am 
Well, it WAS a major failed first release - who wants stuttering in a game that's primary feature is real time movement?!
Anyone able to comment on system temps after the patch? Glad to see optimizations being nailed and performance increases all around but I'd like to see if it's helped systems not run quite as hot too.

Thanks in advance!
Asses of Fire Mar 4, 2014 @ 9:21pm 
With full graphics options enabled I was schocked to see the bad fps with a 660 gtx. I thought i could run this max settings but apparently not. I'm not getting any issues with a hot pc though.
Jackson Mar 4, 2014 @ 10:22pm 
Improved performance a lot for me (running on an Ivy Bridge ultrabook) so really appreciate this patch. Further patches would still be great though! For whatever reason this game causes my PC to kick out a ton of heat. Yes, it's a laptop, but I've played Skyrim, Civ 5, and plenty of other games on it and can say realMyst ME is definitely special in this regard.
Fimbulvinter Mar 5, 2014 @ 2:46am 
The patch hasn't fixed one of the major bugs - the Crash to Desktop when opening the game for many users, with many still reporting it as being unloadable, much less unplayable. Cyan has suggested a hotfix for this issue, but it only works in a minority of cases, and is by no means a solution. Further patching will be needed to resolve this issue.

For reference, the hotfix is to set the following in the launch options exactly as it appears


When combined with the patch, this allowed me to play the game, but without it, it cotinues to CTD
Last edited by Fimbulvinter; Mar 5, 2014 @ 2:56am
Petutski Mar 9, 2014 @ 1:08pm 
How do I get the patch? I redownloaded Myst and still get an abort every time it launches. HELP
Petutski Mar 9, 2014 @ 2:20pm 
Tried the -force-d3d9.............did not work. Where did you set the launch options?
Petutski Mar 9, 2014 @ 4:48pm 
This patch would be nice if I could actually run the game.
*Emberfall* Mar 9, 2014 @ 6:09pm 
Originally posted by mike_papa:
This patch would be nice if I could actually run the game.

Please list your full system specs and any error messages that you are getting. Are you on a laptop or a desktop? Have you tried verifying the integrity of your game cache? If you don't know how just ask.
Last edited by *Emberfall*; Mar 9, 2014 @ 6:09pm
Petutski Mar 10, 2014 @ 8:30pm 
I have found a solution that works for me about 75% of the time. I have a Surface Pro 2 tablet/pc with 8GB of ram. This machine has DirectX 11 and Windows 8.1 with an Intel Graphics display interface (on-board).

First, I made sure that the refresh rate on the monitor (I use an external monitor - 1920x1200) was set to 60Hz. I noticed that it was set to 50Hz, so I changed it.

Next I created a shortcut to "myst.exe" on my desktop, but used the Command Prompt "start" function to launch Myst.exe. The target in the shortcut is, INCLUDING the quotes:

C:\Windows\System32\cmd.exe /c start "realMyst DX9.0" "C:\Program Files (x86)\Steam\SteamApps\common\realMyst Masterpiece Edition\realMyst.exe" -force-d3d9 -dxlevel90

If you want to know the runstring parameters for the "start" command, open a command prompt and type "start /?" and it will list the options.

I think that it is obvious that the Myst program has some timing issues with certain machines and certain display cards. So this worked for me. Hopefully the Cyan folks will figure out a better patch. The new Myst graphics are so excellent! I really enjoy playing it over and over.
Colonel Sanders Mar 16, 2014 @ 11:40am 
Throwing in my weight here with the stationary mouselook issue. It really breaks immersion. Please, please implement standard FPS mouselook. I'm tired of holding down right-click, and I don't particularly like the idea of having to fix this myself using AHK scripts/taping it down/etc.

As for performance, I'm running a 3.6ghz Phenom 955 and 3gb Radeon 7950 and I get around 40-50 FPS with maximum settings at 1920x1080. I'm not surprised to see how bad the performance is - most unity games perform about this well in my experience. Not a huge deal, I just dial back my settings. What really drives me nuts is how dark it gets, even with bloom off. Can we get a brightness slider? I'd submit a more official report in a better place, but Cyan forums seem kinda dead...
Mars Mar 23, 2014 @ 10:55am 
Still no 3D Vision support.. :(
< >
Showing 1-15 of 36 comments
Per page: 15 30 50