IronMonkeyJnr Nov 10, 2013 @ 8:39am
G27 - H Shifter not working in game?
I'm slightly curious, but my H-Shifter doesn't seem to be working in-game? I'm not entirely sure if i'm missing something but during the configuration setup, it seems to be fine, I can even see the buttons click/move on the shifters screen.

My paddles seem to work flawlessly, I've checked 'Use Seperate Shifter' box, to see if that would produce a different outcome but nope, nothing. Any suggestions as to what I'm doing wrong?..

Cheers!
Showing 1-10 of 10 comments
< >
Polly Nov 10, 2013 @ 9:18am 
You need to drive a car without flappy paddles like the X-bow, old M3 or lotus.
Tam Esox71 Nov 10, 2013 @ 9:21am 
tick use separate shifter.
Evilsmurf Nov 10, 2013 @ 10:11am 
Originally posted by esox71:
tick use separate shifter.


This

It's in the wheel set up options
Last edited by Evilsmurf; Nov 10, 2013 @ 10:11am
gstercken Dec 5, 2013 @ 10:46pm 
Same problem here.
  • I have used the presets for the G27 with separate H-shifter.
  • The option "Use separate shifter" is checked.
  • When running the controls wizard, the manually selected gears are working jut fine.
  • I'm using cars without automatic gear (I've tried Lotus Elise SC and BMW M3 E30)
However, when on the Practice track, the H-shifter has no effect on the car, only the shift up/down paddles work.

Any ideas? Has anyone been able to make manual shifting work, or is it not yet implemented?
Last edited by gstercken; Dec 5, 2013 @ 10:47pm
banzai bill Dec 5, 2013 @ 11:10pm 
Originally posted by gstercken:
Any ideas? Has anyone been able to make manual shifting work, or is it not yet implemented?

For me it works without any issues.

Only idea I have is to check your driving assists.
Maybe something is activatet that creates complications (Autoclutch?)
gstercken Dec 5, 2013 @ 11:34pm 
Originally posted by banzai bill:
Only idea I have is to check your driving assists.
Maybe something is activatet that creates complications (Autoclutch?)

Yep, just found out that in addition to all of the above, you have to go to the Realism/Assists settings and disable the Autoshift (and, optionally, Autoclutch) options. They are enabled by default in the "Gamer" profile.

Wow, driving with manual shift feels so realistic, and gives you so much more control!

Thanks!
Last edited by gstercken; Dec 5, 2013 @ 11:34pm
TheDyingScotsman Dec 6, 2013 @ 2:09am 
H-shifter works perfectly. No issue.
SeriousSpy Dec 6, 2013 @ 2:15am 
Try using the Controller Wizard or whatever it's called, try to set it up from there.
Herbaceous Dec 6, 2013 @ 8:23am 
I had a similar problem, but it appeared to be because I still had my X-Box controller plugged in. I also had issues with reverse axis while configuring, which I didn't have when I 1st installed the sim. Teething problems I guess :) Eventually I got it working.
gstercken Dec 6, 2013 @ 10:55am 
Thanks, but like what I said, it's resolved now. :) In order to use manual shift, 3 requirements must be met:

  • Under Options/Controls/Shifters: Make sure that "Use Separate Shifter" is checked and the gears assigned
  • Select a car that has manual shift (e.g. Lotus Elise SC or BMW M3 E30)
  • Under Drive/Realism/Assists, make sure that "Automatic Gearbox" and "Automatic Clutch" are disabled.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Nov 10, 2013 @ 8:39am
Posts: 10