Aquaria > Algemene discussies > Details van topic
somnolentsurfer 1 okt 2012 om 4:53vm
No Mac version?
Well, as the title says really. :-( I've just been playing Spelunky, which reminded me I own this from an old Humble Bundle and had never played it. Would prefer to play through Steam if I could.
1-15 van 31 reacties weergegeven
< >
RH' NBlast 2 okt 2012 om 12:48vm 
This is a quite old game. Both creators are now busy on their own, new projects. It's very unlikely that something in the game will change. You need to use DRM-Free copy from the HIB if you want play on your Mac.
somnolentsurfer 2 okt 2012 om 6:31vm 
Yeah, I know. :-( But it was worth a shot. I crave achievments.

Otherwise I guess I just keep hoping for a multi-format release of Spelunky HD. :-)
Laatst bewerkt door somnolentsurfer; 2 okt 2012 om 6:32vm
somnolentsurfer 12 okt 2012 om 5:01nm 
Huh. Since posting this thread, Aquaria seems to have appeared in the Mac Games list in my library. Got all excited and was about to post to thank someone for having noticed. Then I tried to play it ance got told the game is "currently unavailable ( invalid application configuration )."
RH' NBlast 14 okt 2012 om 1:13vm 
Or maybe something is in works? Hmmm...
somnolentsurfer 14 okt 2012 om 10:10vm 
Here's hopeing.
Sstavix 16 okt 2012 om 11:18nm 
I hope so, too. I'm in the same boat (so to speak...). I'd love to rack up some more achievements with this great game!
Madd the Sane 17 okt 2012 om 6:07nm 
There is a similar issue with Shank: Downloads nothing and won't launch. Both games came from HiBs, so there are Mac versions available. Whether they feel the need to port that to Mac Steam is another issue.
saneman 25 nov 2012 om 6:27nm 
Aquaria is available for Mac as of this post on 25 Nov, 2012.
somnolentsurfer 25 nov 2012 om 7:00nm 
You tested it? I still get the same error described above.
Duanetastic 19 dec 2012 om 7:09nm 
Why is the Linux version on Steam, but the Mac version still isn't?
horsefd 20 dec 2012 om 2:39vm 
This is strange. It's listed as a "Mac game" in Steam on my Mac, but when I try to install it, it installs instantaneously, and then (obviously) fails to launch.
Laatst bewerkt door horsefd; 20 dec 2012 om 5:57vm
somnolentsurfer 20 dec 2012 om 5:19vm 
Yeah, that's the same problem I'm having. It's listing as a Mac game in the library, but doesn't install properly. And the store page is now showing the Steam Play logo, but only with a window and a penguin. :-(
horsefd 20 dec 2012 om 5:57vm 
Did it use to work on OS X on Steam? I can't remember if I played it on Mac or Windows.
Madd the Sane 20 dec 2012 om 11:39vm 
To my knowledge, there hasn't been a Mac Steam version. There are two Mac versions: One from Ambrosia Software, another from the HIB ported by (IIRC) Icculus.
somnolentsurfer 20 dec 2012 om 11:43vm 
Two different people have ported it? That just seems a waste of effort.
1-15 van 31 reacties weergegeven
< >
Per pagina: 15 30 50