Aquaria > General Discussions > Topic Details
somnolentsurfer Oct 1, 2012 @ 4:53am
No Mac version?
Well, as the title says really. :-( I've just been playing Spelunky, which reminded me I own this from an old Humble Bundle and had never played it. Would prefer to play through Steam if I could.
Showing 1-15 of 31 comments
< >
RH Inż. NBlast Oct 2, 2012 @ 12:48am 
This is a quite old game. Both creators are now busy on their own, new projects. It's very unlikely that something in the game will change. You need to use DRM-Free copy from the HIB if you want play on your Mac.
somnolentsurfer Oct 2, 2012 @ 6:31am 
Yeah, I know. :-( But it was worth a shot. I crave achievments.

Otherwise I guess I just keep hoping for a multi-format release of Spelunky HD. :-)
Last edited by somnolentsurfer; Oct 2, 2012 @ 6:32am
somnolentsurfer Oct 12, 2012 @ 5:01pm 
Huh. Since posting this thread, Aquaria seems to have appeared in the Mac Games list in my library. Got all excited and was about to post to thank someone for having noticed. Then I tried to play it ance got told the game is "currently unavailable ( invalid application configuration )."
RH Inż. NBlast Oct 14, 2012 @ 1:13am 
Or maybe something is in works? Hmmm...
somnolentsurfer Oct 14, 2012 @ 10:10am 
Here's hopeing.
Sstavix Oct 16, 2012 @ 11:18pm 
I hope so, too. I'm in the same boat (so to speak...). I'd love to rack up some more achievements with this great game!
Madd the Sane Oct 17, 2012 @ 6:07pm 
There is a similar issue with Shank: Downloads nothing and won't launch. Both games came from HiBs, so there are Mac versions available. Whether they feel the need to port that to Mac Steam is another issue.
saneman Nov 25, 2012 @ 6:27pm 
Aquaria is available for Mac as of this post on 25 Nov, 2012.
somnolentsurfer Nov 25, 2012 @ 7:00pm 
You tested it? I still get the same error described above.
Duanetastic Dec 19, 2012 @ 7:09pm 
Why is the Linux version on Steam, but the Mac version still isn't?
berrrnard Dec 20, 2012 @ 2:39am 
This is strange. It's listed as a "Mac game" in Steam on my Mac, but when I try to install it, it installs instantaneously, and then (obviously) fails to launch.
Last edited by berrrnard; Dec 20, 2012 @ 5:57am
somnolentsurfer Dec 20, 2012 @ 5:19am 
Yeah, that's the same problem I'm having. It's listing as a Mac game in the library, but doesn't install properly. And the store page is now showing the Steam Play logo, but only with a window and a penguin. :-(
berrrnard Dec 20, 2012 @ 5:57am 
Did it use to work on OS X on Steam? I can't remember if I played it on Mac or Windows.
Madd the Sane Dec 20, 2012 @ 11:39am 
To my knowledge, there hasn't been a Mac Steam version. There are two Mac versions: One from Ambrosia Software, another from the HIB ported by (IIRC) Icculus.
somnolentsurfer Dec 20, 2012 @ 11:43am 
Two different people have ported it? That just seems a waste of effort.
Showing 1-15 of 31 comments
< >
Per page: 15 30 50

Aquaria > General Discussions > Topic Details